11-11-17 12:33 PM
96 1234
tools
  1. aullak's Avatar
    My passport died over the course of 32 hours. It seems like the phone was suffering from a physical issue rather than software. Finally the phone would not connect to a cellular network. WiFi was still perfect. The phone was 2-3 years old heavy use. Considering getting a new one as repair seems unlikely. Using a Z10 in the meantime.
    Same issue I am also facing.

    Posted via CB10
    04-21-17 06:29 AM
  2. Mattster723's Avatar
    I'm wondering if it's just that after 3 years the hardware is wearing out. I know duh, but with the consistent upgrades and the phones heating up the components just break.
    Also those that have the issue, are you keeping the phone on 24 hours? I routinely turn mine off, cause there just a time I tell the world to get lost.
    So if you keep it on, even if idle, I would presume it wears on the parts.

    Posted via CB10
    04-21-17 07:17 AM
  3. Old_Mil's Avatar
    I was keeping mine on 24 hours but honestly this isn't an engine or something mechanical with moving parts. Extended on times shouldn't wear anything but the battery like that.
    04-21-17 08:17 AM
  4. wingnut666's Avatar
    scrape the sim slot and clean the sim.

    Posted via CBX
    04-21-17 04:09 PM
  5. Old_Mil's Avatar
    Done and replaced the sim. Didn't solve the problem.

    Preacher the only solution is to replace the phone. If you want to stay with bb10 I would look for a good used z30...
    04-22-17 05:57 AM
  6. preacher2b's Avatar
    I wonder if the cellular radio problem is related to the screen lift problem?

    For God so loved the world, that He gave His only begotten Son, that whosever believeth in Him shall not perish, but have everlasting life.
    04-23-17 08:14 AM
  7. Zeratul57's Avatar
    I would just get another Passport. Electronics break , that's how I see it.

    Sent from one of my SE Passports using BB10 superior software.
    04-24-17 08:49 AM
  8. nhatanh181's Avatar
    Quick question to whom has sos problem: did you use the device intensively that it get too hot right before the problem starts?

    Posted via Blackberry Passport
    04-25-17 09:35 AM
  9. aullak's Avatar
    Quick question to whom has sos problem: did you use the device intensively that it get too hot right before the problem starts?

    Posted via Blackberry Passport
    No it was on normal usage.

    Posted via CB10
    04-25-17 05:40 PM
  10. preacher2b's Avatar
    Normal usage as well.

    Posted via CB10
    04-25-17 06:25 PM
  11. leeiling's Avatar
    It is more like a radio- module, aka celluar- module, issue. No solution so far. I have had the same issue with my Passport No.1. I bought another Passport as daily drive.

    Posted via CB10
    04-25-17 07:48 PM
  12. kumbafu's Avatar
    Just got off the phone with T-Mobile. Tech talked about network upgrades and how that might be making them incompatible with T-Mobile's network.
    04-26-17 12:57 PM
  13. anon(679606)'s Avatar
    In my case it sometimes can connect to cell for 1-5 minutes. I can even make calls, but the most time the phone is useless. All this became a week ago. It worked perfectly before.

    Posted via CB10
    My daily is Priv. I have a voip (PhonePower) that offers a very good SIP android app that works on Passport... soo I can make calls from my home phone on Passport from anywhere on earth via wifi to anyone (USA & CA&Mex free unlimited and 1h each month free to 50+ countries and really cheap after...) works great... free Modem Hooks my home Phones to voip no computer needed at all (jumper in interface feeds to wired Phones & Wireless set too)... costs ~$7/mo but needs US address & 2 year contract ( pay first year in advance, 2 nd year free)...
    04-26-17 07:36 PM
  14. Cortizo5's Avatar
    I've got the same problem my passport doesn't connect to the network anymore, I ve had my passport working fine for 2 years and 3 months and last week this happened.

    Posted via CB10
    Last edited by Cortizo5; 04-27-17 at 09:52 AM.
    04-26-17 09:04 PM
  15. emanuel0ss0's Avatar
    I've had random dropped coverage on both my Passport and Classic. A toggle of the mobile network settings normally fixes it right up.

     Classically Posted SQC100-4/10.3.2.2876 
    04-26-17 11:13 PM
  16. kumbafu's Avatar
    This is happening when i'm indoors. Stepped outside and walked about 6 steps, got full reception. Although as soon as I tried to dial a number it loses all connection. Stop trying to dial, it goes back to 4 bars!
    04-27-17 12:32 PM
  17. wingnut666's Avatar
    likely a carrier issue. I switched providers and have service all the time now.

    Posted via CBX
    04-27-17 01:57 PM
  18. nhatanh181's Avatar
    This is happening when i'm indoors. Stepped outside and walked about 6 steps, got full reception. Although as soon as I tried to dial a number it loses all connection. Stop trying to dial, it goes back to 4 bars!
    Have you tried switch to 2g without data on?

    Posted via Blackberry Passport
    04-27-17 02:23 PM
  19. kumbafu's Avatar
    Just did. Doesnt work. Stuck on searching for network. Im on T-Mobile USA. There's been talk of upgrading towers and im wondering if this has anything to do with that.
    04-27-17 02:54 PM
  20. Chuck Finley69's Avatar
    Had similar type of problems with PRIV last year. At least BlackBerry supports Android. Probably best to move on to new phone supported by your carrier. Yes, that means IOS or Android. Doesn't have to be a BlackBerry, although I'm enjoying a PRIV and DTEK...
    04-27-17 02:59 PM
  21. wingnut666's Avatar
    if your provider doesnt support all the bands your passport does, its time to switch providers, not phones.

    Posted via CBX
    04-27-17 04:29 PM
  22. kumbafu's Avatar
    and just like that...we're back to perfect working order. no reboots, nothing done, but keep the phone in my pocket while i was outside for an hour and a half and everything's back to normal.
    04-27-17 08:07 PM
  23. anon(679606)'s Avatar
    ...phone guru in the pocket... do you offer such repairs to others for a small honorarium ?
    04-27-17 08:10 PM
  24. Cortizo5's Avatar
    Not a carrier issue i've got the same problem ans i'm un mexico

    Posted via CB10
    04-28-17 03:01 PM
  25. johnny_bravo72's Avatar
    if your provider doesnt support all the bands your passport does, its time to switch providers, not phones.

    Posted via CBX
    Should've done your due diligence with both your phone and provider.
    04-28-17 05:12 PM
96 1234

Similar Threads

  1. Battery problems
    By Pool5 in forum BlackBerry DTEK60
    Replies: 60
    Last Post: 08-10-17, 04:19 PM
  2. SIM problem FIXED
    By hbvideo in forum BlackBerry Priv
    Replies: 2
    Last Post: 03-01-17, 02:32 PM
  3. physical keyboard language problem
    By kikipintre in forum BlackBerry Priv
    Replies: 3
    Last Post: 03-01-17, 09:19 AM
  4. Problem with Yahoo email
    By VGagulin in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 03-01-17, 01:24 AM
  5. BlackBerry Classic problems with Miracast
    By Robert.Vincent in forum BlackBerry Classic
    Replies: 2
    Last Post: 02-27-17, 02:00 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.