05-03-17 09:47 PM
82 1234
tools
  1. mzampa's Avatar
    hi,
    I bought here in Italy a Dutsche BB Passport, after twenty day, suddenly lost all connectivy feature.
    don't recognize the networks of all operators and don't recognize wi-fi networks also.
    I reinstall a new rom, the last but without success.
    anyone can help me?
    maurizio
    03-07-17 03:32 AM
  2. Gvo1975's Avatar
    Here is what I was doing and it was working. Downgrade from 3G to 2G. Cellular network coverage will come back I am sure.

    No Junkroid on Steroids on my Passport
    03-07-17 08:53 AM
  3. Old_Mil's Avatar
    My phone can't connect to the cellular network for two days. It says that there is no signal, even if another phone here works fine. Two days ago everything worked perfectly . I haven't changed any settings. OS 10.3.2.2876 with same radio. Any ideas?
    Is it showing a red X or saying "emergency calls only"?

    A large number of passport users are experiencing this failure. It seems to happen independent of the passport model in question, version of the OS, or carrier.

    Nobody has figured out the cause other than it being hardware related.

    This is about the fifth thread discussing it. Sort of sad seeing how nice a device it is otherwise but given the design problem if you are looking for a bb10 device that will last a long time I don't know that the passport is it.
    PIERLUIGI AQUILINO likes this.
    03-07-17 09:41 AM
  4. Sam-Tech's Avatar
    Another new sim tried But the same outcome! Actually there was some progress, I had two issues intially. The phone was not detecting that a sim was present and not connecting to the network "Emergency Calls Only". Now in the settings the sim card info is there, But the phone still cannot connect to the network! I have to give the AT&T support people credit for trying. They just couldn't understand why it wasn't working. So I guess I'm a Zed-10 user for awhile.
    03-07-17 05:32 PM
  5. Drenegade's Avatar
    I told you. It's nothing to do with the sim card. It's a mysterious hardware issue. Likely antenna failure.

    I know how you feel though. After it happened to my Passport, I also went back to the Z10 for a few months. I actually started to like it. Nothing beats swapping out that removable battery. Even if sometimes it's gotta be done three times a day, haha.

    I found another AT&T Passport for sale and snatched it up. Been working good since August now so fingers crossed it holds up. Not sure what I'll do if this one gets the emergency calls only disease. Maybe a Pixel XL.

    Posted via CB10
    03-07-17 09:29 PM
  6. Sam-Tech's Avatar
    I don't see how it could be an antenna issue, I had plenty of signal, But in my case it was partially a sim issue. The new sim is recognized as being in the slot verified by the "Blackberry Virtual Expert" app.

    This was posted to the Blackberry support forum today :

    "I just had another conversation with BlackBerry help on Twitter and they say it is a known issue with hardware and to return it to the carrier. They are all off warranty and in some cases we are not with the original carrier. So, long story short, it will never be fixed by BlackBerry".

    So, I'll be on the Z10 until I decide what to do. Thanks
    03-08-17 12:11 AM
  7. Drenegade's Avatar
    I don't see how it could be an antenna issue, I had plenty of signal, But in my case it was partially a sim issue. The new sim is recognized as being in the slot verified by the "Blackberry Virtual Expert" app.

    This was posted to the Blackberry support forum today :

    "I just had another conversation with BlackBerry help on Twitter and they say it is a known issue with hardware and to return it to the carrier. They are all off warranty and in some cases we are not with the original carrier. So, long story short, it will never be fixed by BlackBerry".

    So, I'll be on the Z10 until I decide what to do. Thanks
    Pretty much as expected. They're not going to honor warranties on 3 year old devices that won't provide revenue. That's bad business.

    Posted via CB10
    03-08-17 12:29 AM
  8. Sam-Tech's Avatar
    I'm smelling a conspiracy here! All of a sudden, all these devices are having problems? I better run and get my Tin Foil Hat on.
    03-08-17 12:32 AM
  9. unclebanglin's Avatar
    it does seem odd that it has happened to so many people all at once...

    the PP was a small batch device. i guess they were all manufactured in the same window, so they are all roughly the same age...so the thinking goes they are just starting to fail.

    what i don't understand is why the issue (for me at least) is isolated to phone calls. i can access data and every now and then get a text, even though im not on wifi and texts don't come via wifi anyways
    03-08-17 01:22 PM
  10. wingnut666's Avatar
    I just figured something out! if you put the wrong APN under network settings....surprise! you get the no svc/emergency calls only prize!
    to solve this issue (with my provider, ymmv) I just hit load apn defaults, then go into and out of airplane mode...and we're back. try it!

    Posted via CBX
    03-08-17 09:55 PM
  11. kunz1925shooter's Avatar
    I just figured something out! if you put the wrong APN under network settings....surprise! you get the no svc/emergency calls only prize!
    to solve this issue (with my provider, ymmv) I just hit load apn defaults, then go into and out of airplane mode...and we're back. try it!

    Posted via CBX
    Sad to say it does not work on my passport...

    Posted via CB10
    03-09-17 01:05 AM
  12. kunz1925shooter's Avatar
    I was wondering, does really affects all passports? Even the SE? Thanks in advance....

    Posted via CB10
    Last edited by kunz1925shooter; 03-09-17 at 02:24 AM.
    03-09-17 01:07 AM
  13. Old_Mil's Avatar
    As best as I can tell this is an issue that affects all passports.
    03-18-17 10:54 PM
  14. wingnut666's Avatar
    i'd say this issue affects very few passports. i've had 3 with no hardware issues...if there is a hardware problem it must be very rare. there are exponentially more posts about passport love than there are about problems..

    Posted via CBX
    03-19-17 06:56 PM
  15. nhatanh181's Avatar
    I've been 3 months with black passport. Signal is fine.

    Posted from BlackBerry Passport.
    03-19-17 07:06 PM
  16. LazyTabbyCat's Avatar
    I've been 3 months with black passport. Signal is fine.

    Posted from BlackBerry Passport.
    Almost year with black passport. Everything were fine but...
    Still no signal

    Posted via CB10
    03-19-17 11:18 PM
  17. Old_Mil's Avatar
    Everything is fine until one day it isn't fine anymore.
    03-19-17 11:24 PM
  18. unclebanglin's Avatar
    Everything is fine until one day it isn't fine anymore.
    yeah i also didn't have a problem ... until i had THE problem
    03-20-17 10:08 AM
  19. Old_Mil's Avatar
    Bump.
    03-25-17 02:03 PM
  20. krazyatom's Avatar
    Got a different carrier sim to try?
    I got both att unlocked and Og passport with tmobile no problem.

    Posted via CB10
    03-25-17 02:53 PM
  21. Old_Mil's Avatar
    Changing the sim to a new t-nobile sim, or a friend's att sim didn't cure mine.

    I did wonder if there is a difference in the failure rate for those who carry the device in a pant / jean pocket vs carrying it in a purse or suit jacket pocket...perhaps somehow stressing the frame/antenna while sitting down.

    However my wife's is developing the same problem and she carries hers in her purse.
    03-26-17 09:38 AM
  22. germanib's Avatar
    I had to replace my passport for an android phone honor 5c, sad! I miss blackberry
    Last edited by germanib; 03-31-17 at 06:28 AM.
    03-31-17 02:38 AM
  23. kbalaz's Avatar
    Ive seen this on 2 Passport models and my 3rd does it intermittently. Lose signal a few seconds but it comebacks, hoping it doesn't go to permanent but I feel it is coming. I had 2 passports, one worked fine, the other had the 'emergency calls only' issue. I swapped the motherboard out of working model and put it into model that wasn't working and it worked fine. So, the problem lies on the motherboard somewhere.
    03-31-17 08:11 AM
  24. preacher2b's Avatar
    It was all fine until it wasn't. Today I get 'Emergency Calls Only'; Voice only; or great coverage. Replaced SIM card - no charge, and no change.

    PassportSQW100-1/10.3.3.2049

    Ugh!

    For God so loved the world, that He gave His only begotten Son, that whosever believeth in Him shall not perish, but have everlasting life.
    04-20-17 12:21 PM
  25. Just Me's Avatar
    My passport died over the course of 32 hours. It seems like the phone was suffering from a physical issue rather than software. Finally the phone would not connect to a cellular network. WiFi was still perfect. The phone was 2-3 years old heavy use. Considering getting a new one as repair seems unlikely. Using a Z10 in the meantime.
    04-20-17 01:41 PM
82 1234

Similar Threads

  1. Battery problems
    By Pool5 in forum BlackBerry DTEK60
    Replies: 47
    Last Post: 04-19-17, 04:28 PM
  2. SIM problem FIXED
    By hbvideo in forum BlackBerry Priv
    Replies: 2
    Last Post: 03-01-17, 01:32 PM
  3. physical keyboard language problem
    By kikipintre in forum BlackBerry Priv
    Replies: 3
    Last Post: 03-01-17, 08:19 AM
  4. Problem with Yahoo email
    By VGagulin in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 03-01-17, 12:24 AM
  5. BlackBerry Classic problems with Miracast
    By Robert.Vincent in forum BlackBerry Classic
    Replies: 2
    Last Post: 02-27-17, 01:00 PM
LINK TO POST COPIED TO CLIPBOARD