1. hoopitz's Avatar
    So I've noticed that when i'm finishing up a phone call, and pull the phone away from my ear, the screen doesn't automatically come on. This is my second Passport (had to send the first one back for a screen issue), but I recall that this worked properly on my first Passport before it got sent back.

    I ran a BBVE test on the Proximity Sensor and something odd is happening. When the phone is standing up perfectly straight, the sensor works, and can tell the difference between "near" and "far." Once I tilt the phone backwards or forwards more than 10 degrees or so, the sensor reads "near" even though nothing is in front it.

    Can someone check whether or not this is happening to them? I'm afraid I've got a hardware issue on my hands.

    Thanks!
    04-08-15 04:35 PM
  2. xandros9's Avatar
    You've probably got a hardware issue on your hands. I don't think its a quirk inherent to the Passport that has some simple software fix. Although you're probably going to want to try to restore/reset the device to rule out software.

    Over at Windows Central, a malfunctioning proximity sensor isn't exactly rare either.
    04-08-15 05:22 PM
  3. mad_mdx's Avatar
    Just tested mine. There is no change when I tilt the phone. Regardless of angle, it says far unless something is close to it.

    Try a hard reboot first (both volume keys) and rerun bbve, if it's still bad, warranty time.
    04-08-15 06:22 PM
  4. mad_mdx's Avatar
    Just tested mine. There is no change when I tilt the phone. Regardless of angle, it says far unless something is close to it.

    Try a hard reboot first (both volume keys) and rerun bbve, if it's still bad, warranty time.
    As far as not coming back on during the end of a call, I noticed that happens too but I don't think it's related to the proximity sensor as even swiping up doesn't work right away, almost like a lag.
    04-08-15 06:23 PM
  5. hoopitz's Avatar
    Just tested mine. There is no change when I tilt the phone. Regardless of angle, it says far unless something is close to it.

    Try a hard reboot first (both volume keys) and rerun bbve, if it's still bad, warranty time.
    Thanks. Mine definitely is faulty. I suppose I can try a OS reload before I go for a warranty claim. Already tried a hard reset holding the volume keys.

    Posted via CB10
    04-08-15 11:44 PM
  6. amateure's Avatar
    May bee a problem with your screen protector whenever you've got one on your phone?

    Posted via CB10
    04-09-15 04:46 AM
  7. kenicolo's Avatar
    BVE said it failed but I rebooted my PP and it was working perfectly


    Posted via CB10
    04-10-15 10:27 AM
  8. rdjohnson's Avatar
    I'm having the same issue with my Passport. It's real spotty in BBVE too. Sensor results depend on how the device is tilted. I've spent over a day trying to resolve the issue and will reluctantly send it in for warranty replacement, or give up on the Passport altogether.
    05-01-15 08:09 PM
  9. RLTurn77's Avatar
    So I've noticed that when i'm finishing up a phone call, and pull the phone away from my ear, the screen doesn't automatically come on. This is my second Passport (had to send the first one back for a screen issue), but I recall that this worked properly on my first Passport before it got sent back.

    I ran a BBVE test on the Proximity Sensor and something odd is happening. When the phone is standing up perfectly straight, the sensor works, and can tell the difference between "near" and "far." Once I tilt the phone backwards or forwards more than 10 degrees or so, the sensor reads "near" even though nothing is in front it.

    Can someone check whether or not this is happening to them? I'm afraid I've got a hardware issue on my hands.

    Thanks!
    From memory, I did get a Z30 during the spring sale and of course the first thing I do is BBVE. When I tested the proximity sensor the device was laying flat with the screen up (obviously).

    Also, regardless of angle the screen on my Passport goes on and off during a phone call depending on how close I have it to my ear. Weird issue.

    Posted via CB10
    05-01-15 08:35 PM
  10. hoopitz's Avatar
    I'm having the same issue with my Passport. It's real spotty in BBVE too. Sensor results depend on how the device is tilted. I've spent over a day trying to resolve the issue and will reluctantly send it in for warranty replacement, or give up on the Passport altogether.
    Sorry that you're having the issue as well. I got a replacement, and all is good now - hope you're in the same boat.
    letrantrung likes this.
    05-15-15 01:10 PM

Similar Threads

  1. Swipe to wake test
    By siung6 in forum BlackBerry Passport
    Replies: 44
    Last Post: 04-20-15, 12:25 AM
  2. Can one roll back voice notes in increments?
    By Phil Pense in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 04-08-15, 08:21 PM
  3. Cracked my screen, who can fix ?
    By MarkWebsterJr in forum BlackBerry Classic
    Replies: 1
    Last Post: 04-08-15, 06:29 PM
  4. How can I transition from 9900 to Classic with Outlook 2013?
    By CrackBerry Question in forum BlackBerry Motion
    Replies: 1
    Last Post: 04-08-15, 03:53 PM
  5. Replies: 2
    Last Post: 04-08-15, 12:04 PM
LINK TO POST COPIED TO CLIPBOARD