1. hobcarroll's Avatar
    Hello - newbie to BlackBerry here. Quite a bit of experience with Android and Windows phones, but nothing with BB system of any kind. I really like the build and "structure" of the Passport, but still trying to get some things to "work" for me before making my final decision to keep or return it.
    Currently, my hot issue is that I have just realized (I think) that I cannot "click" or touch a web link, page, address that is within an email message I am reading, and have it open my browser, and go to it. I have tried everything I can think of (which given the naive nature of my BB experience probably doesn't say much) to find a setting anywhere in Hub settings, account settings, general device settings, etc., that causes this obvious function to be blocked or simply not work. I am sure there is something silly I am just missing, because I cannot believe this is not something that is a requirement of just about any user out there, so I am definitely missing something. Can anyone guide me towards how to get this to work? Or is it possible that it is just not doable and BB people use some other technique to go to the web from inside an email? I appreciate it. Thanks for having probably the best user interchange for devices/software that is out there.

    Additional: first answer suggested that when I click on a link, a "contextual menu" should be popping up. I guess that is my problem, I don't get that. I have tried in different email accounts within Hub, and different emails, with different kinds of "links" to web sites, and nothing happens. No menu pops up, not even a flicker. I have held it for short times, long times, double tap, whatever. Clearly, based on the answer recommending the Hub Browser option, I am supposed to get a contextual menu in the first place, but somehow I have blocked that or something is blocking it, or I need to "reinstall" the Hub app? Thanks for any continued interest in my issue.
    Last edited by hobcarroll; 01-12-15 at 09:59 PM. Reason: First Answer pointed to possible other problem
    01-12-15 09:19 PM
  2. Tim_treo's Avatar
    Clicking on a link should open the browser I believe. I can't tell you for certain because I installed the 'Hub Browser' app which is designed to complement the Passport native browser. Now when I click on a link in a an email Hub Browser opens it and I can return immediately to the hub by hitting the back button. You may want to check it out in the BlackBerry app store.

    Posted via CB10
    01-12-15 09:30 PM
  3. hobcarroll's Avatar
    Hi Tim_treo, and thank you for spotting my question. I actually have purchased the Hub Browser, but only after I installed it and read the directions did I even see the reference to the "contextual menu" that is apparently supposed to have been popping up in the first place. That appears to be my problem. I guess I used a lot of words without actually describing with the proper lingo what my problem was. Any ideas on how to make the menu come back when I press the "link" inside the email? Thanks.
    01-12-15 10:01 PM
  4. trigger1074's Avatar
    Have you checked your default apps and see if you selected browser as default? Reset default apps and see if when you long press a link in browser it gives you the option to select hub browser to open

    Posted via CB10
    01-12-15 10:08 PM
  5. hobcarroll's Avatar
    That was an idea I had not tried. However, (1) there are no default apps listed at all; (2) it says "to set a default app for a specific content or file types, touch and hold a file or content. Tap Open in and select the app......." but as I have explained, touching an holding down a web link within an email does not bring up such a menu in the first place; and (3), there is the option to "reset defaults" to factory settings at the bottom, but when I do that, it just comes back with a blank page - i.e., no default apps, and just in case resetting fixed the issue without showing anything, I went back to see if the email web links worked, and still nothing happens. Is there some way I have damaged or blocked this feature within the OS? I admit that I have side loaded some stock android stuff.
    01-12-15 10:54 PM
  6. hobcarroll's Avatar
    PS -thanks for the input!
    01-12-15 10:54 PM
  7. eldrover's Avatar
    I'm running a Z10 with 10.3.1. I have no trouble opening web links from the Hub. I simply tap the link and it opens in browser.

    If the link is located within a portion of text, it should show up as a blue hyperlink.

    If it isn't for you, it sounds like an software issue that may require an OS reinstall to clean up.

    Posted via CB10
    01-13-15 10:55 AM
  8. homer1475's Avatar
    I'm running a Z10 with 10.3.1. I have no trouble opening web links from the Hub. I simply tap the link and it opens in browser.

    If the link is located within a portion of text, it should show up as a blue hyperlink.
    This is exactly how my passport works, and every other BB Ive owned in the past.

    Hyperlinks show up as blue text, click the blue text and it opes the browser to the correct link. Even my Z10 back on original 10.0.0.xxxx OS worked this way.
    01-13-15 11:00 AM
  9. hobcarroll's Avatar
    Hi - and thanks to everyone for their input. I had apparently done something to mess up the Hub's ability for me to click on or touch a link and have the menu pop up. It didn't work and didn't work, I tried every setting I could find on the phone. At the end, I got rid of some "google" apk apps, backed up, and did a factory wipe and clean, starting over. The menus were back just like everyone said they should be there, and I was careful in backing up to not mess with some of the "get google play services and app store" side loads to avoid any complications, and it has been working find for two days now. Thanks to everyone contributing, I appreciate your time and ideas.
    01-14-15 08:43 PM
  10. hobcarroll's Avatar
    Now realize this has been handled in another discussion and the answer has to do with having had the magnifier on, it interferes with the hyperlinks. They need to allow both at same time, but at least I know what it was and can fix it easily now. Thanks all.

    Posted via CB10
    01-22-15 10:33 AM
  11. ChapiNaples's Avatar
    I was having the same issue, and you reminded me I had enabled the magnifier.
    01-27-15 03:46 PM

Similar Threads

  1. Where can I buy BlackBerry Clothing?
    By roelens1 in forum General BlackBerry Discussion
    Replies: 98
    Last Post: 09-03-16, 09:02 PM
  2. Anyone switch from the passport to classic?
    By kevinbarrsie in forum BlackBerry Classic
    Replies: 96
    Last Post: 01-31-15, 08:07 PM
  3. BBM Save Chats to SD Card?
    By ThePoisonBerry in forum BlackBerry Passport
    Replies: 4
    Last Post: 01-16-15, 12:00 PM
  4. Display font size not apply to all apps?
    By KhalidAznawi in forum BlackBerry Passport
    Replies: 2
    Last Post: 01-12-15, 10:46 PM
  5. Replies: 1
    Last Post: 01-12-15, 06:49 PM
LINK TO POST COPIED TO CLIPBOARD