1. Smokeaire's Avatar
    The BT connection between my Passport and Legend keeps dropping. The connection may last for an hour or so, might last 5 minutes. Sometimes it will reconnect on its own, sometimes not. It I turn off then on the Legend will reconnect, sometimes not. It very frustrating when I'm driving. It never disconnects during a call. I've reset the BT stack many times but that hasn't solved the issue.
    This was never a issue with my old Note2.
    Is this a BB10 issue and will be addressed With the new update due out soon, or is this a inherent problem with the Passport?
    Any known solutions? Thanks.
    02-04-15 06:20 AM
  2. Coach101's Avatar
    I have a legend and it works without issue. The only time it will disconnect is if I move out of range. Are they you running the stock OS or a leak?

    Posted via CB10
    Smokeaire likes this.
    02-04-15 06:33 AM
  3. Smokeaire's Avatar
    I have a legend and it works without issue. The only time it will disconnect is if I move out of range. Are they you running the stock OS or a leak?

    Posted via CB10
    I'm running stock. I believe in some other thread (I searched but couldn't find it) I read of someone having a BT Passport issue and and a exchange for a new one solved the problem. I really would prefer not having to return the phone to Amazon for another if it is a OS cause.

    Sent using my BlackBerry Passport
    02-04-15 07:15 AM
  4. weedb0y's Avatar
    No issues here with plantronic legend and passport. I did have the previous legend BT started to gave hiccups. Plantronics replaced the unit for me

    Posted via Passport.
    Smokeaire likes this.
    02-04-15 07:43 AM
  5. Smokeaire's Avatar
    No issues here with plantronic legend and passport. I did have the previous legend BT started to gave hiccups. Plantronics replaced the unit for me

    Posted via Passport.
    Contacting Plantronics may be something I will have to do. I did delete the Legend, reboot the Passport to reset the BT stack (again). So far it didn't disconnect during my 45 minute commute. I'll see what happens on the commute home.
    Thanks for the advice.

    Sent using my BlackBerry Passport
    02-04-15 08:47 AM

Similar Threads

  1. Issues with my Outlook account
    By rvillanu77 in forum BlackBerry 10 OS
    Replies: 37
    Last Post: 02-21-15, 10:20 PM
  2. Bluetooth doesn't receive files in Q5
    By 16prabu in forum BlackBerry Q5
    Replies: 5
    Last Post: 02-08-15, 02:24 PM
  3. Internet connectivity problem
    By karswarnava in forum Ask a Question
    Replies: 1
    Last Post: 02-04-15, 10:09 PM
  4. Having weird issues loading 10.3.1.2072 onto Z30
    By cracked1up in forum BB10 Leaked/Beta OS
    Replies: 10
    Last Post: 02-03-15, 08:14 PM
  5. Issue with device automatically going to the HUB
    By Brad Mavin in forum BlackBerry Classic
    Replies: 2
    Last Post: 02-03-15, 03:58 PM
LINK TO POST COPIED TO CLIPBOARD