1. ariens's Avatar
    Recently my passport has started losing its signal...the signnal drops and keeps on fluctuating very much...anyone facing the same problems.

    Posted via CB10
    07-24-16 07:01 AM
  2. jaydee5799's Avatar
    what OS are you running? Has anything changed with your provider or your signal?
    07-24-16 07:22 AM
  3. StoicEngineer's Avatar
    I had a similar problem. The cure was to simply turn off the PPSE and restart. Turning WiFi radios off & on did the same trick.

    [It was/is usual for me to keep my phone on for weeks while travelling through hundreds of WiFi router regions. Typically, I would use 6 to 10 different networks per week and always at least 2 each day.]

    Posted via CB10
    07-24-16 12:34 PM
  4. leedium's Avatar
    This JUST started happening to me with my first gen Passport. Could it be something carriers have deployed that requires a software update on Blackberry's side?
    07-24-16 01:36 PM
  5. Drenegade's Avatar
    Also happened with my AT&T Passport. Hardware failure? Seems very common now. It's sad.

    Posted via CB10
    07-24-16 02:16 PM
  6. ariens's Avatar
    Nothing has changed about my carrier...I'm using the Sim on android device and it's working just fine...sometimes. I lose complete signal on my passport and have to restart it.

    Posted via CB10
    07-29-16 06:32 AM
  7. allsportsfan's Avatar
    No issues with my se

    Posted via CB10
    07-30-16 09:38 AM
  8. Sai Gannavaram's Avatar
    I too faced a similar issue , but then I rebooted the device once and the problem was solved

    Posted via the CrackBerry App for Android
    07-31-16 04:46 AM
  9. PG_Passport's Avatar
    I experienced the same with first generation Passport. I got crazy and bought a new SE which fixed the problem....or not? Sometimes it occurs again with SE. I have also tries to change Sims. No effect. Old Sim works fine in iPhone . So it's not the Sim. Carrier doesn't have a clue either. They say the reception of signal in my area is excellent.

    Posted via CB10
    07-31-16 05:35 AM
  10. johnyberry's Avatar
    The same thing just started happening to me. I've had my passport for about a year with no issues. Nothing has changed with my provider. WIFI still works great. Thought maybe I changed a setting by accident or requires some kind of update.
    08-02-16 10:57 AM
  11. johnyberry's Avatar
    I've tried the usual restart and off/on stuff. Still nothing.
    08-02-16 11:18 AM
  12. Farzeen25's Avatar
    Never had such an issue with my piano black passport. I have heard the PPSE has stronger antennas, so there is no reason for that to happen.

    Posted via CB10
    08-02-16 11:57 AM
  13. ariens's Avatar
    I don't know but it is very annoying...I'm losing signal now and then and a red Cross is displayed...please help

    Posted via CB10
    08-02-16 12:44 PM
  14. leedium's Avatar
    Just replaced the antenna unit with a new one. Same issue. Tried my SIM in an iphone 5, worked. Tried my buddy's SIM in my passport no, signal.

    Walking around the city, the signal goes in and out from 2 to 4G.

    Is this a software issue?

    Does anyone have a working Passport in the Amsterdam Area, Netherlands?
    08-03-16 11:35 AM
  15. Drenegade's Avatar
    Just replaced the antenna unit with a new one. Same issue. Tried my SIM in an iphone 5, worked. Tried my buddy's SIM in my passport no, signal.

    Walking around the city, the signal goes in and out from 2 to 4G.

    Is this a software issue?

    Does anyone have a working Passport in the Amsterdam Area, Netherlands?
    Interesting that replacing the antenna unit didn't fix it. Did you replace it yourself or send it to a repair shop? I haven't been able to find replacement antenna parts. I'd be skeptical if a shop told you they replaced it.

    But if you did it yourself then yeah. It's a good sign that it isn't physical damage. So weird that this is happening to our passports.

    Posted via CB10
    08-03-16 12:05 PM
  16. PG_Passport's Avatar
    @leedium: yes. I did experience the same thing in Amsterdam. After a few days I decided to buy a new one. The SE. Works fine. Probably something wrong with the handset. Didn't have the time to find out what is was. The Passport is a productivity machine, so no time for outage . Hope BlackBerry is creating a good keyboard successor later this year on Android. Otherwise the Passport is the best handset forever. I didn't throw the old one away. Maybe it can be repaired...

    Posted via CB10
    08-04-16 08:24 AM
  17. leedium's Avatar
    Interesting that replacing the antenna unit didn't fix it. Did you replace it yourself or send it to a repair shop? I haven't been able to find replacement antenna parts. I'd be skeptical if a shop told you they replaced it.

    But if you did it yourself then yeah. It's a good sign that it isn't physical damage. So weird that this is happening to our passports.

    Posted via CB10

    Yes, I actually ordered it from a shop here in Netherlands and replaced it myself(was out of warranty). It's quite easy to do. Same issue. The closer I get into the Center of the city.. and I already live in the center, the better the reception and service. So I know if both the old and new antenna's are having the same issue it must be something else. It can't be the SIM because at certain points I do connect to the carrier (Vodafone) and I get 4G,3G,2G,E service. In my own home I get nothing.

    This is super frustrating. I've only had this phone for two years. I will be getting another one, but man, don't want to buy used, and full price is well, full price.
    Last edited by leedium; 08-04-16 at 02:21 PM. Reason: adding reference
    08-04-16 02:17 PM
  18. leedium's Avatar
    @leedium: yes. I did experience the same thing in Amsterdam. After a few days I decided to buy a new one. The SE. Works fine. Probably something wrong with the handset. Didn't have the time to find out what is was. The Passport is a productivity machine, so no time for outage . Hope BlackBerry is creating a good keyboard successor later this year on Android. Otherwise the Passport is the best handset forever. I didn't throw the old one away. Maybe it can be repaired...

    Posted via CB10
    Hey PG, did you buy used or new? If so where did you get it from? Why did you go SE?

    I do agree with you, this is such a bad *** phone for doing actual work and communicating. I have a working iPhone backup and I'd rather use my broken PP when I do get a signal or find a wifi hotspot.

    I'm thinking of getting a used one of Markplaats, but I don't know...I want the security of nothing wrong with it. Did you buy yours new?

    Proost!
    08-04-16 02:20 PM
  19. PG_Passport's Avatar
    @leedium: it's a company phone. I am one of the 10 survivors or so demanding to keep the BlackBerry alive. The rest are followers... with the iPhone. One day.... people will understand they were misled. Back to your question: We bought it at Centralpoint. The price doesn't vary very much, I think. I kept my two year 'old' pp 1gen phone on the side. Hope to find out some day what is wrong with it. By the way: I also live in the city center: Prinsengracht and also Vodafone. It started around June 16 or so.

    Posted via CB10
    08-04-16 04:50 PM
  20. PG_Passport's Avatar
    @leediun: I chose the SE because of the reviews, which were true: the keyboard is a bit softer and even better. Subsequently: newer phones are almost always a bit better due to the experience with the product during generation 1.

    Proost back !

    Posted via CB10
    08-04-16 04:53 PM

Similar Threads

  1. What BlackBerry apps can I download on the Curve 9360?
    By CrackBerry Question in forum BlackBerry Curve 9370/9360/9350
    Replies: 4
    Last Post: 09-24-16, 03:27 AM
  2. Replies: 1
    Last Post: 07-24-16, 09:39 AM
  3. My blackberry passport is showing me bberror.con/bb10-0015,what can i do?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-24-16, 07:23 AM
  4. I purchased new BlackBerry bty C-S2. It does not take the charge, it has a lock sign?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 07-24-16, 07:21 AM
  5. Will the audioquest dragonfly red DAC work with the blackberry priv?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 07-24-16, 06:19 AM
LINK TO POST COPIED TO CLIPBOARD