06-10-18 08:43 PM
38 12
tools
  1. pat555's Avatar
    My BB Passport started losing signal and is showing emergency calls only and its the 3rd phone it has happened to even after exchanges with the phone company. However, I have noticed that it gets the LTE and 5 bars displayed whenever I am within 1 block of a cell tower. I have done hard and soft resets, sim card replacements. Can anyone sheds some light on how to fix this problem??
    Everything works perfectly except the signal lose and haven't dropped the phone once but, Im sure im not the only one that has had this problem and not interested in switching to another phone! Im a diehard BB Member
    03-05-18 10:07 PM
  2. Chuck Finley69's Avatar
    My BB Passport started losing signal and is showing emergency calls only and its the 3rd phone it has happened to even after exchanges with the phone company. However, I have noticed that it gets the LTE and 5 bars displayed whenever I am within 1 block of a cell tower. I have done hard and soft resets, sim card replacements. Can anyone sheds some light on how to fix this problem??
    Everything works perfectly except the signal lose and haven't dropped the phone once but, Im sure im not the only one that has had this problem and not interested in switching to another phone! Im a diehard BB Member
    I believe I’ve read in the past, this is a known problem without a known solution. When the PRIV did this, one solution was to shut off LTE and set to just 3G/4G HSPA.
    03-05-18 10:26 PM
  3. zer0ten's Avatar
    It's a critical hardware failure that's somewhat common to the BlackBerry Passport and it can't be fixed. It's happened to two of mine. Your Passport is now WiFi only.

    What model of Passport do you have, by the way? Both of mine that failed were the AT&T model.

    Posted via CB10
    03-05-18 10:29 PM
  4. Bla1ze's Avatar
    Everything works perfectly except the signal lose and haven't dropped the phone once but, Im sure im not the only one that has had this problem
    You're certainly not the only one who has had this problem. However, you might be the only one that has had it on that many devices despite having done all the basic troubleshooting steps. At this point, not sure what's left other than switching devices or carriers. I guess you could test your signal on a different device and see if you also have issues on that. Just borrow someone's old phone for a day or pick up some cheap jobby. You only need to see if the same/similar things happen in the same areas and then you'll have an idea if it's hardware or network. You can also play around with the network settings and find out if there's any dominant network in your area be 3G/4G/or LTE and adjust the settings accordingly.
    Qorax likes this.
    03-05-18 10:30 PM
  5. Qorax's Avatar
    @pat555: Do you have another BB phone, other than a Passport? Could you try the same SIM card on it? Maybe it is not the phone/s but the tower that's the culprit.
    03-06-18 04:57 AM
  6. johnny_bravo72's Avatar
    @pat555: Do you have another BB phone, other than a Passport? Could you try the same SIM card on it? Maybe it is not the phone/s but the tower that's the culprit.
    He said he already replaced his passport & simcard several times. Why do you think it's still a tower issue?
    There are several threads here with that same problem. Stop giving him false hope.
    03-06-18 05:43 AM
  7. pat555's Avatar
    @pat555: Do you have another BB phone, other than a Passport? Could you try the same SIM card on it? Maybe it is not the phone/s but the tower that's the culprit.
    I know it's the phone I have already tried my Sim card on another phone and not an issue but, I'm not sure why I doesn't get signal and all of a sudden just stopped working. When it's happen twice before they have lasted between 8-11months each. Don't understand the problem on such a good phone for work. I'm thinking it has to be the internal antenna would have to be the issue?
    03-06-18 06:39 AM
  8. pat555's Avatar
    How can I change the setting to 3G or 4G if I'm not getting signal? Maybe when I'm near the cell tower under settings? I will give it a try. Funny thing is I'm getting delayed texts when I pass any towers
    03-06-18 06:42 AM
  9. pat555's Avatar
    BB Passport SQW100
    03-06-18 06:44 AM
  10. johnny_bravo72's Avatar
    It's a known issue here for some Passports. No solution, unfortunately.
    03-06-18 06:48 AM
  11. pat555's Avatar
    If I can't resolve the issue with my passport! What other BB phone does anybody suggest? I can't get away from the keypad and I'm hooked on the passport overall friendly usage and screen size?? I'm open to any suggestions. The BB Ghost is very intriguing but, who knows when it will be available in the US
    03-06-18 06:49 AM
  12. pat555's Avatar
    Any word on the key one?
    03-06-18 06:52 AM
  13. Chuck Finley69's Avatar
    How can I change the setting to 3G or 4G if I'm not getting signal? Maybe when I'm near the cell tower under settings? I will give it a try. Funny thing is I'm getting delayed texts when I pass any towers
    Under Network Settings
    03-06-18 08:10 AM
  14. Chuck Finley69's Avatar
    Any word on the key one?
    I have used most recently AT&T BlackBerry Passport, AT&T BlackBerry PRIV and finally AT&T BlackBerry KEYone.

    The Passport and PRIV have both experienced “NO SVC” issues but with Passport, it wasn’t permanent for me. The PRIV was fixed with a software update fix from both BlackBerry and AT&T.

    Moving on to KEYone, I haven’t experienced reception issues caused by the actual phone. I do use a case and some have reported that helps with the reception problem if you have the actual reception issue.
    03-06-18 08:18 AM
  15. StainedClass's Avatar
    This happened to my passport too... couldn't get it fixed so now it's an all wifi email and ebook device

    Posted via CB10
    03-06-18 11:14 AM
  16. siung6's Avatar
    same here
    03-06-18 11:19 AM
  17. Qorax's Avatar
    Three Passports. Travel a lot (both domestic, as well as International). No connectivity issues ever.

    Blackberry Passport signal loss-priv-screenshot2.jpg
    ^That's one of my Passport's wallpaper
    03-06-18 11:31 AM
  18. Zedd88's Avatar
    My BB Passport started losing signal and is showing emergency calls only and its the 3rd phone it has happened to even after exchanges with the phone company. However, I have noticed that it gets the LTE and 5 bars displayed whenever I am within 1 block of a cell tower. I have done hard and soft resets, sim card replacements. Can anyone sheds some light on how to fix this problem??
    Everything works perfectly except the signal lose and haven't dropped the phone once but, Im sure im not the only one that has had this problem and not interested in switching to another phone! Im a diehard BB Member
    Long shot. But I had this issue before and was able to fix it by tightening the two screws (you need a star screwdriver for this) at the back of the top panel. Pry open the top back panel (where you insert the SIM and SD card) and you can see two screws. Tighten it a bit and see if your signal improves. Hope that helps.

    Posted via CB10
    03-10-18 05:43 AM
  19. Ginowine's Avatar
    Same here.

    Posted via CB10
    03-10-18 06:59 AM
  20. lowezz's Avatar
    Ya. My Passport has had the same symtoms for the past 4 weeks. Thats weird that many people are having this issue all of a sudden! Strange!

    Posted via CB10
    03-10-18 07:21 AM
  21. markmall's Avatar
    Have you considered moving to a house near a cell tower and working from home? More people are doing it.

    I've had this happen to at least one of my devices and just replaced it. I wasted a lot of time troubleshooting.

    Posted via CB10
    03-10-18 10:27 AM
  22. spacemanZ10's Avatar
    Happened to both of mine after about 15 mths, upgraded to an xperia ZA ultra. Just tried my sim again in my passport for old times, but no joy. It's just a small tablet now.

    Swiped on my Passport!
    03-12-18 12:48 PM
  23. Gogoniant Gagulin's Avatar
    Have the same with my passport in Italy!!!

    Posted via CB10
    03-14-18 10:58 PM
  24. siung6's Avatar
    Long shot. But I had this issue before and was able to fix it by tightening the two screws (you need a star screwdriver for this) at the back of the top panel. Pry open the top back panel (where you insert the SIM and SD card) and you can see two screws. Tighten it a bit and see if your signal improves. Hope that helps.

    Posted via CB10
    Interesting. Since one of my screw is gone. And the other would not want to tighten since some of the plastic has broke. I will try. But probably won't work
    03-15-18 11:57 AM
  25. krazyatom's Avatar
    I wonder if it's hardware related issue. I had over 10 passports and no signal issue ever and I am on at&t tower (cricket wireless).
    03-15-18 12:46 PM
38 12

Similar Threads

  1. I can't add my yahoo mail account in BlackBerry Hub
    By khaled10 in forum BlackBerry Motion
    Replies: 15
    Last Post: 03-10-18, 06:37 PM
  2. NEED HELP: Unlocking Blackberry Bold 9930
    By The_Phoenix in forum BlackBerry Unlocking
    Replies: 1
    Last Post: 03-06-18, 07:29 AM
  3. Problem opening browser link in Blackberry Hub with Keyone
    By mycheng19 in forum BlackBerry KEYone
    Replies: 1
    Last Post: 03-05-18, 07:17 PM
  4. Using the BlackBerry Help app to learn more about your BlackBerry Motion
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 03-05-18, 01:50 PM
  5. passport network problem
    By Tokocaci in forum New to the Forums? Introduce Yourself Here!
    Replies: 1
    Last Post: 03-05-18, 11:15 AM
LINK TO POST COPIED TO CLIPBOARD