1. zmadaric's Avatar
    Hi
    I have my passport since one week. I did restore backup from my BlackBerry q10 and I have some trouble with power button. When I try to wake up my phone with power button I have to wait 5-7 second to see the screen lighting and to be able to unlock my phone. I tough it's because q10 restore and I wiped my device. I installed every single app manually again. But I have the same trouble again. It's occurs not every single time but approximately every second time. Power button doesn't respond quick enough.
    Does somebody have the same trouble with BlackBerry passport? What I have to doe? Thanks and greetings Zack

    Posted via CB10
    Last edited by zmadaric; 10-11-14 at 11:06 AM.
    10-11-14 07:12 AM
  2. BlackQtCoder's Avatar
    No problems here with power button

    Posted via CB10
    10-12-14 05:38 AM
  3. Spawn12's Avatar
    Take it back to where u got it from, it might be a faulty device.

    I don't have this issue with my passport, soon as I press the power button...the phone lights up.

    Posted via CB10
    10-12-14 07:27 AM
  4. Wissam Karaky's Avatar
    It sometime takes a couple of seconds to wake up. That was on 1052. Looks like it is resolved with 1408. OP you may want to try to upgrade and then observe

    Posted via awesome Passport
    10-12-14 08:18 AM
  5. anon(870071)'s Avatar
    No problem either, you may have to return for a new one!

    Posted via Passport OS 10.3.0.908/Rogers Wireless
    10-12-14 09:26 AM
  6. Andrew4life's Avatar
    Have you tried swiping to unlock.

    Posted via CB10
    10-12-14 09:30 AM
  7. lovedaazn's Avatar
    Sounds to me like a hardware issue not software. Give customer support a call! goodluck.
    10-12-14 09:33 AM
  8. zmadaric's Avatar
    I can send my passport back to amazon. I payed only 571 ?. The wired thing is - everything works just fine if I turn "swipe to unlock" option in settings.
    I will try to observe and then make decision: back to Amazon or stuck with it!
    I don't like "swipe to unlock" option. I turned accidentally the screen on my device and started some apps or operations while this option was active.
    Thnx for help

    Posted via CB10
    10-12-14 01:07 PM
  9. LostOnThePianoRoll's Avatar
    I can send my passport back to amazon. I payed only 571 ?. The wired thing is - everything works just fine if I turn "swipe to unlock" option in settings.
    I will try to observe and then make decision: back to Amazon or stuck with it!
    I don't like "swipe to unlock" option. I turned accidentally the screen on my device and started some apps or operations while this option was active.
    Thnx for help

    Posted via CB10
    Is there also delay of more than a second or 2 when you use it to switch OFF the screen? If there is then it's most likely hardware


    Posted via CB10 on my Z10STL100-1/10.3.1.634
    10-12-14 01:23 PM
  10. homl's Avatar
    No such problem here with my Passport; screen turns on immediately. It looks like a hardware issue.
    Does the power button have a sticky feel, not bouncing back? I had a Z30 that had a power button like that. Press it many times to work it loose, and it is working fine now.
    Otherwise, returning your Passport for a new one will be your best option.
    10-12-14 01:29 PM
  11. zmadaric's Avatar
    No. Only if I try to turn it on.

    Posted via CB10
    10-12-14 01:30 PM
  12. zmadaric's Avatar
    It sometime takes a couple of seconds to wake up. That was on 1052. Looks like it is resolved with 1408. OP you may want to try to upgrade and then observe

    Posted via awesome Passport
    How can I upgrade? I am on 1052

    BlackBerry passport power button slow reaktion-img_20141012_203251.png

    Posted via CB10
    10-12-14 01:33 PM
  13. zmadaric's Avatar
    I have updated to 10.3.0.908. It looks like trouble with power button is gone. Thnx for advices.....

    Posted via CB10
    10-13-14 02:23 PM
  14. srissman's Avatar
    I am currently having the same problem. Very long delay to button unlock.

    I first thought the device was locked up completely but I needed patience.
    I am on Rogers in Canada and the problem continued with updates.

    Originally I did a device transfer so not a clean build from my Z30.

    Since 10.3.1 kinda was released early today I jumped to see if a newer version would solve the problem.... nope. Clean install.

    I cannot see this as hardware, but after official release if it continues I will try to RMA with Digital River.

    I keep swipe unlock turned off by default.
    10-31-14 05:44 PM
  15. Mark anthony Tan's Avatar
    Hi guys,suffering the same problem! Noticed this problem occurs when my battery went down and maybe the battery saving mode is on and the keyboard lights is off. The issue is resolve if resetting the phone but still its so inconvenient.. is it normal? Or shall i make a replacement? Thanks!!
    12-26-14 10:44 PM
  16. destiny.seeker's Avatar
    I'm having the same issue. It doesn't happen when I have the swipe to unlock feature on, but it happens quite often if I turn the feature off.

    So I'm very sure it's the software issue.

    I often accidentally turn on the device with swipe to unlock feature on, thus I tried to disable that feature off to see if the accidental wake still happens. Now it doesn't happen, but slow wake up happens.

    So I have to choose one problem over the other... sad



    Posted via CB10
    12-27-14 06:42 AM
  17. HITC's Avatar
    Has anyone continue to suffer this problem so far? My Passport is on 10.3.2.500 and I suffered this thing. I think it's the software problem because when I do the power button test with BBVE, the power button works fine. Has anyone success in return the device because of this fault?
    05-02-15 04:10 AM
  18. symbotier's Avatar
    Has anyone continue to suffer this problem so far? My Passport is on 10.3.2.500 and I suffered this thing. I think it's the software problem because when I do the power button test with BBVE, the power button works fine. Has anyone success in return the device because of this fault?
    Me too! 10.3.2.500. Had it also on 10.3.1. It isn't terrible for me but is a bit annoying when it happens.

    Posted from my Passport
    05-02-15 08:35 AM
  19. HITC's Avatar
    Me too! 10.3.2.500. Had it also on 10.3.1. It isn't terrible for me but is a bit annoying when it happens.

    Posted from my Passport
    I can't swipe to answer the phone when someone calling until the screen is on. Do you suffer the same?
    05-02-15 08:45 AM

Similar Threads

  1. Replies: 5
    Last Post: 10-21-14, 10:13 AM
  2. Looking for Line app in Blackberry World or Amazon AppStore
    By LukasL in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 10-15-14, 07:50 AM
  3. Replies: 1
    Last Post: 10-11-14, 01:00 PM
  4. Blackbery balance and Blackberry Blend
    By Hendri kusliawan in forum BlackBerry Q10
    Replies: 2
    Last Post: 10-11-14, 08:25 AM
  5. My top 10 game selection for the BlackBerry Passport
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-11-14, 05:00 AM
LINK TO POST COPIED TO CLIPBOARD