1. Buddha Piece's Avatar
    Alright, so I returned my passport a month after it's release because the headphone volume just wasn't loud enough and didn't have any bass. I switched between 3 or 4 of them, and still had no luck. The audio boost wouldn't work either, there was no increase in sound or anything. This was really noticeable in a car using the AUX ports, especially when comparing to the Classic, iPhone, or Nexus 5. (The Classic is the opposite for comparison purposes, it pumps out great, great sound with a lot of bass.) I've been using a Classic and iPhone but looking to sell those both to get a Passport - but seeing as I haven't tried the new OS updates on it, is there anyway the audio bass issues have been fixed? Or are people still carrying around a portable amp, I've considered this before but not quite sure if I wanna do that yet. Has the software updates improved the camera as well?

    Thank you to whoever can help me out.
    03-27-15 11:58 AM
  2. ngc's Avatar
    Ive had the same problem, not loud enough and I just updated my Passport to the latest OS via OTA (10.3.1.2576).

    Kind of a let down but Ive learned to live with it.
    03-27-15 12:09 PM
  3. Buddha Piece's Avatar
    Ive had the same problem, not loud enough and I just updated my Passport to the latest OS via OTA (10.3.1.2576).

    Kind of a let down but Ive learned to live with it.
    Yeah, it was one of the bigger reasons why I returned it in the first place. I use my phone for Spotify/Music a lot. Shame, everything else about the phone is near perfect to me, except that one issue.
    03-27-15 12:14 PM
  4. Buddha Piece's Avatar
    Just went ahead and purchased the red Passport, along with a Fiio E6 Portable Amp to keep in the car, figured I'd give that solution a try.
    03-27-15 10:08 PM
  5. Al moon's Avatar
    with the amp it'll be fine one of the reasons i just carry a small mp3 and the small amp because music just doesnt sound loud enough on passport i had the same problem with the z30
    03-27-15 10:19 PM
  6. iToya's Avatar
    I went ahead and got the amp. I think it's some regulation BS built in so we won't be deaf in two years with the phone. Clearly, I'm interested in my headphones blocking out the annoying folks of the world.

    Typed and swiped from my Passport.
    rolojr1 likes this.
    03-27-15 11:07 PM
  7. Risky_KillMoves's Avatar
    It's a software issue, has been since 10.3 and hasn't yet to be fixed. I noticed my Z10 was significantly louder which was running 10.2.1 at the time, I purchased my Passport the day of release, when 3.1 was available and loaded my Z10 with it, I noticed the change as well so please don't blame the device blame the software.

    Work Wide | PassportSQW100-1/10.3.1.2576
    03-27-15 11:32 PM
  8. Buddha Piece's Avatar
    Hopefully it's a software issue that can be addressed in the future than, but the Classic was also running an updated OS and the sound and bass is much much better. Either way, I am excited to get my Passport and AMP.
    03-28-15 02:31 PM
  9. creaturex's Avatar
    Hi there!
    I got the same issue with my passport :-/ I have invest a lot of $$ into my car audio upgrade, especially subwoofer and I am really disapointed with low frequencies of the headphones output

    I have also tried to play around with the Neutron music player, yes it's better, but still not good as the sound output of any ****ty cheap android device

    I also bought Brodit phone holder, install AUX, etc etc ...

    PLEASE help me with this issue... I don't want to carrry another device for playback in my car
    04-14-15 09:27 AM
  10. YeemanBB's Avatar
    Did you turn on headphone audio boost?

    Posted via CB10
    04-14-15 10:39 AM
  11. Buddha Piece's Avatar
    Hi there!
    I got the same issue with my passport :-/ I have invest a lot of $$ into my car audio upgrade, especially subwoofer and I am really disapointed with low frequencies of the headphones output

    I have also tried to play around with the Neutron music player, yes it's better, but still not good as the sound output of any ****ty cheap android device

    I also bought Brodit phone holder, install AUX, etc etc ...

    PLEASE help me with this issue... I don't want to carrry another device for playback in my car
    Yeah sadly I just went ahead and bought the fiio portable amp and left it inside my car. It's a really small thing that adds bass finally.
    04-14-15 11:30 PM
  12. Buddha Piece's Avatar
    Did you turn on headphone audio boost?

    Posted via CB10
    Yes, I've tried it. For whatever reason in a car when connected to an aux port I don't believe the phone recognizes the car as a headphone device. The audio boost will not trigger on as they would on the older OS BlackBerry if I remember correctly, those would get really really loud and bassy
    04-14-15 11:31 PM

Similar Threads

  1. I will tell you why blackberry hardware sales are low......
    By Anthony Roberts5 in forum General BlackBerry Discussion
    Replies: 367
    Last Post: 04-15-15, 11:15 AM
  2. Replies: 14
    Last Post: 04-07-15, 10:55 AM
  3. Blackberry Assistant Being Lazy
    By lander06 in forum BlackBerry Passport
    Replies: 17
    Last Post: 03-29-15, 11:02 AM
  4. BlackBerry Q4 Fiscal 2015 Earnings Call Live Blog!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 1
    Last Post: 03-27-15, 09:45 AM
  5. BlackBerry launches Enhanced SIM-based Licensing for 3 Hong Kong
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 03-27-15, 07:51 AM
LINK TO POST COPIED TO CLIPBOARD