1. Onyros's Avatar
    Hi there guys,

    (Posted this inadvertently on Q&A - I thought "Heh, this forum posting thing works strangely here"... Turns out I was logged off after registering. I'm dumb. Sorry)

    I'm at wits end. Bought a used Passport for my emailing pleasure - and because I love the format - and when I got it WiFi was not working well. It was working perfectly on 4G, but it would not detect WiFi networks. Also, the blue WiFi slider would just switch between on and off, whenever I tried to turn WiFi radio on.

    Suspecting it might be a botched OS that had went through too many updates without a fresh install, I first tried a(nother) security wipe, but the problem remained. So I connected the Passport to my laptop with Link and tried to do a Factory Reset (Reload > Reload on a Mac).

    After I tried that, the device said it had failed the OS reload. After I unplugged the Passport from my laptop's USB port, its red led started blinking intermittently. Anything I tried wouldn't stop the blinking, unless I tried reconnecting the Passport to my laptop and Link - which would render a green led.

    I tried another OS reload... it always failed. As soon as I unplugged the Passport from the USB port, it would go back to the blinking red leds. I didn't think much of it, but as much as I pressed the power button or volume buttons combination, it wouldn't stop blinking.

    So, I just left it overnight, knowing eventually it would run out of battery, and I would then try Autoloader to do a fresh installation...

    My problem now is that the Passport doesn't even seem to charge. Fixed red led goes on when I plug it to the wall charger, but that's it. It doesn't even heat up from charging, doesn't seem to be holding its charge. Pressing the Power Button for 10 seconds, 20 seconds, one minute... nothing happens.

    Autoloader gets stuck in "Connecting to bootrom" on the command line (Win10), doesn't seem to detect the Passport.

    Link doesn't detect it, either on Win or OS X.

    Have I managed to completely brick my Passport? Any help is more than appreciated. Sorry for the wall of text, thought you'd appreciate as much context as possible. Passport was running 10.3.3, supposedly the latest and greatest version of the firmware because when I tried updating it said there were no updates for the OS.

    Beers will definitely be in order if anyone manages to help me revive the thing.
    02-03-17 05:01 PM
  2. marcaccioc's Avatar
    try an autoloader
    02-03-17 05:07 PM
  3. Onyros's Avatar
    -- snip snip --
    Autoloader gets stuck in "Connecting to bootrom" on the command line (Win10), doesn't seem to detect the Passport.

    Link doesn't detect it, either on Win or OS X. -- snip
    I did, to no avail...
    02-03-17 05:11 PM
  4. shawnreum's Avatar
    I did, to no avail...
    Have you tried holding volume up and down button at the same time until device reboots?
    02-03-17 06:45 PM
  5. anon(2313227)'s Avatar
    What the device thinks is latest and what is latest is two different things.
    Get the latest Autoloader for 10.3.3 you can find and run it.
    02-03-17 08:02 PM
  6. kbalaz's Avatar
    If I missed it, sorry. Have you tried a new USB cable? Did you try plugging it into the wall and leave it to charge? Some usb ports don't offer enough juice to charge the passport. If you have tried all of the above, try running the autoloader and when it stops, unplug it and plug it back in again, if it doesn't continue, re-start the autoloader. Good luck
    02-04-17 08:21 AM
  7. CyberMan2013's Avatar
    Allow the phone to charge overnight or for some hours to ensure that it has enough battery, download and install the BlackBerry Desktop Software which should include drivers. This is to ensure that the drivers are installed. There is a special driver that is only installed when the phone is shutting down or restarting though, which allows connection to the bootrom. I suspect that this driver is not installed and because you can't shut down and restart your phone normally, you're not able to have that driver install. Hence the reason why the autoloader isn't connecting to the bootrom. You can try using a different USB port, try using a different PC then try run the autoloader again. But your problem has to do with the drivers required for the connection not being installed.

    Posted via CB10
    02-04-17 08:29 AM
  8. par_pa's Avatar
    I had a similar problem with a Q10 last week. I followed a tip from another forum, and it worked perfectly, but maybe difficult for the Passport because you have to remove the battery.
    Here's how you disassemble a BlackBerry Passport | CrackBerry.com
    What I did for the Q10 was disconnect the charger, remove the battery, the SIM card and the SD card, then wait 24 hours. After, reinstall everything, and hopefully it will work again.
    For me, it worked for many BlackBerry phones I had to revive. Good luck.
    02-04-17 11:02 AM
  9. Onyros's Avatar
    @shawnreum, yes, I did try that. Even connected to mains, Passport does nothing.

    @deremi, I have tried the latest autoloader available for the Passport. It hangs on "Connecting to bootrom", doesn't seem to recognise the device.

    @kbalaz I will try all those again, but I have tried a few of those already from reading other similar situations reported before in the forum.

    @Cyberman2013 I do have Link installed, the drivers are there. I have left it charging twice overnight, the charger doesn't heat up as it used to when charging, neither does the device. Doesn't seem to be charging, probably because it does need the firmware installed properly and not corrupted (as it seems to be) to do so. So you're absolutely right there.

    And finally, @par_pa... I may have to do just that, as a last resort. Nothing to lose right now, it seems. I hope I can reassemble it after. Not my first stroll through that park... With other devices, but still!

    Thank you all for those tips. If there's something else I may have missed, please do chime in! Cheers!
    02-04-17 11:30 AM
  10. lenonx's Avatar
    Mate,
    Is your bbpp working at the moment? I had the similar issue but managed to fix by wiping the device using SIC and then installed OS using autoloader! Pleasevlet me know if you're still having the same issue! Cheers!
    04-18-17 05:13 PM
  11. Onyros's Avatar
    Hi there, guys, sorry for a very long overdue update: it was bricked and it has thus remained.

    I bit the bullet and actually bought a new one, because I just love the damned thing.

    I'll use it until I can get the KeyOne for a somewhat lower price.
    06-01-17 06:14 AM
  12. joeytino's Avatar
    You are not alone. It appears mine self destructed last night. About 30 minutes after using the phone I saw the Blackberry logo and that is all I have seen since. Neither Link or an autoloader can recover it because it reboots once it gets to a certain point in memory.

    Considering that all of my previous BB's are still functional - and I was prepping my Bold 9000 for backup duty before I remembered the PP has the nano SIM - I am very bummed that this one failed so quickly.
    Last edited by joeytino; 06-13-17 at 01:16 AM.
    06-13-17 01:03 AM
  13. Onyros's Avatar
    I have a new one, and it's working perfectly. I can only imagine what an updated OS with an updated Android runtime with power efficiency update would make of this phone...

    Anyway, I also ordered the KeyOne (got a great price) and am eager to see how it compares. But the Passport's form factor and keyboard? Simply amazing. The screen is awesome, battery life even with the few Android apps I use is great, I don't know... there's little I don't like about the Passport. (Apart from the occasional heating on the top right)

    As this Passport is about one week old, I can make a cool comparison between the two of 'em. I'll eventually just flip the one that loses the bout, as I already have a secondary phone and won't need two with PKBs.

    I sent the one that failed for repair to a representative who claims is authorised, I'll keep you posted on the eventual solution on my side, might help someone else.
    06-13-17 10:15 AM
  14. joeytino's Avatar
    There may be some hope if your Passport is not starting. Watch the blinks. ( Each number reflects the count of fast blinks a pause then the next series of rapid blinks for the second number, etc.) If yours is 1 3 2 keep reading.

    During my initial research on this issue, I never saw any mention that there was a security feature that forced you to use 10.2.x or higher if your phone had been upgraded to or exceeded it and the autoloader I had on my laptop was 10.1. something. I installed Link on a separate PC that did not have any AntiVirus that might have any sort of Port blocking or Firewall ( My work PC with Link and Blend now does and that complicated things.) and launched the newer autoloader and for the first time in months I see a green light! Within 20 minutes my Passport lives again! Although I now have a Keyone so...Sophie's Choice, though the power of the Passport is stronger. (Better keyboard IMHO and I do not like Android.) I still have to deal with the double typing and wiggling camera focus, but it's no longer sitting there dead and that was very frustrating.
    Last edited by joeytino; 11-08-17 at 08:10 PM.
    11-08-17 03:45 PM

Similar Threads

  1. Replies: 0
    Last Post: 02-03-17, 04:51 PM
  2. Can I get Facebook Live working on my BlackBerry Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-03-17, 04:12 PM
  3. BlackBerry begins rollout of February Android security update
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 4
    Last Post: 02-03-17, 03:07 PM
  4. blackberry 10 OS.
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 02-03-17, 02:02 PM
LINK TO POST COPIED TO CLIPBOARD