1. KombatVirus's Avatar
    Hey everyone. I quite recently upgraded to a Passport, running OS 10.3.0.908, and have a couple questions / concerns

    First of all, blackberry blend tends to be pretty slow. Specifically there is often a delay when typing, and the whole application freezes up when you hit "enter" to send. Is there a certain way to smooth this out, or was blend just not fully developed before release? I mean, it is usable, but just barely. I really love this app, but at this moment it is easier to just use the phone to quickly send a message instead of waiting on this lagging app.

    I have heard of some fixes like resetting the hub with the 5-swipe gesture, and deleting all your text messages. This doesn't really seem like it is working too well, as the issue still is there. Does the 10.3.1 update make blend any smoother?

    This occurs on pretty much all PCs, powerful or not.

    Anyone have any ideas?
    02-23-15 03:17 PM
  2. Bla1ze's Avatar
    Blend needs an update in a bad way. Hasn't been updated since release.
    kbz1960 likes this.
    02-23-15 03:21 PM
  3. anon1727506's Avatar
    I haven't noticed too many issues with Blend on my two PC.... I tried it on a Tablet but the performance hit on the tablet was too much of a negative. But it isn't something I use too much as the features in Microsoft Outlook make composing and replying to emails a much better experience than Blend.... and I don't do a lot of BBM or Text.

    Of course I'm using a 10.3.1 version
    02-23-15 03:24 PM
  4. pttptppt's Avatar
    Blend needs an update in a bad way. Hasn't been updated since release.
    I thought it was updated at some point?

    Posted via CB10
    02-23-15 03:28 PM
  5. KombatVirus's Avatar
    I often get a 2-3 second delay/freeze when typing. When the actual message gets sent, that circle loading display comes up and the whole app freezes up for up to 15 seconds until the message sends. This is on a powerful PC, on my laptop the issue is even worse.

    So, no fix so far? Blend is just a useless undeveloped gimmick?
    02-23-15 03:40 PM
  6. currentodysseys's Avatar
    I find it working better on a USB rather than wireless, but I would say it works quite better in my case than what you describe (never had 15secs) freezing, but yes it is nowhere close to "butter smooth". I use it on a MacBook though and not win PC.

    try USB and it may make it a bit better?

    Posted via CB10
    KombatVirus likes this.
    02-23-15 04:07 PM
  7. KombatVirus's Avatar
    I have tried it on USB and indeed it seems to be quicker, but definitely not "buttery smooth" thats for sure. Here is to hoping for an update!

    On another note, if you have a paired device in blend, if you connect the phone with USB will it automatically transfer the data over the cable rather than the wifi network?
    Last edited by KombatVirus; 02-23-15 at 05:32 PM.
    02-23-15 05:06 PM
  8. Monsterlad's Avatar
    I find it a bit stuttery when trying to send messages, but hey it's functional lol
    02-23-15 05:21 PM
  9. Bla1ze's Avatar
    I thought it was updated at some point?

    Posted via CB10
    Maybe you're right, back in mid-December. Still doesn't change what I said about it needing an update lol.
    02-23-15 07:36 PM
  10. woofster's Avatar
    Interestingly, Blend worked fine for me when I first got my Passport in Oct 2014. After a month or so of use though I started getting severe lag when texting via Blend. It hasn't gotten any better since.

    Initiating a text message results in a lag of, at times, half a minute. Once it gets past the first lag, the remainder of the text message can be typed out quickly and freely. Sending the message will usually result in more lag, usually less severe than the initial one.

    Some of you guys say it's workable and bearable but, to be honest, it's unacceptably laggy. I really hope the OS update will make Blend operate the way one would expect it to.
    02-23-15 11:44 PM
  11. greatwiseone's Avatar
    There's a little bit of lag...but it's worst on less powerful tablets and laptops. When I use it on my y510p, I don't feel a lot of lag....

    Posted via CB10
    02-24-15 01:48 AM

Similar Threads

  1. ESPN Cricket 2015 (World cup app) not working after OS 10.3.1 upgrade on Passport
    By cjterminator in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 02-28-15, 05:03 PM
  2. Replies: 2
    Last Post: 02-24-15, 07:41 AM
  3. How do I fix my BlackBerry ID, two screen names and can't clear it up?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-23-15, 08:27 PM
  4. Evernote updated in BlackBerry Beta Zone - You can now see notebooks shared with you
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 02-23-15, 03:12 PM
  5. How do I unistall the lastest update for my blackberry Z10 ???
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-23-15, 03:08 PM
LINK TO POST COPIED TO CLIPBOARD