1. krivonosov's Avatar
    Hi Crackberry world!
    Need your help and consult, pls!

    Body: BB Passport SQW100-1

    Trouble:
    I bought it from owner, who used phone for years and all was ok. But he damage screen and decide to sell device.

    My doings:
    Ordering and installing new screen from Aliexpress. Also slick-glass attached to screen for protection. All OK!
    but... when installed sim-card — lags became! And lags exists only when sim enabled and I do calls.. or after calls. I thinked that it can be troubles that gives slick-glass, and removed it.. but no / Nothing changes.

    Basic symptoms:
    1) sometimes screen not wake up immediately.. and I try to wake it by Pwr button and by pressing U+enter ... After 3-5 tries it's woke.
    And sometimes it's wake normally.
    2) screen brightness not controlled by sensor.. and screen alway stay too bright, and sometimes maximum dark (but it's visible and working, not sleep!). Sometimes 3-5 cycles of enabling-disabling of screen it became OK and sensor start working fine.
    3) Touch became crazy during calls and sometimes after calls. It automatically touch something in the bottom line of screen.

    last ROM installed to my BB was 10.3.3.2205 - and it's gave lags..
    now ROM downgraded to 10.3.3.2049 - same lags..

    Well..
    I tried to experiment with phone last days and see that basic only when sim inserted. And as I saw previous damaged screen - it was damaged in left top corner (and in previous damaged screen sensors works OK! but i didn't tested it with sim-card.. I don't know how it worked with inserted sim)

    Lags:
    1) speaking over headset that plugged in audio-port. Display touch becames crazy when talking over plugged headset, Sensor of brightness becames crazy too.
    2) when charging - touch live at his own))
    3) waking up by PWR button (or U+enter) works OK when sim-card not inserted... Sensor works OK too.

    One time:
    Phone heats alot after one call, heats in right top (where processor & simcard zone), sensor becames crazy and touch too, I switched off phone, another not working.
    Also phone heats alot in right top when skype-enabled, and when phone boot up sometimes too.

    Is it screen lag, or other module? Can anyone help?
    Attached Thumbnails Blackberry passport after repair-_35-1-.jpg  
    03-23-17 05:45 AM
  2. kbalaz's Avatar
    Did you install just the screen or screen with digitizer? Is this a BlackBerry OEM part or third party screen? Both of which can give you issues. You can try and open it up and reattach cables and make sure something isn't loose. Sometimes those little ribbon cables don't go down all the way.
    03-23-17 07:52 AM
  3. krivonosov's Avatar
    Did you install just the screen or screen with digitizer? Is this a BlackBerry OEM part or third party screen? Both of which can give you issues. You can try and open it up and reattach cables and make sure something isn't loose. Sometimes those little ribbon cables don't go down all the way.
    thanks for answer! Link for screen I've bought: https://www.aliexpress.com/item/100-...608.0.0.t3vl1Y it's with Digitizer.
    I opened phone week ago, and re-attach cables, remove dust etc.
    After it phone lags became too much ))) Same lags that i've write in first post.

    But strangeness in that fact, that without SIM - all working fine! but when insert sim, boot up phone, lags begins...
    Last edited by krivonosov; 03-23-17 at 08:53 AM.
    03-23-17 08:32 AM
  4. chetmanley's Avatar
    Have you tried a different sim card?
    kbalaz likes this.
    03-23-17 09:18 AM
  5. kbalaz's Avatar
    this ^^^
    if you do not have another sim available, try setting your mobile network to 4G, 3G. It is funny that without sim it works fine. You may have inadvertently damaged the antenna at the bottom of the device when you replaced the screen as well causing the unit to struggle to find a signal. If another sim doesn't help, check your screws at the bottom of the device below the screen and make sure it is all correct and you didn't change or damage something there.
    03-23-17 11:47 AM
  6. krivonosov's Avatar
    Have you tried a different sim card?
    jet no, but previously I inserted card that I cut myself from old-sim size to nano-sim, it's working fine but lags begin.
    then I went to mobile office and ask to give me new sim with exact format. Used it, and there was same lags.
    03-23-17 11:48 AM
  7. krivonosov's Avatar
    Have you tried a different sim card?
    this ^^^
    if you do not have another sim available, try setting your mobile network to 4G, 3G. It is funny that without sim it works fine. You may have inadvertently damaged the antenna at the bottom of the device when you replaced the screen as well causing the unit to struggle to find a signal. If another sim doesn't help, check your screws at the bottom of the device below the screen and make sure it is all correct and you didn't change or damage something there.

    guys, thanks for answers!
    solution is funny:

    1) when I disassemble device - there no special strange gasket like that I saw in youtube videos:
    Blackberry passport after repair-blackberry-passport-teardown-4.jpg

    and I made self-made gasket, and put it in same place.
    I think gasket represented in models after SQW100-1, or something like that... but my model is 100-1! and there no gasket, and seems like that some unoptimal current was among motherboard & phone cover.

    2) when I disassembled device - I clean contacts of sensor and a little bit bend-out sensor-linked contacts on mainboard.

    and all last days phone works fine!

    thanks all!
    03-29-17 05:50 AM

Similar Threads

  1. Blackberry Calendar not receiving Facebook Birthdays
    By Aztronauta in forum BlackBerry DTEK60
    Replies: 5
    Last Post: 04-16-17, 06:09 AM
  2. Mario run is Not running on BlackBerry 10!??
    By Alfa TomSen in forum Android Apps (Amazon Store & APK Files)
    Replies: 8
    Last Post: 04-08-17, 12:41 PM
  3. BlackBerry not part of Google's secure phone list.
    By CranksterBB10 in forum General BlackBerry Discussion
    Replies: 47
    Last Post: 04-08-17, 09:45 AM
  4. privacy shade in our BlackBerry os 10?
    By sudheern in forum BlackBerry 10 OS
    Replies: 10
    Last Post: 03-24-17, 01:02 PM
  5. I love my Blackberry Passport (LinkedIn)
    By Keng Ng in forum BlackBerry Passport
    Replies: 7
    Last Post: 03-23-17, 02:25 PM
LINK TO POST COPIED TO CLIPBOARD