1. Scott Toner's Avatar
    Running the BB Navigation app on my BB Passport and it works terrible! Map freezes and lags behind. I see a red box appear every time this happens. I assume it indicates that GPS signal is lost. I'm using it on open highway so there is no forms of interference. I have read in other threads that maybe the LTE is causing the interference. Any suggestions on what I could do to correct this problem? Is BB aware of the problem?
    juststart likes this.
    03-11-15 08:09 AM
  2. zamboni08's Avatar
    Try turning airplane mode on and off? I find that can help sometimes.

    Posted via CB10
    03-11-15 08:12 AM
  3. franchise22's Avatar
    What OS are you running? Had the same issues until I installed the latest leak and the .2480 bars. Works perfect now.

    Posted via CB10
    03-11-15 08:47 AM
  4. amccray5's Avatar
    Just got my AT&T Passport a couple days ago and am having the same issue. I'm running OS 10.3.1.1995. Just gonna grab that updated leak this weekend.

    Posted via CB10
    03-11-15 09:50 AM
  5. Scott Toner's Avatar
    I'm running the same OS version. Let me know if you have any luck with that. I don't know how to update with the leaks? I've watched some videos but i'm reluctant to try.
    03-11-15 08:47 PM
  6. mad_mdx's Avatar
    Try a different maps app. Such as Waze.
    03-11-15 10:31 PM
  7. Arabianhorse's Avatar
    I'm running the same OS version. Let me know if you have any luck with that. I don't know how to update with the leaks? I've watched some videos but i'm reluctant to try.
    I am not too techie but Sachesi is easy to use. The updates make the phone smoother and the radio is awesome -downgrade that is.

    SQW-100-3 10.3.1.2480/2244 Allergy/Pulmonary
    03-11-15 11:00 PM
  8. matute008's Avatar
    This is for Franchise22, I just bought the AT&T love the phone but hate the GPS. Where did you get the leak version? Did you get your phone from AT&T?
    03-12-15 08:33 AM
  9. franchise22's Avatar
    This is for Franchise22, I just bought the AT&T love the phone but hate the GPS. Where did you get the leak version? Did you get your phone from AT&T?
    Yes. Bought my passport at an at&t store in town. The 2267 leak is available in the forums and then you have to install bar files on top of it for 2480. It all sounds complicated and confusing, but it is super easy! The forum threads have instructions on exactly what you are supposed to do. I'll search the forums and add the links in a moment. Let me know if you need any help. It will be well worth your time to do this and you'll be kicking yourself for not doing it sooner. Good luck!

    Edit: forum threads below. Hope this helps.

    OS 2267 + Radio 2268 'Blitz' Non-Destructive Update

    http://forums.crackberry.com/showthread.php?t=1000576

    OS 10.3.1.2480 upgrade files [Passport Only]

    http://forums.crackberry.com/showthread.php?t=1000622
    Last edited by franchise22; 03-12-15 at 10:39 AM.
    Scott Toner and Inkhie Mars like this.
    03-12-15 10:29 AM
  10. Aljean Thein's Avatar
    Yea, use Waze map

    Suffer Now & Live The Rest Of Your Life As A Champion
    03-12-15 10:31 AM
  11. Scott Toner's Avatar
    Franchise 22 Thank you for the links. I followed the instructions and was able to get both updates on my Passport device. Navigation works perfectly now and I learned something as well. Much appreciated.
    franchise22, flip68 and bspence87 like this.
    03-12-15 03:06 PM
  12. Larry Harper's Avatar
    Posted via CB10
    03-12-15 09:40 PM
  13. juststart's Avatar
    I purchased a Passport yesterday from ATT even though I knew there might be some issues. I was hoping it was isolated but as soon as I got in my car and tried to navigate home, it threw up an error and wouldn't do anything. I downloaded Waze and it had issues at first but after about 5 minutes it worked fine. Really weird. The native app won't give me navigation at all.
    03-13-15 10:19 AM
  14. tdaye's Avatar
    I purchased a Passport yesterday from ATT even though I knew there might be some issues. I was hoping it was isolated but as soon as I got in my car and tried to navigate home, it threw up an error and wouldn't do anything. I downloaded Waze and it had issues at first but after about 5 minutes it worked fine. Really weird. The native app won't give me navigation at all.
    And did you try the above mentioned?

    Posted via CB10
    03-13-15 10:32 AM
  15. juststart's Avatar
    Did I try a different firmware? No, kind of trying to avoid that.
    03-13-15 12:07 PM
  16. amccray5's Avatar
    Updated to 10.3.1.2558 earlier today. GPS is now flawless!
    03-14-15 09:33 PM
  17. lang007's Avatar
    The gps on wave is up and down and I have installed the upgrade
    03-16-15 08:41 PM
  18. vvildstar's Avatar
    Running the BB Navigation app on my BB Passport and it works terrible! Map freezes and lags behind. I see a red box appear every time this happens. I assume it indicates that GPS signal is lost. I'm using it on open highway so there is no forms of interference. I have read in other threads that maybe the LTE is causing the interference. Any suggestions on what I could do to correct this problem? Is BB aware of the problem?
    You may want to try a new SIM card.
    03-17-15 07:29 AM
  19. juststart's Avatar
    You may want to try a new SIM card.
    Yea that's not the issue.

    Posted via CB10
    03-17-15 09:47 PM
  20. coufy's Avatar
    Some software get only gsm localisation data which are not exact, to get gps data you have to turn off gsm. I think its bb10 fault.

    Posted via CB10
    03-18-15 12:13 AM
  21. sloanb's Avatar
    I have the same issue here so it does appear to be widespread. Maps works perfect on my Classic.
    05-22-15 11:06 AM

Similar Threads

  1. BlackBerry World issues
    By yeo123 in forum BlackBerry Z10
    Replies: 7
    Last Post: 03-13-15, 11:49 AM
  2. Any Passport owner in Bihar, India
    By helalzone in forum BlackBerry Passport
    Replies: 3
    Last Post: 03-11-15, 02:14 PM
  3. blackberry z10 is not updating to os 10.3.1.1565
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-11-15, 07:51 AM
  4. How to fix BlackBerry id login issue?
    By botbotd in forum Ask a Question
    Replies: 1
    Last Post: 03-11-15, 07:38 AM
  5. Why is my Blackberry 9790 switching off?
    By CrackBerry Question in forum BlackBerry Bold 9790
    Replies: 0
    Last Post: 03-11-15, 07:12 AM
LINK TO POST COPIED TO CLIPBOARD