1. nithukuttan's Avatar
    Hey everyone, I am new into BB world and had no idea it would be this difficult to handle a BB phone. Right now, the only apps I was able to fix was just the Whatsapp.

    I have 1mobile app installed, turned on unknown application install setting, set SSL to low, and even tried to downgrade to see if anything will fix the problem.

    Neither could I run any apps like messenger, new facebook, instagram, chrome, or almost 90% of the apk i wish to run on it, but I am not even able to downgrade it to a 10.2 version just to see if it ll give me any chance. I bought this phone a week before, and I am already regretting it. Please help me somebody. I use latest 10.3.3.1463. No snap as well. It just opens and close in a blink.

    Basically everything opens and close in a second that it shatters all my hopes.
    01-01-18 12:01 AM
  2. johnny_bravo72's Avatar
    If apps are a necessity, you bought the wrong phone. Get an Android or iOS device.
    01-01-18 12:14 AM
  3. donz88's Avatar
    Blackberry was a unique phone. It might produced for certain user. If you adoring a smartphone that could give you many things as you expected, then you should go to android or iOS. No need to be regretted. It's your choice, with all risks. I believe, you already considered many things before deciding.

    Posted via CB10 using awesome  Passport SE
    01-01-18 01:09 AM
  4. nithukuttan's Avatar
    well, there are people whom I read from the threads who are using many updated version of apps like the ones I mentioned before, but not me. I ve seen many people using the latest 10.3.3 and still was able to run many things. Even I cannot execute a single instruction from this Crackberry threads itself, for say, the snap. I mean they are meant to run in our BB os and I still get the problem. What am I doing wrong? Should I downgrade it to lower ones for more compatibility? (I cannot downgrade it either )
    01-01-18 10:06 AM
  5. CrackPriv's Avatar
    It works with a lot of Android apps when you use Cobalt's Google patches.

    Posted via CB10
    01-01-18 10:45 AM
  6. conite's Avatar
    Hey everyone, I am new into BB world and had no idea it would be this difficult to handle a BB phone. Right now, the only apps I was able to fix was just the Whatsapp.

    I have 1mobile app installed, turned on unknown application install setting, set SSL to low, and even tried to downgrade to see if anything will fix the problem.

    Neither could I run any apps like messenger, new facebook, instagram, chrome, or almost 90% of the apk i wish to run on it, but I am not even able to downgrade it to a 10.2 version just to see if it ll give me any chance. I bought this phone a week before, and I am already regretting it. Please help me somebody. I use latest 10.3.3.1463. No snap as well. It just opens and close in a blink.

    Basically everything opens and close in a second that it shatters all my hopes.
    None of the apps you listed work on BB10.

    Use Facebook Lite and Messenger Lite instead of Facebook and Messenger.

    Chrome needs to be patched to work properly, so you're better off with the native browser.

    You have to use iGrann native app, or try an old version of Android Instragam (v10.3.2 or prior).

    Snap isn't compatible with OS 10.3.3, and you can't downgrade to 10.3.2.

    1mobile is full of malware - do not use.
    nithukuttan likes this.
    01-01-18 11:38 AM
  7. Invictus0's Avatar
    You have to use iGrann native app, or try an old version of Android Instragam (v10.3.2 or prior).
    The mobile site is another good alternative, it's close to feature parity with both of those options.
    01-01-18 12:22 PM
  8. Dunt Dunt Dunt's Avatar
    well, there are people whom I read from the threads who are using many updated version of apps like the ones I mentioned before, but not me. I ve seen many people using the latest 10.3.3 and still was able to run many things. Even I cannot execute a single instruction from this Crackberry threads itself, for say, the snap. I mean they are meant to run in our BB os and I still get the problem. What am I doing wrong? Should I downgrade it to lower ones for more compatibility? (I cannot downgrade it either )
    Problem is much of that info you are reading is old and no longer applies. If you can still exchange the phone, BB10 isn't a great option anymore.

    If not, you'll need to take the time to read some of the latest info on the apps that you need. And see if there are workarounds (like the ones conite mentions).
    01-02-18 07:55 AM
  9. mikael11's Avatar
    If you really are interested in getting more out of your Passport, goto section BBOS10 and find thread labled Cobalt's landing page. Goto page 1 and read the instructions thouroghly. You can make quite some apps to work (but not Snapchat).

    Posted via CB10
    CrackPriv likes this.
    01-02-18 10:49 PM
  10. gsfx's Avatar
    Most of the answers here are not useful. Yes, the BlackBerry Passport is a BB 10 OS phone, but its capable to run Android apps. And if these Android apps do not run there is something wrong with the phone, not with the user. Yes, perhaps its better to have an iPhone or an Android phone if you wont things to work properly out of the box. But as I understand none of the Android apps are working.

    I have the same problem after updatinh to 10.3.3.1435. I do not want to run any Android app but some apps that are important to me. Workarounds are nice, but not always helpful. If the engine of my car is blown it makes sense to repair it. Yes I can install a sail on the roof, that will look cool but is not useful for my purposes. For my Passport I just want Threema and Telegram to work and some other Android apps like the Bible app.

    Any ideas how to get Android working again on 10.3.3?

    Best regards

    Fred
    01-06-18 05:05 AM
  11. Jrox74's Avatar
    Hi I'm running android Whatsapp,Instagram (V 10.3.2) Line, WeChat, Signal, Telegram, Viber, & Disa (For FB Messenger) and all work well. You have to watch the android runtime as newer versions the runtime is to advanced for BB10. I know the day will come when I'll have to switch but for now My Passport OG is doing the job just fine, Rcoking 24-7 with my Passport OG (10.3.3.1435) & Se,i Retired Z10
    01-08-18 11:44 PM
  12. rajeshnomulwar's Avatar
    Hey everyone, I am new into BB world and had no idea it would be this difficult to handle a BB phone. Right now, the only apps I was able to fix was just the Whatsapp.

    I have 1mobile app installed, turned on unknown application install setting, set SSL to low, and even tried to downgrade to see if anything will fix the problem.

    Neither could I run any apps like messenger, new facebook, instagram, chrome, or almost 90% of the apk i wish to run on it, but I am not even able to downgrade it to a 10.2 version just to see if it ll give me any chance. I bought this phone a week before, and I am already regretting it. Please help me somebody. I use latest 10.3.3.1463. No snap as well. It just opens and close in a blink.

    Basically everything opens and close in a second that it shatters all my hopes.
    Pl contact me on rajmin8@gmail.com. I may help you in resolving the issues. Don't regret buying BB10. It's an awesome device. And can be used till its last breath

    Posted via CB10
    01-09-18 01:40 AM
  13. curtis nyawanda1's Avatar
    BB 10.3.3.746 missing native apps now I can't access file manager using USB cable to my computer pls assist

    Posted via CB10
    01-11-18 05:07 PM
  14. drilluminate's Avatar
    None of the apps you listed work on BB10.

    Use Facebook Lite and Messenger Lite instead of Facebook and Messenger.

    Chrome needs to be patched to work properly, so you're better off with the native browser.

    You have to use iGrann native app, or try an old version of Android Instragam (v10.3.2 or prior).

    Snap isn't compatible with OS 10.3.3, and you can't downgrade to 10.3.2.

    1mobile is full of malware - do not use.
    Which instagram version work on OS10.3.2

    Posted via CB10
    01-15-18 04:53 AM
  15. conite's Avatar
    Which instagram version work on OS10.3.2

    Posted via CB10
    Read my post again.
    01-15-18 06:39 AM
  16. Hrishikesh Jadhav's Avatar
    Mine is 10.3.2.2474 I never got os update of 10.3.3 how did u get that update?

    Posted via CB10
    01-15-18 07:56 AM

Similar Threads

  1. Hub doesn't run in the background anymore
    By filanto in forum Android Apps
    Replies: 16
    Last Post: 07-11-18, 01:07 PM
  2. Q10 won't charge after installing 10.3.3.3057
    By havilah1 in forum BlackBerry Q10
    Replies: 9
    Last Post: 01-04-18, 03:31 PM
  3. Need Help Getting Android WhatsApp Working Correctly
    By hennesseystealth in forum BlackBerry Z30
    Replies: 4
    Last Post: 01-03-18, 01:16 PM
  4. Replies: 2
    Last Post: 01-01-18, 04:37 AM
  5. Quick Help Needed about BlackBerry KEYone (Android)
    By SamWarner in forum Ask a Question
    Replies: 2
    Last Post: 01-01-18, 02:08 AM
LINK TO POST COPIED TO CLIPBOARD