1. Bompibomp's Avatar
    This has probably been asked many times. It really annoys me because I really LOVE the passport. It beats everything I have tried. BUT, there is always a but...

    The phone is always on WI-FI when at home and friends and I have set it to 3G/2G only.

    Before I wiped my phone I had play store installed, SNAP, Facebook, twitter, instagram, myfitnesspal, 4 email accounts w/ push+history set on 'forever', spotify.

    I did a reset 4 hours ago. I went via the system settings, security and privacy, security wipe menu. Did a backup via link before I executed.

    Now I have 4 email accounts w/ push+history set on '30 days', Facebook, twitter, spotify. I tried to keep the phone as 'clean' as possible.

    The phone has been on standby since reset. I just brought the phone with me to the store and was back home within 20mins. It was not used during that time.

    Now after 3 hours of non-use it looks like the attached pics. 12% power loss for not using the phone and 88% equals 18 hours.

    Any ideas?

    Edit: 81%(16h) after 4hours of non-usage.
    Edit: 75%(15h) after 5hours of non-usage.
    Attached Thumbnails Battery life-bbp1.jpg   Battery life-bbp2.jpg  
    Last edited by Bompibomp; 02-20-16 at 03:54 PM.
    02-20-16 02:30 PM
  2. shkthx's Avatar
    I'm in the same boat as you are. I've read suggestions of getting a task manager through snap that can close Android apps that are still open in the background that BlackBerry OS doesn't list. That's what I'm going to try and do this weekend because I love the phone too but it's always running hot and actually makes my hand sweat and I have nothing open.

    Posted via CB10
    02-20-16 02:54 PM
  3. Zmain's Avatar
    I'm in the same boat as you are. I've read suggestions of getting a task manager through snap that can close Android apps that are still open in the background that BlackBerry OS doesn't list. That's what I'm going to try and do this weekend because I love the phone too but it's always running hot and actually makes my hand sweat and I have nothing open.

    Posted via CB10
    Please report back to us your findings.

    Posted via CB10
    02-20-16 03:22 PM
  4. Edijs Benoit's Avatar
    Try to drain your battery till it shuts off. Charge it to full again overnight and see what happens

    Posted via CB10
    02-20-16 03:31 PM
  5. Bompibomp's Avatar
    Ok, I will try that. Thanks
    02-20-16 03:47 PM
  6. shkthx's Avatar
    I also read that going back to a previous radio (2702?) helps as well but I've never tried that. I don't even know how to do that.

    Posted via CB10
    02-20-16 04:04 PM
  7. Bompibomp's Avatar
    It keeps asking me to download and install latest radio over and over again. Not sure why tho...
    02-20-16 04:22 PM
  8. Zeratul57's Avatar
    That doesn't sound good. Sounds like a bad install. You might have something broken in there. For sure going to work on standby after os work. Could nose dive within 2 weeks after a big os update and then be fine. It's a computer. It does need rebooted sometimes


    Posted from a wireless charging Passport. Get one!
    02-20-16 04:33 PM
  9. Bompibomp's Avatar
    I tried holding the volume buttons down until it rebooted. Not sure what that really does tho'
    02-20-16 04:38 PM
  10. Ben Christmann's Avatar
    My phone does the same thing. When connected to WiFi the battery is excellent. If I leave the WiFi area or select WiFi off my battery drains very fast. I have wiped and reinstalled the Os 3x. I don't have a data plan, but I select data on, so I can receive pics via text. As soon as I'm away from WiFi data on system spikes and kills battery. If data is selected off the battery is great again but I can't receive pics through text. Problem existed on 2474, 2813, and 2876. All apps deleted and it still doesn't help.
    02-20-16 05:21 PM
  11. Edijs Benoit's Avatar
    I tried holding the volume buttons down until it rebooted. Not sure what that really does tho'
    That's rebooting your hardware. Sometimes helps but like I said try to drain your battery

    Posted via CB10
    Bompibomp likes this.
    02-21-16 08:36 AM
  12. Bompibomp's Avatar
    Thanks alot!

    Draining worked. Down to 87% in 7hours with some usage - mostly FB and installing a new app. Was at my friends house for most of that time. When I came home it started draining a bit faster, but not critical. (Wi-Fi at both places).

    You think 5.0ghz drains more than 2.4ghz. Using 5.0ghz on my router.

    I will drain the phone one more time
    02-21-16 06:22 PM
  13. Edijs Benoit's Avatar
    Thanks alot!

    Draining worked. Down to 87% in 7hours with some usage - mostly FB and installing a new app. Was at my friends house for most of that time. When I came home it started draining a bit faster, but not critical. (Wi-Fi at both places).

    You think 5.0ghz drains more than 2.4ghz. Using 5.0ghz on my router.

    I will drain the phone one more time
    yes, try to switch to 2.4 it is plenty of speed for phone
    02-21-16 06:56 PM
  14. shawnreum's Avatar
    It keeps asking me to download and install latest radio over and over again. Not sure why tho...
    Sounds like you may not have the original OS installed. You mentioned that you did a factory reset. That's not the same as an OS reload, if you didn't know. Factory reset thru the system only resets the settings of the phone back to how it came from factory, but won't fix issues most of the time.

    Try doing an OS reload thru link, on a computer, than let us know.
    Bompibomp likes this.
    02-21-16 07:27 PM
  15. HDQ's Avatar
    If I turn off the cellular network, my ppse could last for more than 3 days.
    But with 4G network, the battery drains quickly, usually it only lasts for 1.5 days.
    Thus I think cellular is the battery killer, perhaps downgrade/upgrade (in the future) the radio might help.
    02-21-16 07:59 PM
  16. shakingthrough's Avatar
    I seem to have more battery drain when either my cell signal is weak or the wifi is poor at some public location. In both instances it makes me think the phone is "trying hard" to stay connected and transmit data, thus draining the battery quicker. I have no proof of my theory however, and am not even sure if it makes theoretical sense.

    Posted via CB10
    02-21-16 10:36 PM
  17. Bompibomp's Avatar
    Sounds like you may not have the original OS installed. You mentioned that you did a factory reset. That's not the same as an OS reload, if you didn't know. Factory reset thru the system only resets the settings of the phone back to how it came from factory, but won't fix issues most of the time.

    Try doing an OS reload thru link, on a computer, than let us know.
    Did a reload through link and it seems like it worked very well. No more questions about an update that has already been installed. I'm gonna drain the battery one more time, but it takes time now - hehe. At 50% now and it shows 1 day and 11hours left.

    Thanks a lot for the help Shawnreum
    02-22-16 10:03 PM

Similar Threads

  1. Priv battery life
    By Terry Mhlanga in forum BlackBerry Priv
    Replies: 48
    Last Post: 03-26-16, 03:21 PM
  2. Having a horrible battery day
    By blackbirdy in forum BlackBerry Priv
    Replies: 27
    Last Post: 02-23-16, 06:26 AM
  3. extra battery pack?
    By Brian Chapnick in forum BlackBerry Priv
    Replies: 4
    Last Post: 02-20-16, 11:26 PM
  4. Why standby consume more battery
    By madh263362 in forum BlackBerry Q10
    Replies: 3
    Last Post: 02-20-16, 07:12 PM
  5. App Manager and Battery life
    By cyclezib in forum BlackBerry Passport
    Replies: 4
    Last Post: 02-20-16, 03:24 AM
LINK TO POST COPIED TO CLIPBOARD