02-10-21 02:52 PM
32 12
tools
  1. ioan_calin's Avatar
    Thank you, David Leonard 45 and Dunt Dunt Dunt!!! It worked! Now I have a camera working really nice. The procedure of swaping cameras (and batteries, by the way) took 20 minutes. I have some guys in a phone repair shop close to me who are quite skilled. Now it feels like a new phone. Love my new (old) Passport Silver Edition!
    mh1983 and brookie229 like this.
    07-03-20 09:42 AM
  2. guizmox's Avatar
    Did the same. My Passport started to be unable to focus some weeks ago, I carefully disassembled it and switched the camera module with my spare device. Works perfectly now. Pretty easy. Took me ~15min


    Posted via CB10
    Radoslav Valkov likes this.
    07-22-20 02:24 AM
  3. tro316's Avatar
    Could you please help? I just replaced my rear facing camera on my blackberry passport sqw100-1 with a brand new part. After turning device back on and opened the camera app I got this message on my screen, “Camera Cannot Open”. Is there something that I’m missing in replacing this part? reset? Hard reset? Thanks for any help. My camera parts do match also BTW.
    02-09-21 09:57 PM
  4. m3ach's Avatar
    Could you please help? I just replaced my rear facing camera on my blackberry passport sqw100-1 with a brand new part. After turning device back on and opened the camera app I got this message on my screen, “Camera Cannot Open”. Is there something that I’m missing in replacing this part? reset? Hard reset? Thanks for any help. My camera parts do match also BTW.
    Did the camera work before you replaced it, in as much as you didn’t get the camera cannot open message?

    You may have a loose connection or maybe the new camera is a dud or damaged in transit?

    If the old camera did work but not properly you could try swapping it back to see if the problem persists.

    If the camera wasn’t working prior to replacement it may be a software problem so you could try reloading the OS using an autoloader to see if that clears the fault.
    tro316 likes this.
    02-10-21 05:22 AM
  5. tro316's Avatar
    Did the camera work before you replaced it, in as much as you didn’t get the camera cannot open message?

    You may have a loose connection or maybe the new camera is a dud or damaged in transit?

    If the old camera did work but not properly you could try swapping it back to see if the problem persists.

    If the camera wasn’t working prior to replacement it may be a software problem so you could try reloading the OS using an autoloader to see if that clears the fault.
    As for the connection with the new replacement, it seemed snug and I did feel the familiar click (I took apart and reinstalled 3 times to make sure) but unfortunately I still received the “Camera Cannot Open” message within the app. Just out of curiosity I opened another camera app (camera++) and it opened using the front facing camera (which I did not replace or has any issues) when I tried to switch it to the rear it would not switch. I did eventually switch the camera back to the old malfunctioning camera to see if the issue still persist and it does (weird audible shaky noises trying to focus and shaky images). The thing is it does accept the old but not the new. I did a side by side comparison and it appears all the tiny numbers match. I am sure it’s a hardware and not software, if anyone out there knows of something that I may have missed please help. I may just put my phone up for sale on eBay. The problem also is that I ordered the camera replacement from China and took too long to get to Arizona. I just don’t have the patience to wait for another shipment. Anyone want to swap for a keyone or keytwo?
    02-10-21 11:02 AM
  6. tro316's Avatar
    As for the connection with the new replacement, it seemed snug and I did feel the familiar click (I took apart and reinstalled 3 times to make sure) but unfortunately I still received the “Camera Cannot Open” message within the app. Just out of curiosity I opened another camera app (camera++) and it opened using the front facing camera (which I did not replace or has any issues) when I tried to switch it to the rear it would not switch. I did eventually switch the camera back to the old malfunctioning camera to see if the issue still persist and it does (weird audible shaky noises trying to focus and shaky images). The thing is it does accept the old but not the new. I did a side by side comparison and it appears all the tiny numbers match. I am sure it’s a hardware and not software, if anyone out there knows of something that I may have missed please help. I may just put my phone up for sale on eBay. The problem also is that I ordered the camera replacement from China and took too long to get to Arizona. I just don’t have the patience to wait for another shipment. Anyone want to swap for a keyone or keytwo?
    UPDATE: I took apart my Blackberry Passport SQW100-1 again just to double check the parts and I did see something inconsistent. There are some numbers on the camera module that are not the same, this most likely is the problem. The camera that came with the device (old one) reads /1451 4/V12/06 and the new one that I bought reads (new one) /1440 6/V12/08 . What a bummer. I don’t have the energy to go shop around for the correct one if that’s the case. Let me know you thoughts folks. I’ll post some pics. Thanks again. I did good at taking apart and putting it back together again at least. Anybody else have any problems with passport camera focusing?-img_8891.jpg
    02-10-21 02:51 PM
  7. tro316's Avatar
    As for the connection with the new replacement, it seemed snug and I did feel the familiar click (I took apart and reinstalled 3 times to make sure) but unfortunately I still received the “Camera Cannot Open” message within the app. Just out of curiosity I opened another camera app (camera++) and it opened using the front facing camera (which I did not replace or has any issues) when I tried to switch it to the rear it would not switch. I did eventually switch the camera back to the old malfunctioning camera to see if the issue still persist and it does (weird audible shaky noises trying to focus and shaky images). The thing is it does accept the old but not the new. I did a side by side comparison and it appears all the tiny numbers match. I am sure it’s a hardware and not software, if anyone out there knows of something that I may have missed please help. I may just put my phone up for sale on eBay. The problem also is that I ordered the camera replacement from China and took too long to get to Arizona. I just don’t have the patience to wait for another shipment. Anyone want to swap for a keyone or keytwo?
    Anybody else have any problems with passport camera focusing?-img_8845.jpg
    02-10-21 02:52 PM
32 12

Similar Threads

  1. Bluetooth Stream Problems
    By joejuck in forum BlackBerry Android OS
    Replies: 3
    Last Post: 08-31-17, 04:48 PM
  2. Replies: 8
    Last Post: 07-21-17, 11:51 PM
  3. Camera sound issue after update
    By claudioh in forum BlackBerry DTEK60
    Replies: 4
    Last Post: 07-20-17, 08:42 AM
  4. Replies: 4
    Last Post: 07-17-17, 09:23 PM
  5. KeyONE Keyboard -- Doesn't light up under any way!
    By gskv in forum BlackBerry KEYone
    Replies: 2
    Last Post: 07-16-17, 06:02 PM
LINK TO POST COPIED TO CLIPBOARD