1. brian4591's Avatar
    Just switched from Z10 to Passport and all my android apps won't load now. See attached picture of the loading screen that doesn't do anything.
    Android apps not loading-img_20141208_104329.png

    Posted via CB10
    12-08-14 01:47 PM
  2. vvvhhh8's Avatar
    First launch is always a little bit longer. Have you tried to delete the app and install it once more?
    Which OS where you running on your z10?
    12-08-14 02:21 PM
  3. brian4591's Avatar
    Thanks for the reply. I deleted one app and tried re-installing but the install just hangs. See attached.
    Android apps not loading-img_20141208_112901.png

    Posted via CB10
    12-08-14 02:29 PM
  4. vvvhhh8's Avatar
    I suggest a hard reset of the phone, and then try to install an android app.
    12-09-14 02:28 AM
  5. civilian101's Avatar
    I loaded OS 3.1.1154 on my Z30 using the Blitz method a few days ago and experienced this problem after doing the same on my old STL100-1 Z10 without any issues.
    After a few days of reading and trying every thing I could find on this topic with no success, I finally backed up my device using Link and loaded the leak using an autoloader which obviously deleted the data and reset the device.
    The process was surprisingly painless as I was able to recover my BBM chat history, wifi logins, contacts and game and app data from the selective restore of the BB Link backup.
    Good news is that my Z30 is now running buttery smooth on 10.3.1.1154 with no problems with Android apps. The only thing which I know was different between my Z10 and the Z30 was that I had loaded a modified apk on the Z30 to facilitate running android apps patched to remove the dependency on Google services using Lucky Patcher.
    12-11-14 09:45 AM
  6. kamarov's Avatar
    Did you restore from a backup? If you did, you might have made the same mistake I did and restored the Blackberry Runtime (since 10.3 has a different Android runtime). I did a factory reset, restored from my Z10 backup, deselecting BlackBerry Runtime, and everything was back to normal.

    Posted via CB10
    brian4591 likes this.
    12-11-14 11:23 PM
  7. rebroker2009's Avatar
    Reinstall the amazon app directly from their site, this will fix your issue


    Blackberry Passport running 10.3.1.1151
    12-11-14 11:25 PM
  8. SaxManJim's Avatar
    I'm experiencing the same problem on my Z10. Can't reinstall the amazon app from their site, the install hangs on "Initializing". I may try a backup/reset/restore to see what happens.
    12-17-14 07:58 AM
  9. brian4591's Avatar
    This happened to me again. Going from Passport to Passport.

    My fix:
    - full backup with BlackBerry Link
    - installed a new leaked OS (could have just wiped phone and just gone back to official OS)
    - restored backup made with BlackBerry Link but de-selected the "BlackBerry Runtime" app out of the list of apps to restore

    This fixed my problem. Android apps all run again

    Posted via CB10
    02-11-15 12:51 AM

Similar Threads

  1. How do I get my previous OS back?
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 04-18-15, 05:06 AM
  2. I converted an android user to the blackberry passport
    By Sandrot in forum General BlackBerry Discussion
    Replies: 24
    Last Post: 12-09-14, 10:01 AM
  3. Z30 with Xfinity apps and HDMI output
    By kjjb0204 in forum BlackBerry Z30
    Replies: 7
    Last Post: 12-09-14, 06:37 AM
  4. Replies: 3
    Last Post: 12-08-14, 04:21 PM
  5. Post FLASH Websites that do not work on 10.3.1 here!!!
    By khehl in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 12-08-14, 12:17 PM
LINK TO POST COPIED TO CLIPBOARD