1. Jonesy1966's Avatar
    So I finally got my Passport yesterday and I've got to say I'm more impressed by it than I thought I would be. The only issue I have with it so far is with the Amazon app, when I try to open it, it asks for permissions, I hit OK and the app just fails, doesn't even attempt to open. Of course, you can't delete it to reload, that would be too simple!

    I'm not really that worried as I mostly use Snap, but I do like to check out Amazon every now and then for the free apps. Any thoughts?

    SQW100-1 10.3.0.1154

    TIA
    10-17-14 08:31 AM
  2. robsteve's Avatar
    Just download the Amazon appstore from the Amazon web site and reinstall. A few people have had this problem.

    http://www.amazon.com/gp/mas/get-app...UvbUpU10980710
    Jonesy1966, ianbordas and EsJayDee like this.
    10-17-14 08:34 AM
  3. Variante Alta's Avatar
    Same...download the newer Store app and everything works great.

    Posted via CB10
    Jonesy1966 likes this.
    10-17-14 08:35 AM
  4. Jonesy1966's Avatar
    I wasn't sure if I could download the app with an existing app already on board.

    Thanks for this!

    Posted via CB10
    10-17-14 09:03 AM
  5. DecAway's Avatar
    Did you fix the issue?

    Posted via CB10
    Jonesy1966 likes this.
    10-17-14 10:45 PM
  6. Stomps01's Avatar
    The problem could be that you did a full restore and for some reason causes the Amazon apstore and android apps to fail. I had to do a factory reset then did a partial restore of contacts, remember app files, etc... and left out restoring apps. Another tine i did the up and down arrow reboot and that worked. I suggest trying that first. Lol

    Posted via CB10
    Jonesy1966 likes this.
    10-18-14 02:36 AM
  7. Jonesy1966's Avatar
    Did you fix the issue?

    Posted via CB10
    I did, thank you Just ran the update and all is well.
    10-18-14 08:22 AM
  8. mousii's Avatar
    Thank you for the answer and also including the link . It fixed the issue for me too.
    01-11-15 07:44 PM
  9. dale-c's Avatar
    Yep. Had the same issue. This fixed it.

    Posted via CB10
    01-11-15 09:53 PM
  10. Arun67's Avatar
    Hey dude
    even I have the same problem..
    It showed as "unfortunately stopped working"
    But the solution which you gave dint work out...
    Help me out please...
    I have my BlackBerry passport...
    01-17-15 09:32 AM

Similar Threads

  1. Night mode is not working on 10.3.1.6132 on z3
    By madh263362 in forum BB10 Leaked/Beta OS
    Replies: 2
    Last Post: 10-20-14, 03:10 PM
  2. How to find out the PRD from the Passport? (For Unlocking)
    By Blackerthanblack in forum BlackBerry Passport
    Replies: 4
    Last Post: 10-18-14, 02:57 AM
  3. Why wont it pass 100 on the reboot screen?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-14, 08:21 AM
  4. How do you install Kakaotalk on the BB Z3?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-14, 07:40 AM
LINK TO POST COPIED TO CLIPBOARD