1. DecAway's Avatar
    Is anyone else having this problem? Mine just sits there saying "initializing" until I finally close the app. Anyone know of a way to reload the app without having to reset the OS?

    Posted via CB10
    10-17-14 02:13 PM
  2. Carl Estes's Avatar
    I believe you can uninstall the app, then re-install it.
    No need to reload the OS.
    10-17-14 02:41 PM
  3. DecAway's Avatar
    I have no idea how to uninstall it. It's a core bb10 app that you can't hold down on the icon and delete.

    Posted via CB10
    10-17-14 02:47 PM
  4. robsteve's Avatar
    Just download it from Amazon and reinstall.

    Install Amazon Appstore
    10-17-14 02:48 PM
  5. beamerboym3's Avatar
    Yes, Robsteve's suggestion might work. Mine always just crashed and disappeared when I transfered data to my Z30. Posted a thread on this last week. Your right about being a core app and can't delete it. I just did a factory reset (reload) of OS and did a custom restore, for try the app, "device switch". Then transfer your data that way from a fresh phone. If you restore your phone from a previous back up, your going to have problems. Still had lingering issues with my contacts but resolved them through email account contact sink.

    Posted via CB10
    10-17-14 03:05 PM
  6. beamerboym3's Avatar
    Meant "from my Z30".

    Posted via CB10
    10-17-14 03:06 PM
  7. DecAway's Avatar
    I tried downloading the app and installing it and still didn't fix it. I even shut the phone down, and then attempted a 2nd reinstall. No dice.

    Posted via CB10
    10-17-14 04:30 PM
  8. DecAway's Avatar
    Ok, I fixed it! I'm a genius!

    Posted via CB10
    10-17-14 09:06 PM
  9. Munx's Avatar
    I am having the same issue. How did you resolve it?

    Posted via CB10
    10-17-14 11:38 PM
  10. Munx's Avatar
    Fixed. I just downloaded and reinstalled.

    Posted via CB10
    10-17-14 11:41 PM
  11. DecAway's Avatar
    I found out that mine wasn't working because I confused amazon app store by downloading the kindle reader app and logging in with a different account. For whatever reason, the kindle app would login but the app store would fail to initialize. I took a gamble and went into the kindle app and logged out and then logged in with the same email account that was registered with amazon app store and bam, it worked!

    Posted via CB10
    10-18-14 06:55 AM
  12. jthep's Avatar
    Having problems with the Amazon appstore in that it asks for permission in location, pics, etc. and when I accept, it crashes! Every time! I tried deleting it and that won't work and I have been unable to install it again. I logged out of all amazon related apps from kindle, prime video, and the amazon shopping app. Prime video never worked either, but kindle and the shopping app did work.

    I guess I will just dl android apps from apktrain.com from now on? Just can't get amazon appstore to work....

    Posted via CB10
    10-20-14 02:13 PM
  13. ndallari's Avatar
    Fixed it.
    Went to Settings> Appmanager and selected Appstore app.
    Selected Clear Data.
    Restarted App and it is working now.

    11-03-15 05:13 PM

Similar Threads

  1. Why is Apollo no longer available on my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 12-04-14, 09:14 AM
  2. Official response on US VIP orders
    By Chad Elbandagji in forum BlackBerry Passport
    Replies: 16
    Last Post: 10-17-14, 06:23 PM
  3. Passport not showing on Canadian site
    By bbjdog in forum BlackBerry Passport
    Replies: 7
    Last Post: 10-17-14, 02:22 PM
  4. How do I recover the password om my BBM?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-14, 02:18 PM