07-01-15 12:45 PM
46 12
tools
  1. Poi25's Avatar
    I've been dealing with this for awhile, but maybe there's nothing I can do if I use Gmail. I have my own .com and signed up for Google Apps when it was free a few years ago. So I'm on the "grandfathered" plan without ActiveSync. Maybe the only way to fix this is to migrate over to Outlook and use them for email with my own domain.

    We all know Google's IMAP situation with archived mail is weird. I set up the Gmail server settings to send deleted mail within Hub to trash instead of archive. Then I went into Gmail and created a folder/label called "Archive" which I tagged to every single piece of email that's Sent/All Mail. This way, when syncing all folders within Hub, I can file emails and archive them (hope this makes sense).

    However, I cannot search for any emails unless they're in my Inbox. The "Remote search" function returns no results as well. The only way I can search for an archived piece of mail is if I go to the dropdown, select "Archived" under the specific email account (where you select folders), wait for it to load, and then search. It's annoying and tedious.

    Is my best option to just migrate my email over to a paid service?
    06-27-15 04:27 PM
  2. shawnreum's Avatar
    Sounds like you just need to get things to auto sync to your phone. If that means you have to go paid service, then I would have to say go paid service.

    Posted via CB10
    06-28-15 08:27 AM
  3. Poi25's Avatar
    Sounds like you just need to get things to auto sync to your phone. If that means you have to go paid service, then I would have to say go paid service.

    Posted via CB10
    Syncing is not the problem, even without ActiveSync it polls the server every 5 minutes and sync my emails (setting within Hub). I was giving my description of the service so people knew which version of Google Apps I was using.

    My question surrounds searching within all email.

    I can't be the only one dealing with this.

    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    06-28-15 12:37 PM
  4. robsteve's Avatar
    Can you pay to get active sync on your Gmail account?

    Outlook.com will no longer allow you to host your own domain . You now have to use the paid Office365 if you want to host your own domain.

    Posted via CB10
    06-29-15 05:32 AM
  5. Zmain's Avatar
    I've been dealing with this for awhile, but maybe there's nothing I can do if I use Gmail. I have my own .com and signed up for Google Apps when it was free a few years ago. So I'm on the "grandfathered" plan without ActiveSync. Maybe the only way to fix this is to migrate over to Outlook and use them for email with my own domain.

    We all know Google's IMAP situation with archived mail is weird. I set up the Gmail server settings to send deleted mail within Hub to trash instead of archive. Then I went into Gmail and created a folder/label called "Archive" which I tagged to every single piece of email that's Sent/All Mail. This way, when syncing all folders within Hub, I can file emails and archive them (hope this makes sense).

    However, I cannot search for any emails unless they're in my Inbox. The "Remote search" function returns no results as well. The only way I can search for an archived piece of mail is if I go to the dropdown, select "Archived" under the specific email account (where you select folders), wait for it to load, and then search. It's annoying and tedious.

    Is my best option to just migrate my email over to a paid service?
    Try Typemail it's Android app works really well.

    Posted via CB10
    06-29-15 07:09 AM
  6. Poi25's Avatar
    Can you pay to get active sync on your Gmail account?

    Outlook.com will no longer allow you to host your own domain . You now have to use the paid Office365 if you want to host your own domain.

    Posted via CB10
    To tell you the truth, I am unsure if the ActiveSync issue is even the problem. Starting January 30, 2013 Google transitioned to GoogleSync which is based off of ActiveSync protocol. Legacy Google Apps users (free version) don't have that functionality but it still works simply off IMAP.

    Do you use Gmail? All I want to do is search all my email within Hub. All my folders are selected to sync, so I feel like it should work.

    But the only way for me to access the archived mail is to browse to that folder and then search. Universal search is broken.

    Try Typemail it's Android app works really well.

    Posted via CB10
    Absolutely zero interest in using an Android application when the Hub is far superior.

    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    06-29-15 08:37 AM
  7. jeffawa's Avatar
    I also have a standard Google Apps account and use the IMAP remote search function on my Blackberry. OP I get the same results as you. The default search for the inbox only. Only way around is to open up sub folders in bb10 and search. I did upgrade my account for the 30 day trial to Business Google Apps and implemented the active sync (google sync) protocol and the search results were no different. I switched back to the standard version and IMAP because the only benefit of the paid version would have been if remote search of all folders was enabled.

    The missing feature is to have the ALL MAIL folder accessible through the blackberry hub. I don't know if this is a blackberry or Google limitation.
    06-29-15 09:20 AM
  8. Poi25's Avatar
    I also have a standard Google Apps account and use the IMAP remote search function on my Blackberry. OP I get the same results as you. The default search for the inbox only. Only way around is to open up sub folders in bb10 and search. I did upgrade my account for the 30 day trial to Business Google Apps and implemented the active sync (google sync) protocol and the search results were no different. I switched back to the standard version and IMAP because the only benefit of the paid version would have been if remote search of all folders was enabled.

    The missing feature is to have the ALL MAIL folder accessible through the blackberry hub. I don't know if this is a blackberry or Google limitation.
    Finally, someone else using the same setup! Thanks for responding jeffawa. That's weird regarding the search feature. I'm inclined to say that it'sa limitation with Gmail. I'm curious if paid Outlook users have no issues.

    Here's what to do regarding the All Mail issue. I mentioned it in the OP but I'll go into bigger detail.

    Basically, Gmail's implementation of All Mail (Archiving) is weird, because it assigns what seems to be an invisible label to email messages. So on BlackBerry devices or anything other than Gmail itself, those services can't find them. A workaround is to create a label/folder called Archived (or whatever you want to call it). Go into Gmail on your desktop and filter your email to select every single All Mail (Archived) message. I included Sent Mail just to keep everything semi-consolidated.

    Label/File every single one of these messages to the new Archived label/folder. Now, all the All Mail messages within Gmail will have a folder you can sync using the Hub.

    If you use Gmail desktop, instead of hitting the Archive button from now on, file messages to the new Archived folder. If you download the Advanced Shortcuts Google Labs extension within Gmail, you can set up the keyboard shortcut (v + down arrow to select + enter) to quickly file the emails.

    This allows you to at least pull up all your archived Gmail messages within the Hub, but again, the universal search I made this thread about doesn't work.
    06-29-15 09:34 AM
  9. robsteve's Avatar
    Finally, someone else using the same setup! Thanks for responding jeffawa. That's weird regarding the search feature. I'm inclined to say that it'sa limitation with Gmail. I'm curious if paid Outlook users have no issues..
    I tried a search on my Outlook account that is set up as active sync. It remote searched all the folders I had, not sure if it searches the junk folder. Just to be clear, I used the search in the hub, not the universal search.

    The word I searched for was from last year and I knew it related to emails in a separate folder. The emails would not have been on my phone as I stopped syncing forever, as remote search seems to do the job when I need an old email.

    Back to your problem, since you now have an archive folder, if you use active sync, it should search that folder along with the rest of the folders unless Google has done something different with their active sync implementation. I do not use Gmail, so can't test anything on my end.
    06-29-15 12:31 PM
  10. amacw's Avatar
    Same set up and same problem. Sorry to be unhelpful but I'm hoping that maybe someone can brainstorm through this with results.

    Posted via CB10
    06-29-15 01:47 PM
  11. Poi25's Avatar
    Back to your problem, since you now have an archive folder, if you use active sync, it should search that folder along with the rest of the folders unless Google has done something different with their active sync implementation. I do not use Gmail, so can't test anything on my end.
    My sync settings are set to forever and to poll the server every 5 minutes. Considering I'm syncing all folders, including the new Archived folder that includes all the Gmail "archived" messages, after the initial sync, it SHOULD be able to search the folder.

    What I meant by universal search was search within Hub, not from the homescreen; exactly like you said.

    ActiveSync or not, I would think after syncing a folder to "Forever," it should have all the messages and just sync current changes.

    Maybe this is a Gmail issue.


    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    06-29-15 02:07 PM
  12. shawnreum's Avatar
    Here's a screen shot of my settings on gmail.
    Like you said if I set Gmails settings to archive, all my deleted emails go to the archived folder. And archive was how I first had it set up, but my Passport was getting over loaded with archived email. So I switched mine to delete copy.
    Advanced Hub email searching question (those using Gmail with archive settings already established) Can I get some help?-img_20150626_210408.png

    The following is a screen shot of folder sync.
    But you will have the archived folder also.
    Advanced Hub email searching question (those using Gmail with archive settings already established) Can I get some help?-img_20150626_205038.png

    If you can't seem to get into the correct settings than I'll walk you thru them later.
    Also there are a few other settings I know of that it could be, which we can go over later if you can't get it based on my screen shots.

    Posted via CB10
    06-29-15 07:40 PM
  13. Poi25's Avatar
    Here's a screen shot of my settings on gmail.
    Like you said if I set Gmails settings to archive, all my deleted emails go to the archived folder. And archive was how I first had it set up, but my Passport was getting over loaded with archived email. So I switched mine to delete copy.
    Click image for larger version. 

Name:	IMG_20150626_210408.png 
Views:	498 
Size:	214.4 KB 
ID:	360039

    The following is a screen shot of folder sync.
    But you will have the archived folder also.
    Click image for larger version. 

Name:	IMG_20150626_205038.png 
Views:	498 
Size:	66.6 KB 
ID:	360042

    If you can't seem to get into the correct settings than I'll walk you thru them later.
    Also there are a few other settings I know of that it could be, which we can go over later if you can't get it based on my screen shots.

    Posted via CB10
    Shawn, I already established that settings within Gmail and Hub are correct. By the way, the screenshot of your Gmail is reflecting archiving, not deleting. Unless you're using POP on your Passport and not IMAP, your IMAP settings (Auto Expunge ON and Archive the message) will archive emails when you delete them from the Hub, not send them to the trash.

    You need auto-expunge OFF and Move the message to the Trash to send Gmail's copy to the trash when you delete from the Hub.
    06-29-15 08:18 PM
  14. shawnreum's Avatar
    No they go to my trash on gmail.
    I double checked it.
    Also I believe I'm running imap
    As the emails address is imap.gmail.com

    Then once there in my trash folder I just leave them there. Anything older than 30 days old gets removed from Gmail. And the trash folder of the Passport isn't set to auto sync the trash folder so it's kept off my phone.

    Posted via CB10
    06-29-15 09:28 PM
  15. BeetrootJulip's Avatar
    Here's a screen shot of my settings on gmail.
    Like you said if I set Gmails settings to archive, all my deleted emails go to the archived folder. And archive was how I first had it set up, but my Passport was getting over loaded with archived email. So I switched mine to delete copy.
    Click image for larger version. 

Name:	IMG_20150626_210408.png 
Views:	498 
Size:	214.4 KB 
ID:	360039

    The following is a screen shot of folder sync.
    But you will have the archived folder also.
    Click image for larger version. 

Name:	IMG_20150626_205038.png 
Views:	498 
Size:	66.6 KB 
ID:	360042

    If you can't seem to get into the correct settings than I'll walk you thru them later.
    Also there are a few other settings I know of that it could be, which we can go over later if you can't get it based on my screen shots.

    Posted via CB10
    Question about what you said above:

    You said that you switched from archiving mail upon delete to deleting mail upon delete because your Hub was getting overloaded with archived mail.

    I have my mail set to archive upon delete, and it works (shows in archived All Mail) on Gmail. But I cannot access All Mail/archive in Hub. How are you doing this?

    Thanks.

    Posted via CB10
    06-29-15 09:44 PM
  16. BeetrootJulip's Avatar
    Here's a screen shot of my settings on gmail.
    Like you said if I set Gmails settings to archive, all my deleted emails go to the archived folder. And archive was how I first had it set up, but my Passport was getting over loaded with archived email. So I switched mine to delete copy.
    Click image for larger version. 

Name:	IMG_20150626_210408.png 
Views:	498 
Size:	214.4 KB 
ID:	360039

    The following is a screen shot of folder sync.
    But you will have the archived folder also.
    Click image for larger version. 

Name:	IMG_20150626_205038.png 
Views:	498 
Size:	66.6 KB 
ID:	360042

    If you can't seem to get into the correct settings than I'll walk you thru them later.
    Also there are a few other settings I know of that it could be, which we can go over later if you can't get it based on my screen shots.

    Posted via CB10
    Said another way, I do NOT have the Archive or All Mail folders available to sync to Hub. I have my settings set like you said: Auto-Expunge On and Archive when deleting.

    But no Archive or All Mail folders available to sync!

    Posted via CB10
    06-29-15 09:51 PM
  17. emanuel0ss0's Avatar
    OP, I set my Gmail email on my Passport to have all my emails on my device. I have emails dating back to 2009 on my device. Is this what you mean or am I missing something?

    Post via my Awesome Red Passport running on T-Mobile Unlimited Data. SQW100-1/10.3.2.680
    06-29-15 10:41 PM
  18. shawnreum's Avatar
    Do you see that folder mapping icon at the bottom of the screen shot?
    If I remember correctly, go into it.
    Select the trash drop down.
    Look for the archive folder if available.

    If not available, than it may have been removed from your Gmail.
    If I remember correctly under general tabs I think the setting send and archive button in reply.
    Turn it on. And try sending / archiving an email to create an archive folder in Gmail.


    Advanced Hub email searching question (those using Gmail with archive settings already established) Can I get some help?-img_20150629_233608.png

    Posted via CB10
    06-29-15 10:46 PM
  19. Poi25's Avatar
    No they go to my trash on gmail.
    I double checked it.
    Also I believe I'm running imap
    As the emails address is imap.gmail.com

    Then once there in my trash folder I just leave them there. Anything older than 30 days old gets removed from Gmail. And the trash folder of the Passport isn't set to auto sync the trash folder so it's kept off my phone.

    Posted via CB10
    No idea how that's happening, because the settings you showed in Gmail are the default settings that need to be changed because they cause email to be archived, not deleted. And they're the settings for POP, look at your screen shot again.

    Look in any other thread on the subject and what I'm say will be repeated.

    Now this thread is turning into that. I just want search functionality.

    "All Mail" folder will never be visible from the Passport, unless you create an additional "Archived" folder and tag all the messages like I said in a previous post. Doesn't matter if you show/hide the label or select Show in IMAP on Gmail's settings, it still doesn't show up.

    Advanced Hub email searching question (those using Gmail with archive settings already established) Can I get some help?-untitled-1.jpg

    To clarify even more, I think you should re-read the differences between POP and IMAP. In your POP settings, you chose to delete Gmail's copy when ACCESSING an email downloaded through POP protocol. That downloads the message to your client (whatever is using POP) and deletes the copy on Gmail's server. What you then do on the client side with that message is unrelated to Gmail. This literally has NOTHING TO DO with what I am asking about. These settings don't even affect the Hub in any way because they are POP settings and talk about accessing an email message, not deleting it.

    You have the absolute standard IMAP settings, so your mail should be archiving and not deleting on Gmail's end when deleting from your Hub. Some other magical settings are enabled, or something really strange is going on.

    Telling people to edit a setting that has to do with POP and doesn't even have to do with the topic at hand doesn't fix this issue.


    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    Last edited by Poi25; 06-30-15 at 12:04 AM.
    06-29-15 11:27 PM
  20. Poi25's Avatar
    OP, I set my Gmail email on my Passport to have all my emails on my device. I have emails dating back to 2009 on my device. Is this what you mean or am I missing something?

    Post via my Awesome Red Passport running on T-Mobile Unlimited Data. SQW100-1/10.3.2.680
    Syncing is not my question. Try searching for an old piece of email from the top level of Hub. The search will return empty, that's what I'm referring to.

    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    06-29-15 11:37 PM
  21. shawnreum's Avatar
    No idea how that's happening, because the settings you showed in Gmail are the default settings that need to be changed because they cause email to be archived, not deleted. And they're the settings for POP, look at your screen shot again.

    Look in any other thread on the subject and what I'm say will be repeated.

    Now this thread is turning into that. I just want search functionality.

    "All Mail" folder will never be visible from the Passport, unless you create an additional "Archived" folder and tag all the messages like I said in a previous post. Doesn't matter if you show/hide the label or select Show in IMAP on Gmail's settings, it still doesn't show up.

    Click image for larger version. 

Name:	Untitled-1.jpg 
Views:	217 
Size:	256.8 KB 
ID:	360080

    To clarify even more, I think you should re-read the differences between POP and IMAP. In your POP settings, you chose to delete Gmail's copy when ACCESSING an email downloaded through POP protocol. That downloads the message to your client (whatever is using POP) and deletes the copy on Gmail's server. What you then do on the client side with that message is unrelated to Gmail. This literally has NOTHING TO DO with what I am asking about. These settings don't even affect the Hub in any way because they are POP settings and talk about accessing an email message, not deleting it.

    You have the absolute standard IMAP settings, so your mail should be archiving and not deleting on Gmail's end when deleting from your Hub. Some other magical settings are enabled, or something really strange is going on.

    Telling people to edit a setting that has to do with POP and doesn't even have to do with the topic at hand doesn't fix this issue.


    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    Those are my settings and things work for me on my phone. They used to archive to a folder that would never delete off my Gmail account and sync like crazy to my phone where I was able to search through them, but now they don't and go to trash instead.

    I don't care what your pointing out. As what your pointing out is the settings I have used and adjusted and things work for my use now. Which I'm trying to reverse what settings I have changed.
    So arguing that is pointless on your end and a waste of time on your end also.

    Your having sync issues and that's simple to see.
    I know your position on this site, seen you in many threads, and know you tend to troll rather than want to try using someone's help or helping others. You think you know all and that's that.

    Enjoy you day and good luck.
    There's no help for those who don't want.

    For those who want help, open a new thread, let this be.
    Or shoot over a message

    Posted via CB10
    06-30-15 05:28 AM
  22. Poi25's Avatar
    Your having sync issues and that's simple to see.
    I know your position on this site, seen you in many threads, and know you tend to troll rather than want to try using someone's help or helping others. You think you know all and that's that.
    The thing is, I'm not having sync issues. I clearly stated that in this thread, but you took it off course and that's what the thread has become now, questions about archiving/deleting Gmail messages.

    I'm not trolling you, I'm pointing out that you're mistaken about the settings. I don't know all, and to humor you I set my settings exactly how your Gmail settings are. Guess what? It started archiving messages again.

    You also pointed out a setting about a reply all button, thinking that somehow has to do with the Hub. You do realize that's a Gmail setting, correct? It doesn't change anything on a BlackBerry device.

    I'm trying to fix search, not what we've talked about for the past bunch of replies.

    For your viewing pleasure:

    http://m.crackberry.com/how-get-gmai...hout-archiving

    http://forums.crackberry.com/blackbe...emails-969022/

    That's just 2, you can pull up more in a search. Again, not trolling, just pointing out that you're an anomaly, because the settings that work for you don't work for anyone else.

    BlackBizzle my nizzle // SQW100-1 // 10.3.2.798 // Cricket Wireless
    06-30-15 09:10 AM
  23. shawnreum's Avatar
    The only way I can search for an archived piece of mail is if I go to the dropdown, select "Archived" under the specific email account (where you select folders), wait for it to load, and then search. It's annoying and tedious.
    Sorry to say, but that's an autosync issue with the folder your trying to search in. I have many folders I don't have to go into, and still pulls up when I do a search from the main inbox.
    Your archive folder is not refreshing/sync and when you enter it is when it does.
    So if you still don't believe it's an auto sync issue than I don't know what to tell you.

    But I will tell you this. You have to get that specific folder to auto sync in the background and load the emails to the phone before you can search thru it without having to open it up each time.

    If you can get it to auto sync the emails to the phone in the background for that specific folder, than you'll be able to search it from the main email.

    BTW, I showed that Gmail info because the other user said he couldn't find the archive folder. And I know I removed mine from Gmail, just can't remember 100% how I did, but I know I did it thru gmail. Thought that gmail setting was the one I switched to accomplish it.


    Posted via CB10
    06-30-15 09:38 AM
  24. Poi25's Avatar
    Sorry to say, but that's an autosync issue with the folder your trying to search in. I have many folders I don't have to go into, and still pulls up when I do a search from the main inbox.
    Your archive folder is not refreshing/sync and when you enter it is when it does.
    So if you still don't believe it's an auto sync issue than I don't know what to tell you.

    But I will tell you this. You have to get that specific folder to auto sync in the background and load the emails to the phone before you can search thru it without having to open it up each time.

    If you can get it to auto sync the emails to the phone in the background for that specific folder, than you'll be able to search it from the main email.
    Do you use paid Google Apps? For my email account, like I said, I set up sync settings to forever, and server refresh to 5 minutes. When I did that at first, I could actively see the Hub processing emails.

    If I go to the dropdown menus for the email account, and select "Archived," for example, all the emails are there, dating back to 2009. So they are "synced" for all intents and purposes. If I'm in the Archived folder view, I can then search for emails no problem.

    The problem arises when I try to conduct the same search from the top level of Hub. It then returns nothing.
    06-30-15 09:53 AM
  25. shawnreum's Avatar
    At the top drop down. If you go to Gmail, tap the + and drop all sub folders down. What color is the folder your trying to search in? Blue or green?

    Posted via CB10
    06-30-15 10:14 AM
46 12

Similar Threads

  1. Getting emails 3 seconds late on the classic....
    By bap3221 in forum General BlackBerry Discussion
    Replies: 42
    Last Post: 06-29-15, 01:17 PM
  2. WTS: Verizon BlackBerry Q10 with extras
    By Jiggy1971 in forum The Marketplace - Buy, Sell & Trade
    Replies: 5
    Last Post: 06-29-15, 10:03 AM
  3. BB Blend - Question and warning
    By TTQ225 in forum BlackBerry Z30
    Replies: 9
    Last Post: 06-28-15, 11:18 AM
  4. Forwarding an email as a text msg.
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 06-27-15, 04:31 PM
  5. Why does the app have so much trouble with images?
    By Technarch in forum CrackBerry Apps
    Replies: 0
    Last Post: 06-27-15, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD