1. KombatVirus's Avatar
    Hey everybody,

    I recently bought a beautiful new car, a fully loaded 2013 Accord v6 coupe. When I rented a newer 2013+ civic a while back, with the same navigation system, it had an extremely useful feature which would allow the system to read your text messages and reply with voice commands. In my profession, this is extremely useful and a major feature. However, it doesn't work properly

    Now in the civic, it was working flawlessly. For whatever reason, in the accord it does not. I read up on some threads on the car forums, and it comes down to a fault with the phone not Honda's system. I found how to fix the iPhone for proper operation, but absolutely no information for the passport. That is why I am posting here as a last ditch effort.

    I have tried re-pairing the device to the car with no success. On the lock screen it shows the car does have SMS access. My text message app is also extremely glitchy and slow when the phone is connected, indicating some kind of access attempting to be made. When I try to open my SMS inbox on my car, it also comes up as blank with a longer than usual loading time

    Keep in mind that all other bluetooth functions are properly operating. Contacts, phone calls, music, everything else displays properly except for SMS which is critical for me

    Please let me know if you have any ideas!
    07-22-15 04:38 PM
  2. NYCDweller's Avatar
    Hello and congrats on your new ride. I miss my 2005 Accord Coupe v6 6MT.

    My Passport paired with my Infiniti q50 flawlessly. I did run into an issue where I had to delete and pair again since I renamed my device. Is the is the case with you?

    If not, try disconnecting the car battery so the codes will clear. Assuming this is a pre-owned car it may be recognizing the previous owners setups causing confusion (even though it may not show on your navi screen). Before disconnecting the battery be sure to have your radio code handy and the unlock button on your key pad ready to press in case the alarm goes off when the battery is reconnected.

    Have you try rebooting your Passport?
    07-22-15 05:06 PM
  3. KombatVirus's Avatar
    Thank you for the suggestions

    I have deleted all the previous set profiles, as well as reset the whole car's system. I am certain this is not on the car side of things, but the passport itself. I have rebooted it many times and tried re-pairing as well. I am about to try removing access to all my email accounts and such and only leaving SMS enabled, perhaps that was confusing the car, and re pairing.
    07-22-15 05:55 PM
  4. KombatVirus's Avatar
    I have tried what I said above, as well as the fixes NYCDweller suggested with no luck. It just does not display the texts and slows down my text messaging app greatly. Under the settings however, I noticed that "push object" is stated as not connected, not sure if this could be the cause and there is no toggle to turn it on. The phone states the car has SMS access.

    I really need help Blackberry community, this is an amazing feature and very critical for me!
    07-23-15 12:38 AM
  5. NYCDweller's Avatar
    I have tried what I said above, as well as the fixes NYCDweller suggested with no luck. It just does not display the texts and slows down my text messaging app greatly. Under the settings however, I noticed that "push object" is stated as not connected, not sure if this could be the cause and there is no toggle to turn it on. The phone states the car has SMS access.

    I really need help Blackberry community, this is an amazing feature and very critical for me!
    interesting - do you have another car to see if the phone pairs? if all else fails try giving BB support a call. they will have you send them your activity log for review (if they don't request that they do). The process is painless since they guide you through the process and it is done directly from your phone.

    So you get an idea of the simplicity of this; you go to: help icon > pull down screen > create report

    The tech will tell you what to report and will confirm receipt. This will give them a visual of how your device is interacting or lack of interaction. Kind of like hooking your car up to an OBD2 scanner.

    tech number is 877-552-5532

    keep us/me posted on this...
    07-23-15 02:37 PM
  6. nomi1978's Avatar
    I had a similar issue with my passport and my 2013 nissan Altima. I was constantly getting a White screen or it took a long time to load messages. I had to reload the software and everything started working as expected.

    Now with my z30 I find sometimes the system message about the good morning and how many unread messages I have causes my Altima system to freeze up. I have turned off those notifications.

    Hope that helps.

    Posted via CB10
    07-23-15 02:47 PM
  7. KombatVirus's Avatar
    After many more hours of trying to get it work, flipping settings around, etc. Still no luck on getting the SMS/Email inbox to display. Does anyone know what the options rSAP mode, and "Today View Message" specifically do?

    I also did a factory reset of the device, with no success there either. Extremely frustrating, this is an amazing feature and I need to get it to work! It worked flawlessly in a civic I will test with a different android based phone later, but it must be something with the passport.

    Also I have 2 additional questions:

    1) Is there a way to activate blackberry assistant through the car somehow, and use voice commands in that manner? That could be a good work around! As far as I know it does in fact play through the speaker, but I am not sure how to activate the assistant without touching the phone (if possible)

    2) Whenever I hook up the phone to the car via USB, it keeps disconnecting and connecting multiple times and never remains solid. Every couple of seconds I get the pop up with the option to charge, access sd card, connect to computer, etc. Then it disconnects again and the pop up requests what to do once again. The facts are:
    I KNOW the cable is solid, because I could charge the device perfectly and backup/restore data from it when connected to my home PC
    I KNOW the phone port is solid, because of the above reasons as well
    I KNOW the car USB jack is working properly, because I had a friend of mine connect her iPhone and we were able to charge it and play music from it with no issues at all

    Super frustrating that these simple things don't work properly on my passport. Warranty claim time?
    07-29-15 02:55 PM
  8. Baked's Avatar
    Press and hold the phone button on the steering wheel should activate the assistant.

    Posted via CB10
    KombatVirus likes this.
    07-29-15 09:47 PM
  9. KombatVirus's Avatar
    That did not work, however I found that if you use the voice command "Call Blackberry Assistant", you can bring it up that way.

    Not going to let this thread die. I need to find a fix people! Looking online, it works for some and not for others, there must be a setting or option that can be changed to make this work! I was able to access email inbox once but never again, so whats going on Blackberry?
    08-04-15 06:49 PM
  10. NYCDweller's Avatar
    That did not work, however I found that if you use the voice command "Call Blackberry Assistant", you can bring it up that way.

    Not going to let this thread die. I need to find a fix people! Looking online, it works for some and not for others, there must be a setting or option that can be changed to make this work! I was able to access email inbox once but never again, so whats going on Blackberry?
    As I mentioned - did you call tech support so they can review your logs? If so, what was the outcome?
    08-04-15 07:21 PM
  11. Baked's Avatar
    You may have to have the dealer call Honda tech line.

    Posted via CB10
    08-05-15 06:37 AM
  12. kvndoom's Avatar
    What OS version are you using on your passport?

    Also, are there any software updates available for the Accord through your dealer? Being a first year model, I'm sure there were bugs that needed to be fixed.
    08-05-15 07:43 AM
  13. KombatVirus's Avatar
    What OS version are you using on your passport?

    Also, are there any software updates available for the Accord through your dealer? Being a first year model, I'm sure there were bugs that needed to be fixed.

    I'm on the latest updated OS, 10.3.2 that I just updated to recently. I had the same issue on 10.3.1 however.

    I will definitely call Honda tomorrow, and see if they can update the system for me

    I had another small bit of progress today. I didn't change any settings, but when the phone was unlocked I could actually see the folders when I went into the text/email area on the car. However, when I opened the inbox or any other folder it would show up as empty.

    Also, blackberry assistant doesn't play through bluetooth and I am unable to call it through the car. If anyone has a fix for that, it would be appreciated.

    I am not giving up on this people!! A fix WILL be found no matter how long it takes me. I will post back after calling the dealer tomorrow
    08-05-15 10:41 PM
  14. casperoui's Avatar
    hey man, sorry to hear about your troubles.. Im not sure if you already did that but when I paired my passport with a friends mazda 3 a notification pop-up on my passport asking me if that was my car..when I said yes, it gave access to the whole phone including text messages and stuff..and when the phone was locked it would show a steering wheel. The same thing happened when i paired my passport with my sisters ford fiesta..it even had the ford symbol which i thought was really cool..
    Now i dont know if you already did that, but i cant think of anything else..maybe there is some kind of permission you have to allow or something..i dont know..
    2013 Honda Accord and Text Messaging (Bluetooth)-img_20150722_223525.jpg
    08-06-15 04:04 AM
  15. KombatVirus's Avatar
    hey man, sorry to hear about your troubles.. Im not sure if you already did that but when I paired my passport with a friends mazda 3 a notification pop-up on my passport asking me if that was my car..when I said yes, it gave access to the whole phone including text messages and stuff..and when the phone was locked it would show a steering wheel. The same thing happened when i paired my passport with my sisters ford fiesta..it even had the ford symbol which i thought was really cool..
    Now i dont know if you already did that, but i cant think of anything else..maybe there is some kind of permission you have to allow or something..i dont know..
    Click image for larger version. 

Name:	IMG_20150722_223525.jpg 
Views:	163 
Size:	185.1 KB 
ID:	365505
    Hey buddy,

    Yes I allowed access to the phone during initial pairing. And yes. when the screen is locked, it shows a steering wheel and says HONDA (I can't recall if it is a honda logo or wheel), and the text under it reads that it has access to everything, including SMS! I'll take a picture of it later today, but the lockscreen shows everything working properly
    08-06-15 11:55 AM
  16. KombatVirus's Avatar
    2013 Honda Accord and Text Messaging (Bluetooth)-img_20150806_183258.jpg

    So there you have it, everything is working.

    PS: I was able to get Blackberry Assist to start working.

    Also, I got the constant reconnection via USB issue fixed, it was quite easy. All you have to do is go to Storage and Access in settings, and under USB, select either USB MASS STORAGE or CHARGE ONLY modes, and the connection stays. It seems if you don't have one of these boxes ticked, it will keep detecting the car as a computer every couple of seconds and asking you to make a choice. Once you select one of these modes in settings everything operates properly.

    Still no progress with the texting via HondaLink. If the phone is unlocked and I go back and forth in the car menu to texting, I can get the folders to show up. However, all folders come up as being empty, even though I have loads of text messages. When the phone is locked, I cannot even access the folders.

    I called Honda, they said there are no software updates available for my car. I am still browsing the Honda forums to make sure I have the latest version, but according to my VIN and the dealership, I already do (however I am skeptical, they also said there are no records of it ever being updated in the first place). They tried to make me book an appointment with a service technician, but what can they figure out if they don't even know the car has updateable software?

    Any other ideas? I have to get to the bottom of this!
    08-07-15 01:55 PM
  17. KombatVirus's Avatar
    Today with the phone unlocked, I was able to switch accounts on the Honda system and actually access and open my email. However it only works if done manually, the phone is unlocked, and I still don't get notifications or anything from the car. Text messages still display as empty. No clue why this is going on but must have something to do with access permissions. MAP settings are all correct of course
    08-08-15 01:31 PM
  18. KombatVirus's Avatar
    08-26-15 05:15 PM
  19. qabb's Avatar
    OK. Not entirely sure if this will help. But I was playing around with the system in a friend's Acura TLX and in one of the settings screen in the car (maybe it was the phone menu then settings), there was an option to turn on SMS and/or email.

    Can you check if that's turned on.

    I don't have access to that car obviously so can't help anymore. But thought I would share the little I know.

    Hope it helps.



    Posted via CB10
    08-27-15 11:37 AM
  20. KombatVirus's Avatar
    Yes of course I had it turned on. Car-side everything is armed and ready to go

    I can flip between different "Accounts" meaning SMS and the 3 email accounts I have on my Blackberry. Very rarely, if the phone is unlocked and I flip between it a couple of times, I can get folders to pop up on my car screen, but they always show up as completely empty. Once I got my email to properly display in the car, but that was only once. It really sucks
    08-27-15 02:04 PM
  21. KombatVirus's Avatar
    Bump!

    Still desperately looking for answers. So unfortunate that such a vital feature won't work for me With the new hands free laws it is essential in my line of work!
    09-10-15 06:07 PM
  22. KombatVirus's Avatar
    After that last update, I can see all my accounts (3 emails + SMS). I can actually open and see my emails, but no matter what can't open and access SMS. Its like the phone is blocking it even though everything is enabled that should be. What do I do??? Someone must have an answer out there!
    09-21-15 07:46 PM
  23. erose75's Avatar
    It's probably hondalink. It blows in the 2013 Accord. Trust me, I have it. Voice recognition is awful. The whole system lags. And honda always says there is nothing wrong. Hopefully they fixed it in the new 2016 refresh but doubt the 2013-2015 will get software updates anytime soon, if ever now. Even the sound system is terrible. My 2003 accord with just 6 speakers sounds 10 times better.

    Fyi, if the passport has the button between the volume up/down buttons, press and hold that for bbassist to come on thru the car. It's at least better than using the actual hondalink voice button on the steering wheel.

    Posted via CB10
    09-21-15 11:34 PM

Similar Threads

  1. Why are my text messages queued to be downloaded?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 08-25-15, 08:57 PM
  2. Replies: 5
    Last Post: 07-23-15, 07:39 AM
  3. Bluetooth not Playing music from Internet (browser)
    By paranee2 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 07-22-15, 03:49 PM
  4. Updated Z30 on Verizon and now camera cant be started
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-22-15, 03:15 PM
  5. With T-Mobile and waiting for 10.3?
    By Jamaa in forum BlackBerry Q10
    Replies: 2
    Last Post: 07-22-15, 02:25 PM
LINK TO POST COPIED TO CLIPBOARD