1. Hey_Daniel's Avatar
    We have one day left until the end of the year and still no official release for the Blackberry Bold 9000 and Blackerry Curve 8900 OS 5...

    According to this its meant to be here by tomorrow Only 1 Week Left Until RIM Promised OS 5 RollBack | BlackBerry Cool

    Who thinks RIM will roll this out by tomorrow?

    I personally think, highly unlikely... the storm 1 has jus been rolled out with the official OS 5.0.

    Maybe they are saving the best until last
    12-30-09 02:25 PM
  2. AZBBFAN's Avatar
    Why not use a leaked 5.0 for either of the phones you listed? I have been running 5.0 for months on both my 8900's without a hitch. Really nice thing about it to is VVM on 5.0 so its worth it. If you don't like it then you could always go back. I promise RIM has long ago released 5.0 for the 8900 and 9000, carriers however release the OS's and they drag their feet every time. Why wait for your carrier if you don't have to?
    12-30-09 02:34 PM
  3. Hey_Daniel's Avatar
    I have downloaded the OS 5 to my phone about 6 times now, and just keep rolling back because i just think to myself its not official... Not that i had a problem with it leak OS... Its more peace of mind i think
    12-30-09 02:46 PM
  4. ridesno159's Avatar
    Why not use a leaked 5.0 for either of the phones you listed? I have been running 5.0 for months on both my 8900's without a hitch. Really nice thing about it to is VVM on 5.0 so its worth it. If you don't like it then you could always go back. I promise RIM has long ago released 5.0 for the 8900 and 9000, carriers however release the OS's and they drag their feet every time. Why wait for your carrier if you don't have to?
    Very true, it's the carriers who make it official, RIM just gives them the OS. Did you read the article and a few of the comments? They explain it's the carriers issue now not RIM's. So don't be mad at RIM because they did what they said they would do. There are leaks for phones that will get 5.0.
    12-30-09 02:50 PM
  5. dbone15's Avatar
    Peace of mind? What does that mean? If you actually had a problem, then downgrading may actually make sense.

    The 5.0 OS for the Tour will be out long before the bold 9000 and Curve 8900. It will be released at the same time that the Tour 2 is released to silence tour 1 owners just like the storm 2 and 5.0 for the storm 1.
    12-30-09 10:03 PM
  6. Kevin Michaluk's Avatar
    I contacted RIM back in the day (article that bbcool references in their post) about the rollout of 5.0. I've reached out to RIM a couple times in the past week to try and get an updated statement. Still waiting on some official word. Their office is closed until Jan. 4th, so don't think I'll have one by tomorrow.

    HOWEVER.. I'd safely say it's not going to happen as it's NOT UP TO RIM. It's up to the carriers to push out the code. I think RIM likely gave the greenlight a long time ago that 5.0 was good enough to roll out, but carrier uptake to push it out has been slow. So I'm saying no, won't happen.

    BUT stay tuned. Hopefully I'll have an official statement on the blogs soon.
    12-30-09 10:30 PM
  7. nba1991's Avatar
    bad news, i just spoke to a worker for sprint, i asked when are the releases for 5.0 for the 8330 and 9630, she said there are no upcoming releases for those phones so it must not be in the near future or there keeping it a secret, and i know that workers arent always reliable so its not certain.
    12-30-09 11:35 PM
  8. MojoSwag's Avatar
    bad news, i just spoke to a worker for sprint, i asked when are the releases for 5.0 for the 8330 and 9630, she said there are no upcoming releases for those phones so it must not be in the near future or there keeping it a secret, and i know that workers arent always reliable so its not certain.
    Speaking as a former worker at Sprint, we didn't get info about upcoming stuff until about 2 weeks before the actual release of the product. So Its most likely not coming anytime soon

    I used to roll with Birdman's 5.0 hybrids, which totally kicked ***, but I ended up rolling back because it wasn't an official build, some of my must-have apps didn't work, and for me, I kept getting cut off at the 50-60 minute mark on calls which I couldn't stand.

    I'm not gonna hold my breath for a 5.0 for my 8330. I've got an upgrade coming so I'll probably move on soon anyway.
    12-31-09 12:52 AM
  9. Ossprey's Avatar
    I have the latest "leaked" os 5.0 on my bold 9000 and it is still rather buggy in parts. Thing is as I'm on vodafone uk I don't need too wait for official carrier os's I just load them direct from the blackberry website. The problem with this is even the blackberry website hasn't even received a updated os 5. So my money would be on another month or so. Software never seems too ever meet target deadlines. As this is a major update rim will want it too be perfect unlike the original os I had on my bold 16 months ago.
    So my money is on February some time.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-31-09 05:18 AM
  10. makaveli95's Avatar
    Peace of mind? What does that mean? If you actually had a problem, then downgrading may actually make sense.

    The 5.0 OS for the Tour will be out long before the bold 9000 and Curve 8900. It will be released at the same time that the Tour 2 is released to silence tour 1 owners just like the storm 2 and 5.0 for the storm 1.
    And you calculate this how?
    OS 5.0 for the Storm 1 was only released because the Storm was crap without it. Also, no 9000 official 5.0 was released when the 9700 came out, so how can you conclude this?
    12-31-09 10:00 AM
  11. jlsparks's Avatar
    I have downloaded the OS 5 to my phone about 6 times now, and just keep rolling back because i just think to myself its not official... Not that i had a problem with it leak OS... Its more peace of mind i think
    To clarify: it may not be your carrier's official release, but it absolutely is 100% official software created by RIM. Leaks are typically beta versions incorporating modifications that (hopefully) either resolve prior build issues, or introduce new functionality. That said, again, it's beta software, and like any other beta software you may have issues. If you're content to wait until your carrier gets around to approving a build from RIM chances are the leaks will be increments beyond the carrier release. For me, it's worth installing each leak that comes out, because (with only one exception), each leak has evidenced incremental improvement over the last.
    12-31-09 10:08 AM
  12. shansmi's Avatar
    Man, another one of these. Not going to happen. Go cruise any carrier forums to look for major OS releases for any existing device during prime time hype of newly released devices. The are VERY few. Matter of fact the 8900 release of OS5 is the only one I know of and that may just be because Sprint I believe is either legacy CDMA or WiMax.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-31-09 10:42 AM
  13. XilinxUnder's Avatar
    I've downloaded a few of the betas of 5.0 for my ATT Bold 9000 and have had to roll back because of bugs that didn't let apps run such as VVM and Handbase. Running 4.6.304 for now but will keep trying the 5.0 beta as they are released. Anyone got something later then 401?
    12-31-09 11:11 AM
  14. MojoSwag's Avatar
    To clarify: it may not be your carrier's official release, but it absolutely is 100% official software created by RIM. Leaks are typically beta versions incorporating modifications that (hopefully) either resolve prior build issues, or introduce new functionality. That said, again, it's beta software, and like any other beta software you may have issues. If you're content to wait until your carrier gets around to approving a build from RIM chances are the leaks will be increments beyond the carrier release. For me, it's worth installing each leak that comes out, because (with only one exception), each leak has evidenced incremental improvement over the last.
    You make a very good point. My problem is that I have an 8330, and the only leak which was .230 is a seriously buggy build. They hybriders have done a fabulous job in making it better, but the base is still crap. Thats why I'm waiting for an official
    12-31-09 04:27 PM
  15. Hey_Daniel's Avatar
    Thanks for all of the feedback everyone...
    01-01-10 05:48 PM
LINK TO POST COPIED TO CLIPBOARD