1. Tripster's Avatar
    Here is the easiest instructions to swap radios manually!
    Before doing this, make sure you have deleted all the previous OS's off of your pc and the files/folders in: C:\program files\common files\Research In Motion\Shared\Loader Files.


    • Download 5.0.0.191 HERE
    • Download V7.15 HERE
    • Download 5.0.0.230 HERE
    • Install .230 on your computer
    • Install .191 on your computer
    • Install the hybrid
    • The hybrid will open up Shrink-A-OS for you
    • Shrink whatever your heart desires
    • Don't close out of S.A.OS
    • Goto c:\program files\common files\Research In Motion\shared\loader files
    • Goto the CDMA folder in .191
    • Copy the .191 CDMA folder
    • Goto .230 folder
    • Delete the .230 CDMA folder
    • Paste the .191 CDMA folder
    • Go back to S.A.OS
    • Then select Loader (SEE BELOW FOR WHERE AND WHAT TO LOOK FOR BEFORE PRESSING NEXT IN THE LOADER!)
    • Wait for it to load
    • Then your set!

    If done correctly you should see rim0x0D000D04.sfi (Platform 4.2.0.43) like in the picture below, if your platform reads this: (4.2.0.61) you are still running the .230 radio file.



    I will be updating the download link for the latest Irtehun's hybrid for the 9630 as soon as it becomes public.
    Last edited by Tripster; 01-13-10 at 05:34 AM. Reason: Direct link for V7.15 updated...
    12-27-09 01:31 PM
  2. willyboy6's Avatar
    Thanks for the detailed walk through Tripster. Very good stuff. Here is another walk through for those users who are contemplating this switch. This was put together by Driphter over at BBH who initially discovered and published this procedure. see here --> Wanna Make 50v7.11 FASTER and Get a Better Radio??? - BBHybrids Forums

    Enjoy and good luck to all.
    12-27-09 01:40 PM
  3. illmatic's Avatar
    Great post, thanks. I saw this in the other thread and followed the instructions yesterday and it worked perfectly.
    12-27-09 02:30 PM
  4. anon(67796)'s Avatar
    great post...things like this need to be put in the stickies for easy findings!
    12-27-09 02:51 PM
  5. Tripster's Avatar
    Thanks for the detailed walk through Tripster. Very good stuff. Here is another walk through for those users who are contemplating this switch. This was put together by Driphter over at BBH who initially discovered and published this procedure. see here --> Wanna Make 50v7.11 FASTER and Get a Better Radio??? - BBHybrids Forums

    Enjoy and good luck to all.
    Your welcome!
    Great post, thanks. I saw this in the other thread and followed the instructions yesterday and it worked perfectly.
    Glad to hear that it went smoothly and worked for ya.
    great post...things like this need to be put in the stickies for easy findings!
    Thanks!
    12-27-09 03:03 PM
  6. greeneink's Avatar
    I ve tried this 5 times and it bricked my phone each time. It hangs up trying to connect abouyt the third time and the red light flashes. I've tried to wait it out and I've also (after I get the, cannot connect) disconnect the sync cable and reconnect it. So be warned, it may not work for you. Make sure you know how and have time to fix a brick.

    I do have a question, are you installing this on top of .230 or on top of .230/50v15? Does it matter? I'd really like to try the other radio to see for myself if the radio files are better.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-27-09 03:12 PM
  7. Tripster's Avatar
    I ve tried this 5 times and it bricked my phone each time. It hangs up trying to connect abouyt the third time and the red light flashes. I've tried to wait it out and I've also (after I get the, cannot connect) disconnect the sync cable and reconnect it. So be warned, it may not work for you. Make sure you know how and have time to fix a brick.

    I do have a question, are you installing this on top of .230 or on top of .230/50v15? Does it matter? I'd really like to try the other radio to see for myself if the radio files are better.

    Posted from my CrackBerry at wapforums.crackberry.com
    I am not sure why it bricked on you and I'm installing V7.15 on top of .230. During what part of the loader process does it disconnect?
    12-27-09 03:22 PM
  8. greeneink's Avatar
    Its the last reboot before full install. Step 8 or 9. Right before app restore.
    About the only thing I haven't tried is to install .230hybrid over 4.7
    I would like to mention I've installed several of the hybrids without difficulty.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-27-09 06:03 PM
  9. anon(67796)'s Avatar
    Its the last reboot before full install. Step 8 or 9. Right before app restore.
    About the only thing I haven't tried is to install .230hybrid over 4.7
    I would like to mention I've installed several of the hybrids without difficulty.

    Posted from my CrackBerry at wapforums.crackberry.com
    their must be an application that tries to install and it must be a corrupted file thats causing it to brick..
    12-27-09 06:10 PM
  10. Tripster's Avatar
    Its the last reboot before full install. Step 8 or 9. Right before app restore.
    About the only thing I haven't tried is to install .230hybrid over 4.7
    I would like to mention I've installed several of the hybrids without difficulty.

    Posted from my CrackBerry at wapforums.crackberry.com
    Have you tried to use BBSAK to do a low-level wipe before loading the hybrid?
    12-27-09 06:13 PM
  11. greeneink's Avatar
    No, that is something I haven't tried. I never really thought that should make a difference.
    I do seem to be the only one on the boards that is having this problem, maybe it's worth a try.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-27-09 06:18 PM
  12. Tripster's Avatar
    No, that is something I haven't tried. I never really thought that should make a difference.
    I do seem to be the only one on the boards that is having this problem, maybe it's worth a try.

    Posted from my CrackBerry at wapforums.crackberry.com
    I always do a low-level wipe before installing hybrids/unofficial/official releases of OS's, some same you don't have to cause loader.exe does one itself but your dealing with a hybrid which is tweaked vs stock os. Again, that's just me and my opinion.

    Make sure you have a up to date backup though. If you want you can save the download links for the apps/themes and email them to yourself from a different email account so you can just email them to the email account on your BB.
    12-27-09 06:24 PM
  13. greeneink's Avatar
    I reinstalled allowing it to erase all my apps. (after backing them up with BBSAK)Well, it bricked again at "device initialization". So I reran the hybrid and hit LOAD OS as soon SHRINK A OS opened. It ran through the cycle this time. Waiting on reboot now, but it looks good. I appreciate you guys sticking with me. Hopefully, I'll get reboot soon and be able to install all my apps with BBSAK and be able to try the .191 files in asn area I regularly drop calls in-between towers. I'll post back on this thread. NOPE. i'm still using the .230 radio. I'll retry with a full wipe of apps.
    12-27-09 07:16 PM
  14. Tripster's Avatar
    I reinstalled allowing it to erase all my apps. (after backing them up with BBSAK)Well, it bricked again at "device initialization". So I reran the hybrid and hit LOAD OS as soon SHRINK A OS opened. It ran through the cycle this time. Waiting on reboot now, but it looks good. I appreciate you guys sticking with me. Hopefully, I'll get reboot soon and be able to install all my apps with BBSAK and be able to try the .191 files in asn area I regularly drop calls in-between towers. I'll post back on this thread. NOPE. i'm still using the .230 radio. I'll retry with a full wipe of apps.
    That is weird that it keeps bricking on ya, what all did you select with s.a.os before this try?
    12-27-09 07:21 PM
  15. greeneink's Avatar
    All I shrink is All Languages, All IM, CityID, help, V casts, vodaphone VZNavigator
    Thats it
    I'm downloading the .191 OS you linked, hoping I have a corrupt file.
    12-27-09 07:48 PM
  16. Tripster's Avatar
    All I shrink is All Languages, All IM, CityID, help, V casts, vodaphone VZNavigator
    Thats it
    I'm downloading the .191 OS you linked, hoping I have a corrupt file.
    Alright and that's the same .191 os link I used.
    12-27-09 07:50 PM
  17. greeneink's Avatar
    Another brick!
    I feel like I'm building a house. I'm done, it's back to .230 for me. Thanks for the help.
    12-27-09 08:55 PM
  18. Tripster's Avatar
    Another brick!
    I feel like I'm building a house. I'm done, it's back to .230 for me. Thanks for the help.

    Very sorry that it didn't work out.
    12-27-09 09:05 PM
  19. drinka4yearz's Avatar
    I tried a few radio swaps and the only one witch seems to work is .191 for the .230 every other one I try I get a error why is that.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-28-09 01:15 PM
  20. We_Ready's Avatar
    Did my phone fine....tried my wife's phone and i'm pretty sure it's the .191 radio because of no lightning bolt when charging, but when I push alt/shift/H it is still showing 5.0.0.351 (554) which means the 7.15 didn't install right?
    12-28-09 02:02 PM
  21. willyboy6's Avatar
    Did my phone fine....tried my wife's phone and i'm pretty sure it's the .191 radio because of no lightning bolt when charging, but when I push alt/shift/H it is still showing 5.0.0.351 (554) which means the 7.15 didn't install right?
    Correct, that is one of the older hybrids. I don't remember 7.14 or 7.13.... You will only see the radio swap in the different platform version. .230 shows .61 while .191 shows .43. Won't affect your app version.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-28-09 04:29 PM
  22. Tripster's Avatar
    I tried a few radio swaps and the only one witch seems to work is .191 for the .230 every other one I try I get a error why is that.

    Posted from my CrackBerry at wapforums.crackberry.com
    Other radios might not work at all with .230, which could brick or damage your BB. The 2 radios I know that work with .230 are: .140/.191.
    Did my phone fine....tried my wife's phone and i'm pretty sure it's the .191 radio because of no lightning bolt when charging, but when I push alt/shift/H it is still showing 5.0.0.351 (554) which means the 7.15 didn't install right?
    It seems to me that you didn't uninstall the previous .230 with V7.11 (I think) on your computer, with V7.15 in your about screen you should see .238 and when you do the alt+shift+h, you should see .405 (645).
    Last edited by Tripster; 12-29-09 at 05:32 AM.
    12-29-09 05:28 AM
  23. willyboy6's Avatar
    Don't forget if you're trying to make changes you should always select the downgrade option when app loader prompts you otherwise the load will not make any changes to your berry.
    12-29-09 08:03 AM
  24. ipodtouch1234's Avatar
    I made an easier way to do this. Just Click here.
    12-29-09 01:16 PM
LINK TO POST COPIED TO CLIPBOARD