04-04-14 01:58 PM
717 12345 ...
tools
  1. Crucial_Xtreme's Avatar
    Do i need to dl the older os in order to downgrade:?
    Yes, d/l the old OS, but don't install. Then uninstall the current. Then Install the old OS, delete the Vendor XML file, plug in BB, open DM.
    07-24-08 03:13 PM
  2. jeffh's Avatar
    Do i need to dl the older os in order to downgrade:?
    To add to C_X, if you didn't uninstall the older OS, all you have to do is uninstall the newer and the AL will detect the older and offer to downgrade the next time you run it. If you uninstalled the older OS, but kept the installer file, you can use that to reinstall. The only reason you'd have to d/l again is if you both uninstalled the older OS and deleted the installer. In that case, you have to d/l it again.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-24-08 03:19 PM
  3. bmcclure937's Avatar
    Do i need to dl the older os in order to downgrade:?
    1) Go into Control Panel : Add/Remove Programs and uninstall any OS that is [B]newer/B] than the one you are "rolling back" to

    2) If you already have the .exe on your PC for the desired OS to "roll back" to, then run the install file. If not, then download from your carrier (or whatever source) and run the install file once downloaded

    3) Proceed with running AppLoader and it will "downgrade" you!!
    07-24-08 03:26 PM
  4. taimaishuu916's Avatar
    Where can i get the old os at?
    07-24-08 03:29 PM
  5. bmcclure937's Avatar
    Where can i get the old os at?
    Are you using the 8310 (unlocked) on TMobile's network, or is your information wrong??

    You can get the 8310 OS from ATT's site or the 8320 OS from TMobile's site...
    07-24-08 03:33 PM
  6. taimaishuu916's Avatar
    Yeah i am using the 8310 unlocked on Tmo.
    07-24-08 03:38 PM
  7. bmcclure937's Avatar
    Yeah i am using the 8310 unlocked on Tmo.
    Then you can get the latest release...OS 4.5.0.55

    Or you can get a little older release... OS 4.5.0.52

    *EDIT* : Scratch what I said... I found a link for the latest official ATT release! GO HERE
    Last edited by bmcclure937; 07-24-08 at 03:52 PM.
    07-24-08 03:46 PM
  8. taimaishuu916's Avatar
    Shoot i used the jl cmder program and now my bb is has a white screen with a circle in the middle. I loaded 4.2 and turn on dm but nothin happened. It ddidnt prompt me to do anything.
    07-24-08 03:57 PM
  9. bmcclure937's Avatar
    Shoot i used the jl cmder program and now my bb is has a white screen with a circle in the middle. I loaded 4.2 and turn on dm but nothin happened. It ddidnt prompt me to do anything.
    As I told you in our PM convo... please take the time to read through the guide. I took the time to make the guide and I took these things into consideration...

    There is a link to direct you on what to do

    BlackBerry 101: How to Reload the Operating System on a Nuked BlackBerry | CrackBerry.com

    *FYI : I took that directly from the steps in the guide and getting the '507' error is expected. This wipes the entire device of any traces of the last OS!
    Last edited by bmcclure937; 07-24-08 at 04:04 PM.
    07-24-08 04:01 PM
  10. taimaishuu916's Avatar
    Sorry about that, i was freakin out when i saw a blank screen on my BB
    07-24-08 04:04 PM
  11. bmcclure937's Avatar
    Sorry about that, i was freakin out when i saw a blank screen on my BB
    Most people do!
    07-24-08 04:06 PM
  12. taimaishuu916's Avatar
    Thanks man! Your tutorial works!
    07-24-08 04:55 PM
  13. bmcclure937's Avatar
    Thanks man! Your tutorial works!
    Thanks for the compliment, glad we could step you through the process and get you up and running again!
    07-24-08 05:48 PM
  14. taimaishuu916's Avatar
    I was able to install the latest os but it still reboots on me nonstop. Its so annoying and i dont know what to do.
    07-24-08 09:10 PM
  15. bmcclure937's Avatar
    I was able to install the latest os but it still reboots on me nonstop. Its so annoying and i dont know what to do.
    Search the forums, this is not really the place to discuss it

    I would start by trying without a microSD card in the device... that may cause your problem. If that does not work... search the forums. And if you cannot find something, roll back to the carrier OS. I provided a link to it for you in post #57
    07-25-08 01:43 PM
  16. ballinsol14's Avatar
    Absolutely amazing!
    07-27-08 03:44 AM
  17. bmcclure937's Avatar
    Absolutely amazing!
    Thanks! Glad it worked for you and helped you out
    07-27-08 11:17 AM
  18. ballinsol14's Avatar
    Thanks! Glad it worked for you and helped you out
    You're always on top of everything!
    07-27-08 04:26 PM
  19. bproud's Avatar
    I have read the how to install and uninstall, and fell like I can do it. My question is when I do this will it see my carrier again after the install where we are still using 4.2.2.123 and I want to upgrade to 4.5.0.55 , or did I miss something? I even have my old os saved.
    07-27-08 05:59 PM
  20. jdwx's Avatar
    I'm on Alltel/Ohio and had no issues upgrading to 4.5.0.51. It turned off my "radio" and it didn't want to dial out at first after the upgrade and I just had to turn the radio back on, but most people aren't even having that happen.

    The carrier doesn't pay attention to the OS as far as I know. It will just work

    Good luck. I did it following these directions and it was easy.
    07-27-08 06:04 PM
  21. bproud's Avatar
    I'm going to try upgrading later, cross my fingers that all goes well. I just love these boards for info. Thanks ;D
    07-28-08 01:31 PM
  22. jeffh's Avatar
    If you were as new as your post count suggests, I'd encourage you not to upgrade until you are more familiar with your device. However, your join date suggests you have been around long enough to know what you're doing, so I'll just leave it at that.
    07-28-08 01:40 PM
  23. anon(1039967)'s Avatar
    what is the vendor.xml file used for?

    Why should we delete it?

    What if we do not delete it?

    thank you
    07-29-08 06:22 PM
  24. jeffh's Avatar
    Excerpted from John Clark: "vendor.xml tells Desktop Manager to only load an OS to the device of the same carrier that's branded to the device. For example, if I have a TMobile BB and download an OS from Vodafone the OS won't load to the device unless I delete the vendor.xml file. Nothing is lost by deleting this file it only serves this one purpose and nothing else. Once that is deleted you can continue on. (Note: This vendor.xml file gets reinstalled with any OS installation or Desktop Manager installation so you may have to delete it again at a later date if you install another OS or update Desktop Manager.)"

    If you don't delete vendor.xml, then you can only install an OS from your carrier. In any event, the OS must match the hardware. Regardless of deleting vendor.xml, you cannot install an 8330 OS on an 8830.
    Last edited by JeffH; 07-29-08 at 07:59 PM. Reason: typo
    07-29-08 07:59 PM
  25. smitty24's Avatar
    Many thanks for this write up - if you follow it step by step - it will work without incident. Thanks again!

    im now enjoying 4.5! woohoo!
    07-29-08 08:19 PM
717 12345 ...
LINK TO POST COPIED TO CLIPBOARD