1. rk604's Avatar
    This was instruction given by smoke921, but unfortunately it didn't work for my new Bold2. I have tried this before on my Curve 8900, it worked flawlessly! Just wanted to see if there were any other alternatives...I am doing this on the newest AT&T firmware/software, using the method below and the deleting the VVM cod files in the JAVA folder. Neither worked...

    FIXED!: Your internet connection must be off, or it will look for the update on the internet, if it is off, it looks through the Common Files/... folder. It issue should only affect if you are upgrading to a different vendor's software/firmware, as in my case, i am upgrading my T-Mobile 9700 to a AT&T software.


    Instructions:
    1) Go to C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\ and find the file 'net_rim_bb_vmm'.

    2) Use notepad to edit net_rim_bb_vmm. Find and change "required" from true to false. This will allow vmm to be uncheck and unselected instead of forced in the install or upgrade process.

    3) Save the file - VISTA USERS PLEASE NOTE: If you have trouble saving the file from notepad, save it to the desktop and then manually move it to C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\

    4) Start Desktop manager

    5) Connect Bold

    6) Go to Apploader - use Add/Remove Programs

    7) uncheck the Visual Voice Mail box

    8) proceed with updating
    Last edited by rk604; 12-18-09 at 07:53 PM.
    12-18-09 07:04 PM
  2. Crucial_Xtreme's Avatar
    If you want to remove Visual Voicemail, go into the Java folder and delete all the vvm.cod's, then run Apploader and it will remove them.
    12-18-09 07:08 PM
  3. rk604's Avatar
    i did that, i have tried:

    1) editing the cod file by change "true" to "false"
    2) deleting the VVM .alx file and all the files in JAVA

    again...when i tried the first method, it worked like a charm on my curve, but not sure why on the bold2, the option to uncheck is greyed out
    12-18-09 07:18 PM
  4. hytran's Avatar
    i did that, i have tried:

    1) editing the cod file by change "true" to "false"
    2) deleting the VVM .alx file and all the files in JAVA

    again...when i tried the first method, it worked like a charm on my curve, but not sure why on the bold2, the option to uncheck is greyed out
    Edit the net_rim_bb_vvm.alx file and change:

    true</required>

    to:

    false</required>

    The option will no longer be greyed out. Are you sure you edited the right file? For the right software version (9700 vs. 8900)? You said cod file

    I can add/remove VVM on my 9000 (5.0.0.411) all day long this way...
    Last edited by hytran; 12-18-09 at 08:53 PM.
    12-18-09 08:50 PM
  5. einhovant's Avatar
    Is this work with 8520 ? Cause this VVM really useless..

    Posted from my CrackBerry at wapforums.crackberry.com
    12-19-09 03:11 AM
  6. Ahheck01's Avatar
    Has anyone else done this successfully? As soon as I find my usb cable, I'm going to give this a try. My battery life has been crap since upgrading to OS 5.0.0.348, and I imagine having VVM running all the time even when I'm using it takes up even more.

    Any other reasons battery life on 5.0.0.348 would be so horrible? I literally charge it at lunch and it dies at midnight.
    12-20-09 04:48 PM
  7. gang4's Avatar
    it works...

    but then...

    sometimes the VVM keep coming back occasionally with other T-mob things after boot up.

    anyway to fix this permanently?
    12-21-09 03:34 AM
  8. doxa sub750T's Avatar
    It works for me. FYI, once you unlock your phone, those annoyances will be forever gone This includes video sample file, etc.
    Last edited by doxa sub750T; 12-21-09 at 05:02 PM.
    12-21-09 02:52 PM
  9. HaTaX's Avatar
    My easy fix for this is just rename the "net_rim_bb_vvm.alx" file to "net_rim_bb_vvm_alx" and the loader won't even see the VVM files.

    Has worked well for me with the past 5-15 OS 5 loads.
    12-21-09 09:18 PM
  10. anon(2878740)'s Avatar
    Is there something special I need to do for the "Shared" folder to appear in C:\Program Files\Common Files\Research In Motion\

    For some reason, I don't have this directory...
    01-03-10 12:02 PM
  11. jackbox's Avatar
    Is there something special I need to do for the "Shared" folder to appear in C:\Program Files\Common Files\Research In Motion\

    For some reason, I don't have this directory...
    Yea you need to install the OS on your phone onto your computer by downloading it and installing it to your computer that BBDM is running on. Also, always disconnect from the internet when loading/updating an OS installed on your computer or it won't work due to DM searching RIM's database for the official releases for your phone's vendor ID.
    Last edited by jackbox; 01-03-10 at 07:31 PM.
    01-03-10 07:20 PM
  12. anon(2878740)'s Avatar
    thanks jackbox
    01-04-10 08:27 PM
LINK TO POST COPIED TO CLIPBOARD