1. superlanb0y's Avatar
    I started getting this error whenver trying to access the Options menu. Whether the icon itself on the home screen or even when navigating through the menu within my email. If I click on it, it either does nothing or displays a error message:

    Error starting
    net_rim_bb_options_app: Module
    'net_rim_tsm_lib' not found


    I believe this started after I updated to 7.1 Bundle 921 on my 9900 Bold.

    How do I get my options back?
    Last edited by superlanb0y; 04-17-12 at 10:13 PM.
    04-17-12 10:10 PM
  2. freethisberrydotcom's Avatar
    You will need to reload your OS. Back up your device.

    Connect your BB to desktop software with your battery, and click update.

    After the process begins to download and start installing, pop in the battery and let the install finish.

    Phone will reboot and then restore your info.
    04-17-12 10:49 PM
  3. superlanb0y's Avatar
    Thank you for your help!

    I followed along and was able to restore my info and get my Options back.

    I should have added I am on a company BES. I tend to avoid my IT department as I find I get the answers here before they can. ( Or they end up coming here as well)

    Now with an OS update, you don't need to re-add to the BES.

    After doing this reset, our IT department located on the other side of the country is not able to re-add to the BES. My IT team is a bit stumped and seem to have me doing the same activation over and over hoping it will work.

    I have ZERO hands on experience with the BES itself and would like to avoid 3 weeks of downtime while they tinker.

    Is it related to the latest OS update? Does the BES require you to identify phone models etc in order for the activation? I see the BES emails appear in my inbox of my desktop email, but usually they are there for only a flash. This time, the emails remain in my inbox.

    Any help so I can avoid loosing my BB for 3 weeks???
    04-19-12 02:11 PM
  4. Mai Zaza's Avatar
    Thank you for your help!

    I followed along and was able to restore my info and get my Options back.

    I should have added I am on a company BES. I tend to avoid my IT department as I find I get the answers here before they can. ( Or they end up coming here as well)

    Now with an OS update, you don't need to re-add to the BES.

    After doing this reset, our IT department located on the other side of the country is not able to re-add to the BES. My IT team is a bit stumped and seem to have me doing the same activation over and over hoping it will work.

    I have ZERO hands on experience with the BES itself and would like to avoid 3 weeks of downtime while they tinker.

    Is it related to the latest OS update? Does the BES require you to identify phone models etc in order for the activation? I see the BES emails appear in my inbox of my desktop email, but usually they are there for only a flash. This time, the emails remain in my inbox.

    Any help so I can avoid loosing my BB for 3 weeks???
    06-27-13 10:52 AM
LINK TO POST COPIED TO CLIPBOARD