09-14-13 01:55 PM
601 ... 2021222324 ...
tools
  1. bobisnice's Avatar
    this is really a usful and greatful post!!

    but, i have a question here: i dont find Connection Preference under Mobile Network Options?

    my device is bb 8520 (black) carrier is Vodacom (im stay in South Africa). and the os is 5..0.0.509 (Platform 5.2.0.47). oh, and i have a data plan.

    PLS advise what may cause this situation?

    I only got three options:

    Data service:
    while roaming:
    network selection mode:

    thk u again!
    05-21-10 07:07 AM
  2. papa44's Avatar
    Hi i was just wondering if it was at all possible to set my Blackberry (Curve 8900) to automatically turn on and connect to WiFi in a specific location (i.e. my home), while at the same time disabling the data service? Maybe something using the GPS capabilities of the Blackberry?
    I love using my WiFi while at home as it is much faster than my data service but i don't leave it on all the time as it eats up my battery life.

    Thanks in advance
    05-22-10 03:09 AM
  3. allanri's Avatar
    I've had very inconsistent results connecting to WiFi with my new BlackBerry. Sometimes it works just fine (e.g. at work), other times I can't get it to work at all with connections that have worked just fine in the past. Right now, I seem to be connected (I have the mobile network turned off, and am still able to browse to web pages), however, the WiFi icon is still greyed out. And applications like Facebook are not able to connect at all.

    One thing I tried to do was to set my connection preferences ... you said:

    Next, we will fine tune some other connection properties. Navigate to Home Screen > Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.
    I don't have this option on my BlackBerry. I'm running OS version 5.0.0.464.
    05-23-10 08:13 AM
  4. djag10's Avatar
    Thank you very much for the post, just one thing, my BB 9550 still cannot connect to the internet. Please help me on other configurations needed... Thank you very much
    05-30-10 11:40 AM
  5. xs11e's Avatar
    Nice one, I myself can't find this either. I already had setup my WiFi, but just wanted the preference settings, but can't find it.

    I'll start a thread about this, I think.
    I can't either, 9700 on T-Mobile. I'm told carriers w/o UMA won't have that option but T-Mo does have UMA and I don't have the option.

    OS is 5.0.0.586
    05-30-10 07:52 PM
  6. vinmontRD's Avatar
    I can't either, 9700 on T-Mobile. I'm told carriers w/o UMA won't have that option but T-Mo does have UMA and I don't have the option
    OS is 5.0.0.586
    That's bizarre -- I'm on TMo (8900) and have used practically every beta 5.x OS that's leaked -- now on 610 -- and I've always had that option. Just checked again to confirm it... Maybe try resending your service books from the Tmo BIS web page page? I depend on that setting to keep UMA as my preferred connection any time I'm near a known wifi access point...

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by vinmontRD; 05-30-10 at 08:19 PM.
    05-30-10 08:17 PM
  7. xs11e's Avatar
    That's bizarre -- I'm on TMo (8900) and have used practically every beta 5.x OS that's leaked -- now on 610 -- and I've always had that option. Just checked again to confirm it... Maybe try resending your service books from the Tmo BIS web page page? I depend on that setting to keep UMA as my preferred connection any time I'm near a known wifi access point...
    More frustrating than bizarre. I've wipe, reinstalled, sent service books (twice), etc.

    I wonder if it's because the phone is a telcel? Could it be the firmware? Telcel may not have UMA but that should make no difference, should it?

    Maybe I could try a different OS? I loaded the one that came right from T-Mo because I thought that might be my best bet but????
    05-31-10 01:44 AM
  8. xs11e's Avatar
    Fixed it!!!!

    See the thread in the 9700 forum titled "Just got my 9700... UMA problem"

    I downloaded the certificates, modified DM to add the certificate manager, followed the instructions three times (I'll only admit to three times, it was really more than that.... typing and reading errors did me in several times!) and added a battery pull to make everything work.

    I turned off the radio and used WiFi to call my landline, I can select WiFi preferred and now I see UMA next to the signal indicator when it's on WiFi.

    My cup runneth over, my next move was to contact the seller and tell him his unlocked Telcel phones didn't work with T-Mo and try to return the phone but I didn't want to do that because the phone appears to be almost unused, no nicks scratches, etc. BTW, the CS guy at the T-Mo store fixed the major Telcel problem for me, the phone now speaks English and the Telcel browser is gone.

    I'm so happy I found the fix and now I'm DELIGHTED with the phone.

    My only regret is that I didn't act sooner, the VERY cute (and VERY sharp!) girl is no longer at the local T-Mo store, she moved out of state... <sigh>
    05-31-10 04:18 PM
  9. Scoottro's Avatar
    most excellent thread

    tnx
    05-31-10 08:56 PM
  10. vinmontRD's Avatar
    most excellent thread

    tnx
    This really is valuable -- good info, and seemingly not available in many places. Maybe this should be stickied? I'd had to see this info scroll off into oblivion, only to be located later on through intrepid thread search...
    05-31-10 09:04 PM
  11. Jiggavel's Avatar
    I need to set up my home wifi!

    Posted from my CrackBerry at wapforums.crackberry.com
    06-02-10 10:23 PM
  12. angelinoff's Avatar
    OK here is my problem.
    I can connect to every secured Wifi router adding pre-shared pass key.
    There are several clubs that I go and they have open wifi hotspots.
    When I try to connect to open wifi I keep receiving "Provisioning bla bla .... enter this PIN to your wireless router .... "

    This is kind of stupid .... isn't it suppose to connect to NON secured wifi network without asking for anything?
    And what am I suppose to tell the bar tender to give me access to the club's router , so I can enter some PIN in order to connect with my BB .....

    If anyone had this issue - please share how to fix that.
    06-03-10 03:17 PM
  13. rafairchil2's Avatar
    Neat, thanks
    06-09-10 08:15 PM
  14. zytrahus's Avatar
    Hi
    I have a Bold 9700 with Tmobile, and bought the phone unlocked from amazon.
    I have no data plan.

    I am trying to access the internet from home using a verizon/fios router.

    I have no issues connecting to the router (IE getting an IP address).

    I have followed instructions to change the browser to hotspot ("hotspot browser" on my 9700). I have also tried to set the Tmo wap address in the TCP settings but no luck so far.

    I haven't tried any other WiFi network.

    WiFi diagnostic shows no problem...

    when I go the browser (start page set to Google it just can't access it (i'll the exact message when I get home)..


    Any idea?
    Last edited by zytrahus; 06-10-10 at 07:39 PM.
    06-10-10 07:35 PM
  15. Hollia's Avatar
    This was truly useful info, Mr. Mcclure! Thank you! Thank you!
    06-10-10 07:39 PM
  16. zytrahus's Avatar
    Hi
    I have a Bold 9700 with Tmobile, and bought the phone unlocked from amazon.
    I have no data plan.

    I am trying to access the internet from home using a verizon/fios router.

    I have no issues connecting to the router (IE getting an IP address).

    I have followed instructions to change the browser to hotspot ("hotspot browser" on my 9700). I have also tried to set the Tmo wap address in the TCP settings but no luck so far.

    I haven't tried any other WiFi network.

    WiFi diagnostic shows no problem...

    when I go the browser (start page set to Google it just can't access it (i'll the exact message when I get home)..


    Any idea?
    Some corrections: I actually can't get an IP address. so this makes more sense as to why I couldn't access the web...

    I was confused by the fact I could see my wifi profile on top of the screen and with wifi logo grayed out.

    I have several computers connected to the router using wifi without problem.
    Do you guys have any idea where I should start looking?
    06-11-10 11:48 AM
  17. zytrahus's Avatar
    I went into my router options and saw that an IP is actually given to my blackberry, no issue is detected by the router:

    PC Name: BLACKBERRY-B3AA
    Connection Type:
    Wireless
    IP Address: 192.168.1.5
    Status: Active
    Remote Access: Enabled


    Doing diagnostic on the blackberry shows that I don't have a valid IP address.

    it must be a router setting, not sure which
    06-11-10 11:23 PM
  18. dnizzz's Avatar
    Quick question...My sister has a blackberry 8100 pearl...so I'm doing a little research for her. We have Tmobile and she does not have internet... She's tried to use the free wifi but when she does not have a "manage accounts" button. When she goes to options and advanced options, the only option she has is tzones... She cant change the settings. How can she use free wifi? she doesn't have internet at home...so I'm talkin like starbucks free wifi or something.

    thanks.
    07-22-10 02:56 AM
  19. hoglite's Avatar
    Hi folks,

    Just done a site survey using the tools option, is -45db regarded as a good/ok signal?

    ta,
    07-29-10 02:56 PM
  20. xs11e's Avatar
    I'm running -85dbm.
    07-29-10 04:32 PM
  21. hoglite's Avatar
    Is that good?

    What's the scale 1 being ?
    07-29-10 04:33 PM
  22. busdoktor's Avatar
    Very good guide
    I am still unable to make calls over the Wi-Fi I am on a Storm2 9550 love it I am connected to my home Wi-Fi all the setting are good but for the BES setting under the Dig there is not IP address and the connection box has a red X. Is there a way I can repair this on my own or do I have to go to the IT dept of my Co. UGG!!
    Please help anyone?
    07-31-10 09:43 AM
  23. freeangle's Avatar
    thanks for guiding...
    08-04-10 04:08 AM
  24. robwilkins's Avatar
    I am trying to get my blackberry connected to WiFi - i can find network ( I am getting the white - in settings and info about connection) but what do I have to do to get the connection working that I can go on websites.

    Ps. I am trying to connect to a wireless connection in my work - does this matter. Also I have no Blackberry service packages (what r these and how do I get them if i need them)

    Thanks
    08-12-10 10:41 AM
  25. hoglite's Avatar
    **************************************************

    Recap :

    At this point, you should be connected to a WiFi network!! (using one of the three options!)

    We will now move on to tweak some settings for your BlackBerry Browser and Connection Preferences.

    If you are NOT connected for some reason... you will need to troubleshoot the problem.
    Trouble shooting your wireless connection can be done using a few utilities on your BlackBerry!
    Move on to 'Step 3 : Troubleshooting your WiFi Connection' if you are having trouble connecting!

    **************************************************

    Step 2 : Tweaking your BlackBerry's Settings

    Once you are connected to a wireless network, there are a few settings you can tweak so that the WiFi connection performs the way you want it to!!

    First of all, we will tweak the Browser Settings. Open your browser and navigate to Menu > Options >
    Browser Configuration. From here, change the 'Browser' option to WiFi (or, in OS 4.5 releases, 'Hotspot')

    My browser configuration is as follows :

    Browser : HotSpot Browser
    All of the formatting boxes are checked : (JavaScript, Java Popups, Terminate slow running scripts, HTML Tables, ForeGround and BackGround Colors, BackGround Images, Embedded Media, Style Sheets)
    Show Images : On WML & HTML Pages
    Emulation Mode : BlackBerry
    Start Page : Start Page (Set to your liking)
    Home Page Adress : Set to your liking

    You can tweak these settings to your liking... but those settings are a good starter.
    Please note these settings are being used on OS 4.5.0.xx on my 8320, there may possibly be minor differences

    (Note : setting the emulation mode to 'BlackBerry' will allow your Berry to have a more "mobile friendly" browsing experience. This also allows for applications, themes, etc to be downloaded and installed OTA (over the air). With emulation mode set as 'Microsoft IE', you do not have these benefits!)

    Hit the 'Back' button and then go to 'General Properties'. Once again, make sure the first option is set to WiFi (or Hotspot) browser. The other options can, once again, be tweaked to your liking. The defaults should be fine.

    Next, we will fine tune some other connection properties. Navigate to Home Screen > Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.

    This dictates what connection your device will choose, depending on availability. For example, if the WiFi is turned on and you enter one of your WiFi hotspots (which you added in Step 1) then your device will automatically connect and use that connection as the default connection (making UMA calls).
    (Please note, this does not automatically switch your browser configuration to connect between EDGE/WiFi. The WiFi preferred only affects the mobile network connection of your device. You will need to manually change from 'WiFi browser' to 'Internet' browser... and vise versa)

    You can change this setting to whatever you may desire... and the options are self-explanatory:
    • Mobile Network Only -- Will not use the WiFi connection to make any calls (browsing still available)
    • Mobile Network Preferred -- will only use WiFi when the Mobile Network is unavailable (in poor service areas)
    • WiFi Only -- Will only make UMA calls over WiFi, even if mobile network is available
    • WiFi Preferred -- will make UMA calls when a WiFi network is available, mobile network if not available


    Finally, navigate to Home > Menu > Manage Connections > WiFi Options.
    This menu will display the current WiFi network you are connected to, along with all of your saved WiFi profiles. From here, you can manage your WiFi networks and remove unused connections. You can also specify if you want the device to auto-connect or manually connect to networks.

    To edit Saved WiFi Profiles : highlight the desired network and hit Menu > Edit. You are able to change the name, security type, etc... (in case you ever make a change in your router configuration!)

    **************************************************

    Step 3 : Troubleshooting your WiFi Connection


    If you have a specific error code for your problem, then please refer to Question 1 in the FAQ section. Otherwise, follow these directions

    This section is dedicated for users who are still experiencing problems when connecting to WiFi networks. If you are unable to connect to a network there are a number of things to take into consideration.

    1. Your router setup
    2. Other routers in close proximity to your router


    In order to do some diagnostics and troubleshooting we will first go to Manage Connections > Services Status

    From here, examine the "Wi-Fi Network" configuration. This should be on, have an active profile, SSID and security type. If this is "OFF" then you will want to make sure the WiFi is "ON" and connected to a network.

    Next, go to Manage Connections > Wi-Fi Options. Press Menu > Wi-Fi Diagnostics. This information window will provide you with a number of areas about your wireless connection. When connected properly, this will tell you everything from the profile name, to IP address, status of your connection, UMA status, etc. This is a good place to start when you run into a WiFi problem.

    Finally, we take this one step further and do a "Site Survey". This can be done by pressing Menu > Site Survey from the WiFi Diagnostics window. It will prompt you to start scan... so press your track ball and begin the scan. It will turn on your WiFi (if not on already) and scan for all available wireless networks. This then gives a detailed report of all of the WiFi networks available near you.

    Specifically, you want to look at the network you desire to connect to and the channel it is running on! If your channel interferes with any of the other visible networks, then you will want to configure your router to have a different channel to get the best results. Sometimes interference can cause a number of connection issues and confuse your device! To change the channel on your router, consult your router's user guide or the manufacturer's website. In most cases, you go to your router's configuration page (192.168.0.1 or 192.168.1.1 in your browser). Then, somewhere under the wireless settings, you can change the channel.

    If your device is not connecting to the router, but it can see it through site survey, do a power cycle on both the router and your device. Once this has been completed, attempt to connect to the network again. If problems continue to persist, I recommend starting fresh from a full reset on the router (no security) and attempting to connect. Once you establish a connection without security, you can go back to the router's configuration and enable security. You will then need to make the proper adjustments to that network profile's security on your device... then connect.
    I am not sure setting your browser to 'Hotspot' is such a great idea, I did this with mine and it prevented any use of the cell network - just said this is a WiFi option only.

    Changed it back to internet browser which made no difference to UMA connectivity - rock solid since I changed router.
    08-12-10 10:47 AM
601 ... 2021222324 ...
LINK TO POST COPIED TO CLIPBOARD