09-14-13 01:55 PM
601 ... 1516171819 ...
tools
  1. lmaopanda's Avatar
    hey, i recently got a bold (unlocked) and am having troubles connecting to any wirelss network. my family has no problems with their phones (iphone and nokia e71) connecting, but i can't connect to any wireless network through wifi. i'm able to find networks, but once i try to connect it tells me i'm not able to connect because it failed to obtain an ip address. when i went to look at the wifi diagnostics page, i can see all the info except the local ip address as well as authentication failure reason. also the status says: ip address no longer valid.

    please help, and any suggestions would be grateful. thanks : )
    07-03-09 02:16 AM
  2. OldDeadOne's Avatar
    I have my home wifi router with bold,when I'm out working how can I switch to looking for wifi when I'm working and then back to my home wifi on the bold? Can I have two separate settings for this?
    07-03-09 12:48 PM
  3. fdv8's Avatar
    I have an ATT 8900 and when I do what you say here:

    Next, we will fine tune some other connection properties. Navigate to Home Screen > Manage Connections > Mobile Network Options. Under 'Connection Preference' make sure you have 'WiFi preferred' selected.

    This dictates what connection your device will choose, depending on availability. For example, if the WiFi is turned on and you enter one of your WiFi hotspots (which you added in Step 1) then your device will automatically connect and use that connection as the default connection (making UMA calls).
    (Please note, this does not automatically switch your browser configuration to connect between EDGE/WiFi. The WiFi preferred only affects the mobile network connection of your device. You will need to manually change from 'WiFi browser' to 'Internet' browser... and vise versa)

    You can change this setting to whatever you may desire... and the options are self-explanatory:

    * Mobile Network Only -- Will not use the WiFi connection to make any calls (browsing still available)
    * Mobile Network Preferred -- will only use WiFi when the Mobile Network is unavailable (in poor service areas)
    * WiFi Only -- Will only make UMA calls over WiFi, even if mobile network is available
    * WiFi Preferred -- will make UMA calls when a WiFi network is available, mobile network if not available

    When I get to Mobile Network Options I don't have an option for Connection Preference. How come?
    07-14-09 06:16 PM
  4. cjizzahn's Avatar
    Just read this thread and found I needed Mobile Network Preferred when I am in the basement where I have no service but there wi fi is still there.
    07-17-09 04:13 PM
  5. John Connor's Avatar
    Got the solution..!! Here is how I got my 8900 to work with wi-fi without Data Plan with AT&T

    1) Download Opera Mini and install it on your blackberry. (I downloaded it from my computer and transferred it to BB. After installing Opera Mini, it has to connect to Opera website once to "I accept/I decline" agreement, so your phone will be charged for ~10KB of data in your Pay as you go data plan)
    2) Call ATT and ask them to Block all your Data. This way you wont accidentally connect to ATT EDGE network
    3) Go to Settings>Mobile Network>Data Services=ON (confirm this)
    4) Now Opera should work fine. Note that Blackberry browser wont work as it will still try to connect through EDGE network.

    PS: There are some places where you have to choose your default browser as HotSpot Browser instead of MediaNet.

    3 days of tweaking and it finally worked..!! Still No BES, No IM, No application....just Opera works..will update more on this...
    07-18-09 01:35 PM
  6. GenuineHelp's Avatar
    Re: Is there a reason why most public wifi spots dont work or is it just me?

    Not too sure what is going on with yours but I would re-try the procedures that were outlined.
    07-20-09 12:37 PM
  7. cycotom's Avatar
    great info, thanks for sharing!
    07-21-09 01:42 PM
  8. zackor2's Avatar
    WiFi when no carrier, Telus, service? I have recently upgrades to a 8350i with WiFi that works great at home & work etc.

    Australia has no iDen coverage, so I have never been able to use my mobile in Australia (I just buy a $25 local sim and borrow a friends phone, much cheaper). Next time I go to Australia will I be able to receive emails and browse, (no voice) using WiFi?

    Telus says no, but I can browse at home with "Mobile Network Telus" turned off?
    07-23-09 02:58 PM
  9. jezmck's Avatar
    Hi all,
    has anyone had any luck using WiFi on an O2 handset with no data plan?

    It seems that they're arbitrarily blocking my WiFi because I don't have a data plan.
    Though I may be mistaken.

    I have a greyed out WiFi icon, but am connected okay.

    I've tried following the numerous guides out there, but they either refer to options that I don't have, or they simply don't help me personally...

    Any help will be hugely welcomed!
    07-28-09 03:29 PM
  10. coldfeet06's Avatar
    i want wifi
    07-29-09 07:33 PM
  11. coldfeet06's Avatar
    i wish verizon had wifi storms
    07-29-09 07:34 PM
  12. coldfeet06's Avatar
    i hope phones in the future at verizon get wifi by popular demand
    07-29-09 07:34 PM
  13. jcreazy's Avatar
    If I have ATT with data blocked would changing it to "Wifi Only" instead of "Wifi preferred" be the way to go?
    07-31-09 10:17 PM
  14. LazyCat's Avatar
    Hi everybody.
    Need help about Wi-Fi.
    I have a wi-fi connection at home and i have no problem to surf the web (PC, laptop & PSP). I connect to home wi-fi without the problem, but when i want to connect to any site my BB 8900 says "Unable to find requested link".
    Any suggestions?
    08-01-09 02:52 AM
  15. vinmontRD's Avatar
    I never appreciated the potential value of UMA until I actually started using it when I picked up my Blackberry 8900 the week it was released in T-Mobile stores. My T-Mobile signal is incredible weak at home, and I'm lucky to connect at GPRS speeds. With UMA, I get spectacular speed, great web browsing, and the ability to use the phone anywhere in my house. The problem is that, while UMA has great potential, I've found that it's been less than perfectly stable. For the most part over the last several months, I can be connected over UMA for hours, send and receive email and text, watch my weather updates come in, and make calls. But...it seems that voice calls always created problems in the system, as the calls would abruptly drop typically after the first few minutes. I would also see the connection in the phone mysteriously drift from UMA to uma to GPRS to gprs when I was having trouble -- and this was when I was sitting in the same room as the WiFi router. Well...it appears that the changes I made last night have finally got this working beautifully...

    I picked up the info on various other sites (I must have read hundreds of posts before finally settling on these choices). Some credit Linksys with having shared this info, some T-Mobile, and some claim to have discovered the settings themselves. I'm not sure about the origin, but I can report exceedingly good results. With the settings described below, I've been able to do everything over UMA that I normally do -- email, SMS, MMS, fast web browsing, weather updates, Viigo, etc. -- and now I can also make phone calls without fear of them cutting out suddenly after a few minutes. Today, I made a few calls, including one for 35 minutes and one for 42 minutes. Sound quality was like a corded phone, and the connection was rock solid.

    My setup:

    Verizon FIOS fiber ---> ONT (fiber to copper) --> Actiontec Router (FIOS support) --> Linksys WRTU54G-TM router (T-Mobile@Home support)

    The Actiontec has a couple of layer 2 switches plugged into it and 5 PC's hung off the switches. I have turned OFF the WiFi section of this router.

    The Linksys WRTU54G-TM supports my T-Mobile@Home VoIP (UMA actually) service, replacing my old corded phones. I also have WiFi turned on in this device. This is what I use to support WiFi connection to my laptops and my Blackberry 8900.

    Linksys WRTU54G-TM settings:

    Setup pages -- pretty much vanilla, except that I restrict the DHCP auto-assignment range to leave a few available for static IP's for my printer, NAS drive and a couple of other devices. Nothing special here.

    Wireless Page -
    - Basic Wireless Settings:
    --- Wireless network mode -- G only
    --- Wireless Channel -- 6 (although this shouldn't matter -- choose one with least interference in the vicinity)
    --- Wireless SSID broadcast -- enabled

    - Wireless Security
    --- Security Mode -- WPA2 Personal
    --- WPA Algorithms -- TKIP/AES

    - Advanced Wireless Settings
    ..[only listing non-default settings here]..
    --- Beacon Interval -- 50 (default is 100)
    --- Fragmentation Threshold -- 2304 (default is 2346)
    --- RTS Threshold -- 2304 (default is 2307)

    - Applications & Gaming
    -- QoS tab
    --- Wireless QoS section
    ---- WMM Support -- Enabled

    Actiontec settings: only thing unique here is that I set up QoS rules to prioritize traffic to the Linksys WRTU54G-TM (priority level 6).

    That's it. With these settings, UMA has for the first time become totally solid and dependable. I have the routers in my basement office, and have a strong signal throughout the entire house on my 8900. I can stroll all around the house and have crystal clear phone calls that do NOT disconnect.
    08-04-09 10:00 PM
  16. aristile's Avatar
    I never appreciated the potential value of UMA until I actually started using it when I picked up my Blackberry 8900 the week it was released in T-Mobile stores. My T-Mobile signal is incredible weak at home, and I'm lucky to connect at GPRS speeds. With UMA, I get spectacular speed, great web browsing, and the ability to use the phone anywhere in my house. The problem is that, while UMA has great potential, I've found that it's been less than perfectly stable. For the most part over the last several months, I can be connected over UMA for hours, send and receive email and text, watch my weather updates come in, and make calls. But...it seems that voice calls always created problems in the system, as the calls would abruptly drop typically after the first few minutes. I would also see the connection in the phone mysteriously drift from UMA to uma to GPRS to gprs when I was having trouble -- and this was when I was sitting in the same room as the WiFi router. Well...it appears that the changes I made last night have finally got this working beautifully...

    I picked up the info on various other sites (I must have read hundreds of posts before finally settling on these choices). Some credit Linksys with having shared this info, some T-Mobile, and some claim to have discovered the settings themselves. I'm not sure about the origin, but I can report exceedingly good results. With the settings described below, I've been able to do everything over UMA that I normally do -- email, SMS, MMS, fast web browsing, weather updates, Viigo, etc. -- and now I can also make phone calls without fear of them cutting out suddenly after a few minutes. Today, I made a few calls, including one for 35 minutes and one for 42 minutes. Sound quality was like a corded phone, and the connection was rock solid.

    My setup:

    Verizon FIOS fiber ---> ONT (fiber to copper) --> Actiontec Router (FIOS support) --> Linksys WRTU54G-TM router (T-Mobile@Home support)

    The Actiontec has a couple of layer 2 switches plugged into it and 5 PC's hung off the switches. I have turned OFF the WiFi section of this router.

    The Linksys WRTU54G-TM supports my T-Mobile@Home VoIP (UMA actually) service, replacing my old corded phones. I also have WiFi turned on in this device. This is what I use to support WiFi connection to my laptops and my Blackberry 8900.

    Linksys WRTU54G-TM settings:

    Setup pages -- pretty much vanilla, except that I restrict the DHCP auto-assignment range to leave a few available for static IP's for my printer, NAS drive and a couple of other devices. Nothing special here.

    Wireless Page -
    - Basic Wireless Settings:
    --- Wireless network mode -- G only
    --- Wireless Channel -- 6 (although this shouldn't matter -- choose one with least interference in the vicinity)
    --- Wireless SSID broadcast -- enabled

    - Wireless Security
    --- Security Mode -- WPA2 Personal
    --- WPA Algorithms -- TKIP/AES

    - Advanced Wireless Settings
    ..[only listing non-default settings here]..
    --- Beacon Interval -- 50 (default is 100)
    --- Fragmentation Threshold -- 2304 (default is 2346)
    --- RTS Threshold -- 2304 (default is 2307)

    - Applications & Gaming
    -- QoS tab
    --- Wireless QoS section
    ---- WMM Support -- Enabled

    Actiontec settings: only thing unique here is that I set up QoS rules to prioritize traffic to the Linksys WRTU54G-TM (priority level 6).

    That's it. With these settings, UMA has for the first time become totally solid and dependable. I have the routers in my basement office, and have a strong signal throughout the entire house on my 8900. I can stroll all around the house and have crystal clear phone calls that do NOT disconnect.
    Here is a really good UMA Guide posted by another crackberry member:

    http://forums.crackberry.com/f100/uma-setup-how-206217
    08-04-09 11:05 PM
  17. falcobramblewood's Avatar
    now that my wifi is stable, I will have to reread this and tweek my settings. Every once and a while I drop my UMA connection while on a call...
    08-10-09 11:18 PM
  18. vinmontRD's Avatar
    Six days since I posted the note with the threshold tweaks -- and I haven't had a single UMA call drop in the middle since then. It's really made an enormous difference for me. Really loving UMA now.
    08-10-09 11:23 PM
  19. babyHERO's Avatar
    i cant wait to get my blackberry. Iv'e been wanting one for so long. Can't wait to use wifi either
    08-17-09 09:57 AM
  20. babyHERO's Avatar
    i cant wait to get my blackberry. Iv'e been wanting one for so long. Can't wait to use wifi either
    08-17-09 09:57 AM
  21. babyHERO's Avatar
    is wifi on all blackberry?
    08-17-09 10:43 AM
  22. loveliestjack's Avatar
    Great guide..
    ...however I am experiencing some issues with wi-fi and my bold. All has been working fine until today when my wi-fi connection has stopped. The wi-fi icon is on the main screen but is not lit up like normal, and I am unable to use the services - do you what it could be? I have tried uninstalling the current settings and re setting it from scratch but still nothing.

    Many thanks
    08-23-09 03:25 PM
  23. vinmontRD's Avatar
    Great guide..
    ...however I am experiencing some issues with wi-fi and my bold. All has been working fine until today when my wi-fi connection has stopped. The wi-fi icon is on the main screen but is not lit up like normal, and I am unable to use the services - do you what it could be? I have tried uninstalling the current settings and re setting it from scratch but still nothing.

    Many thanks
    There are a lot of variables, especially when you're using a consumer-grade router / access point. Common consumer grade routers (e.g., Linksys, DLink, Netgear) tend to have better hardware than firmware. Early firmware releases tend to be premature and not fully debugged. In my experience, the subsequent firmware updates tend to help, but it seems that the economics of the home wifi router / access point market push the vendors to release new models every couple of years rather than continue to keep refining the firmware after the first 18 to 24 months. As a result, many of the products work "pretty well", but may need periodic rebooting to make them continue to work as expected. This may be due to memory leaks or other progressive issues in the firmware that are "fixed" temporarily by rebooting and starting over.

    First thing I'd suggest trying is to reboot your wifi router, and perhaps dropping and reconnecting the wifi connection from your phone after that to see if it makes a difference.

    Also: if you re-post -- please specify details of your phone, carrier, OS version, router / wifi access point and firmware version, as well as any settings you've plugged into it re: security, etc.
    08-23-09 03:34 PM
  24. loveliestjack's Avatar
    Hi Jon,

    My Phone is a Bold 9000 on the 3G network, version v4.6.0.216. We have 2 bold's in the household and my other is working fine so I don't think it's the router.
    Under the wi-fi connection options, it is showing my home network is an option and it seems that all of the settings are present, but something is missing somewhere. Under wi-fi diagnostics the Status says network acquired.
    Another issue is that I cannot via BIS either although the I do have an add-on on my account to allow this to happen and that has also stopped working. When I have completed a diagnostic the RDA: No, IP address unknown. I have tried re-sending the service book etc but currently unable to receive them due to no internet connection.

    I really hope you can help
    08-23-09 04:20 PM
  25. vinmontRD's Avatar
    Hi Jon,

    My Phone is a Bold 9000 on the 3G network, version v4.6.0.216. We have 2 bold's in the household and my other is working fine so I don't think it's the router.
    Under the wi-fi connection options, it is showing my home network is an option and it seems that all of the settings are present, but something is missing somewhere. Under wi-fi diagnostics the Status says network acquired.
    Another issue is that I cannot via BIS either although the I do have an add-on on my account to allow this to happen and that has also stopped working. When I have completed a diagnostic the RDA: No, IP address unknown. I have tried re-sending the service book etc but currently unable to receive them due to no internet connection.
    I don't have a Bold, but I can think of a couple of items to check.

    First, if you can't connect to the phone network via BIS, I'm thinking that you won't be any more successful via WiFi -- sounds to me like some aspect of the device configuration is not allowing a proper connection to the phone network. Pursuing this idea, two items come to mind to check right off. Neither seems likely to me, since your phone connected prior to today -- unless something you did changed a setting or two. Anyway -- let's check:

    1) The firewall settings -- in Options / Security / Firewall -- are the settings the same for the two Bolds in the house?

    2) Even if the settings appear to the be the same, if have you have the firewall turned ON, the first time a process or program attempts to make a connection outside the firewall (e.g., on the Internet), the Blackberry prompts you and asks you 1) if the connection should be allowed, and 2) if you should be prompted again next time -- or if the Blackberry (actually, the Firewall) should assume the answer will be the same. Occasionally, somebody will inadvertently say "no" to the firewall permissions question, and then never see the prompt again -- but the firewall will keep denying the connection.

    To tell the Firewall that you DO want to be prompted again, and have another chance to set permissions for a particular app, go into Options / Security Options / Application Permissions. You normally would scroll down and select a particular application whose Firewall settings you'd want to change. I'm assuming that in the case of the Blackberry Browser, the modules that need permission are under "BlackBerry 4.6 Core Applications" and "BlackBerry 4.6 System Software". Select "Edit Permissions", and when on the next screen, hit the menu button and select "Reset Firewall Prompts". Then hit the menu button again, and select "Save". This way, the next time you attempt to use one of the core applications to gain outside access, you will be prompted to allow the connection. You can follow this general procedure for any app on the Blackberry that needs an outside connection, assuming you have the firewall turned on.

    The fact that you can't get an IP address is of more concern to me. Is there any chance the APN settings were changed? Go into Options / Advanced Options / TCP/IP.

    You should see : APN Settings Enabled checked on the first line.

    The second line should have the name of the APN (access point name) that your phone carrier provides as an Internet gateway for their Blackberry BIS users. In my case, since I'm a T-Mobile customers, I see "epc.tmobile.com" (and an alternate -- an older one -- is "wap.voicestream.com").

    Not positive about the AT&T settings (I'm assuming you're there?), but I believe they are:

    APN: wap.cingular

    Username: wap@cingulargprs.com

    Password: CINGULAR1

    No idea if this is relevant to your situation, but: It's important to double-check your APN settings any time you load a new OS *IF* your Blackberry is an unlocked device that was originally on another carrier. Along with "vendorID", the APN settings from the original carrier remain intact in protected storage even across an OS load, and the fields are reinitialized with the original vendor-specific values any time the OS is reloaded on the device.

    Along with re-sending service books, have you tried re-registering with the wireless network from the Bold? You would do this via Options / Advanced Options / Host Routing Table. Once the list of gateways comes up, you can press the menu button and select "Register Now".

    There are other areas we can explore, but these are the first that come to mind...
    08-23-09 08:11 PM
601 ... 1516171819 ...
LINK TO POST COPIED TO CLIPBOARD