1. stgrego78's Avatar
    Hello I have a sprint 8330 that I am trying to download the boost mobile software onto but it's not working. The app loader keeps telling me the following.


    "THE BLACKBERRY DESKTOP SOFTWARE DOES NOT HAVE BLACKBERRY DEVICE SOFTWARE FOR THE DEVICE THAT YOU HAVE CONNECTED TO THE COMPUTER. CONTACT YOUR WIRELESS SERVICE PROVIDER OR SYSTEM ADMINISTRATOR"

    WHAT DOES THIS MEAN?

    Pleased help!!
    03-25-10 12:11 AM
  2. Krypto's Avatar
    Hi there, this is because you are attempting to load the OS from one carrier to a phone from another carrier. This is what you need to do:

    1. Download and install the OS to your computer
    2. Backup your phone using the BlackBerry Desktop Manager. Close the Desktop Manager.
    3. Open Windows Explorer and go to C:\Program Files\Common Files\Research In Motion\Apploader (on 64-bit systems, go to C:\Program Files (x86)...). Delete the Vendor.xml file in this folder, then double click and run the Loader.exe file in the same folder. This will open the application loader.
    4. Run the application loader (Loader.exe). Select the applications you want installed when prompted and then click next and proceed to install the OS. Note, this process may take ~30 minutes depending on how many apps are getting installed.
    5. If the OS loading process does not restore your data, open the Desktop Manager and restore your data using the backup file you created.
    6. Reinstall any missing third party applications.

    That's it. With that, you should be good to go. The key step here is step number 3. You have to delete that vendor.xml file and use the application loader or it may not work.
    03-25-10 01:06 AM
  3. stgrego78's Avatar
    Ok so I try that and it tells me "THIS APPLICATION IS NOT COMPATIBLE WITH YOUR DEVICE AND CANNOT BE LOADED" wHAT NOW?
    03-25-10 01:27 AM
  4. Krypto's Avatar
    Do you have the 8330 or the 8330m? You should be able to find this info by going to Options > About
    03-25-10 01:54 AM
  5. stgrego78's Avatar
    just a 8330
    03-25-10 02:03 AM
  6. stgrego78's Avatar
    oh sorry my mistake. It's actually a 8330m
    03-25-10 02:05 AM
  7. Krypto's Avatar
    oh sorry my mistake. It's actually a 8330m
    Bingo, that's the reason why... and I'm guessing you've now figured it out as well, right? Unfortunately, the software for the 8330 won't work on the 8330m, meaning you can't use the Boost Mobile OS.

    03-25-10 02:48 AM
  8. o0desufnoc0o's Avatar
    i hope someone responds to this!

    i have the 8330 on telus, and i'm certain it's a 8330, not 8330m. i also get the "This application is not compatible with your device and cannot be loaded." this is what i get using the loader, installing OS 5.0.0.438 (Boost) from the blackberry website. i have deleted the vendor file and simply do not know what else to try.

    help
    04-20-10 08:02 PM
LINK TO POST COPIED TO CLIPBOARD