08-03-12 11:59 AM
91 123 ...
tools
  1. wu-wei's Avatar
    [email protected] Hybrid: Agile (20120718)

    Created by wu-wei

    Those of you who regularly use my builds know the drill, but this one incorporates new files from the just-released 7.1.0.569 OS.

    I have also modified several files based on feedback from my testers. I believe we have isolated the closing page error.

    My hybrids go through testing on several devices, and I am confident that my builds work well on all OS6 devices.

    Recommended base OS versions:

    9300: 6.0.0.723
    9650: 6.0.0.707 (or 6.0.0.719)
    9700: 6.0.0.723
    9780: 6.0.0.723
    9800: 6.0.0.723

    ***NOTE: If you are using a 9700 and experience the "closing page" error, I recommend using 6.0.0.668 as the base OS for this build.

    While these base OSes are recommended, Agile will work over any 6.0.0.6xx or .7xx OS. If you have found another OS in those series that works best for you, certainly feel free to use that one instead.

    Please note that some users have reported a "break-in" period with any hybrid. That is, the first day or so has poor battery life, but then things stabilize and we start sipping at the battery again. Battery life is critically important to me, so I am always mindful of those issues (and reluctant to leave my beloved 9700 for some shiny new OS7 device). I have not experienced this phenomenon myself, but I did want to mention that it is possible.

    To install this hybrid, extract the contents of this zip file into the Java folder of the base OS you choose to use. On my system, these files were extracted into C:\Program Files (x86)\Common Files\Research In Motion\Shared\Loader Files\9700M_v6.0.0.723_P6.6.0.248\Java.

    When you extract the cod files into the folder listed above, you should be prompted to confirm that you want to replace existing files. If you are not prompted, then you are probably trying to extract to the wrong directory and the hybrid files will not be installed on your device.

    If you do not know exactly what you're doing, then you should choose one of the following options:

    1. DO NOT ATTEMPT TO INSTALL THIS HYBRID.
    2. Read my guide on the CrackBerry forums, available here: Hybrid OS Installation Guide
    3. Read any How To posts by elite1 in practically any hybrid or leaked OS thread on CrackBerry.com
    4. Search the CrackBerry forums and read as much as you can find about how the BlackBerry OS loader process works.


    This package does NOT include any third party applications at all. I build hybrid OSes. I do not promote any apps or force users to choose whether they want to install apps they may not want. If you are looking for a particular third party app, I probably have an opinion about it and may be able to tell you where to find it (I'm talking free or paid versions, NOT WAREZ).

    Many thanks to ench18, bmercer94, evered78, kev23m, leontam, lordnorms, Soulja Boy, and walestrings for testing and feedback.

    Download Agile
    Last edited by wu-wei; 07-18-12 at 10:42 PM.
    07-18-12 09:01 PM
  2. kev23m's Avatar
    Thanks Wu for another solid build.
    wu-wei likes this.
    07-18-12 09:04 PM
  3. CristhianHC's Avatar
    OMG wu, finally! Downloading. I'll try it on my 9800, thanks!
    wu-wei likes this.
    07-19-12 12:51 AM
  4. leontam's Avatar
    Good stuff Wu, thank you!
    wu-wei likes this.
    07-19-12 01:08 AM
  5. emwhy's Avatar
    Finally.. It has arrived!!

    Thanks Wu!!
    wu-wei likes this.
    07-19-12 02:29 AM
  6. henxui25's Avatar
    tks mate, i love u
    wu-wei likes this.
    07-19-12 05:34 AM
  7. bartman's Avatar
    Running fantastic on my 9800. Very snappy, browser is fast, gps lock, wifi and 3G all perfect. Currently still suffering a bit from battery drain due to the reindexing etc. but overall Agile seems great. Also found no lag whatsoever on the browsing media.

    Thanks wu!
    Last edited by bartman; 07-19-12 at 06:30 AM.
    wu-wei likes this.
    07-19-12 06:28 AM
  8. shynepapin's Avatar
    So quick Wu, you are the master, good one, will try, but would like to ask how do I keep my recent applications versions, like my twitter and bbm.
    07-19-12 07:57 AM
  9. emwhy's Avatar
    I'm going to try this later after work. Currently downloading it using my 9780. My weekend will be busy testing this release. Thanks again Wu.
    wu-wei likes this.
    07-19-12 08:36 AM
  10. deathbearry's Avatar
    Thanks Wu. Can't wait to install it!
    wu-wei likes this.
    07-19-12 08:39 AM
  11. bmercer94's Avatar
    Still working fine.
    better than Afterburner.
    wu-wei likes this.
    07-19-12 10:10 AM
  12. bharuch7282's Avatar
    downloading now will try in weekend thanks wu
    07-19-12 10:35 AM
  13. kev23m's Avatar
    Dont do a wipe. Start app loader and let it do the rest.

    So quick Wu, you are the master, good one, will try, but would like to ask how do I keep my recent applications versions, like my twitter and bbm.
    wu-wei likes this.
    07-19-12 10:38 AM
  14. BullMarket's Avatar
    Alright...initial report 12 hours in on a 9700.

    Battery consumption is better for me compared to Afterburner, and unit is not running as hot. I did a security wipe and app deletion prior to intalling his hybrid. Also wiped the OS and started with white screened device.

    Browers thus far has been very good. Fast...loading multiple tabs with no issues. Have not loaded a super large page yet, but for my normal browsing use it has been monster.

    12 hours in and the hour glass is much less eventful. I take this as the OS starting to settle, and all in all the interface is snappy and without lags.

    I still had the lag when trying to preview a photo that was just taken by the camera. Basically, I take the picture...scroll all the way to the left preview menu and click. The photo takes about 15 seconds to render. I will see if this improves as the OS settles.

    Memory leak is holding at about 22 to 23 MB from an initial value of approximately 90. Does not impact performance.

    Thanks again for the hard work in building and testing this build. If i can resolve the photo preview lag then I am golden.

    Thanks!
    07-19-12 11:56 AM
  15. shynepapin's Avatar
    Dont do a wipe. Start app loader and let it do the rest.
    I didn't but still showed the downgrade option, read somewhere in the forum to remove two cod file did do that but it showed downgrade, then I remove the blackberrymessenger.alx file so I didn't get BBM at all but downloaded straight using a browser prompt.

    Now using Agile, guess it hasn't settled but so I can't say anything now but tested the browser with 3 tabs but it still say memory low and shutdown even after closing one tab.

    Thought Wu really put so much into this but I guess we will still wait till it settles and try again but can't stop using browser because when am not on my pc it is my pc.

    Hope Wu will still try looking at this issue and find a solution for it and don't rush the next hybrid, you need time to perfect this, said that because I feel Agile was rushed.

    Thanks Wu for your effort.
    Last edited by shynepapin; 07-19-12 at 12:13 PM.
    07-19-12 12:04 PM
  16. shynepapin's Avatar
    I can't even open crackberry.com not mobile without the browser not closing.
    07-19-12 12:18 PM
  17. CristhianHC's Avatar
    9h, 36m since the startup.
    Battery discharge: Minimum: -0.1%, Maximum: -11.4%, Average: -5.2%.
    Memory: 295.0MB, and since startup: -2.8MB.
    Everything works, fast browser. Good work Wu.
    07-19-12 12:59 PM
  18. wu-wei's Avatar
    I didn't but still showed the downgrade option, read somewhere in the forum to remove two cod file did do that but it showed downgrade, then I remove the blackberrymessenger.alx file so I didn't get BBM at all but downloaded straight using a browser prompt.

    Now using Agile, guess it hasn't settled but so I can't say anything now but tested the browser with 3 tabs but it still say memory low and shutdown even after closing one tab.

    Thought Wu really put so much into this but I guess we will still wait till it settles and try again but can't stop using browser because when am not on my pc it is my pc.

    Hope Wu will still try looking at this issue and find a solution for it and don't rush the next hybrid, you need time to perfect this, said that because I feel Agile was rushed.

    Thanks Wu for your effort.
    Shrink your OS on the PC. If you're worried about twitter and BBM, which it sounds like were updated OTA, then keeping those apps in the Java folder on your PC will attempt to overwrite them. If you want to keep the newer version that is on device, delete the files from the Java folder.
    07-19-12 01:22 PM
  19. CristhianHC's Avatar

    I still had the lag when trying to preview a photo that was just taken by the camera. Basically, I take the picture...scroll all the way to the left preview menu and click. The photo takes about 15 seconds to render. I will see if this improves as the OS settles.
    Thanks again for the hard work in building and testing this build. If i can resolve the photo preview lag then I am golden.
    Same problem here on a 9800.
    Takes like 5 - 8 sec's after taking a picture.
    Still an awesome hybrid, thanks wu.
    07-19-12 01:29 PM
  20. deathbearry's Avatar
    got trouble installing this at first. it suddenly become all white after load it. even icons become sort of square symbols. then i do from scratch. wiped it, and install the new base.
    now, it's done. will drop the review after 24 hours from now.
    07-19-12 02:58 PM
  21. CristhianHC's Avatar
    got trouble installing this at first. it suddenly become all white after load it. even icons become sort of square symbols. then i do from scratch. wiped it, and install the new base.
    now, it's done. will drop the review after 24 hours from now.
    Didn't happened to me.
    07-19-12 03:19 PM
  22. Erniesmit's Avatar
    Backed up my data and completely wiped my phone and installed the Hybrid on the 6.0 Bundle 2949 (v6.0.0.668, Platform 6.6.0.236)
    Base and booting is quick absolutely no lag smooth performance not lag in the picture gallery no lag after taking a picture response is a lot more smoother excellent browsing experience now haven't had a closing page yet pages that usually close now fully load and displays as it should

    Battery drain is much less than afterburner and 8 hours into the install only -0.9mb lost memory

    Thanks wu-wei for an excellent hybrid
    07-19-12 03:35 PM
  23. wu-wei's Avatar
    I wanted to let folks know that I have not completely resolved the closing page error, but I am not seeing it happen very frequently. There's just no way around hardware limitations on the 9700, it seems.
    07-19-12 06:25 PM
  24. BullMarket's Avatar
    My picture rendering lag is still pretty pronounced...about 25 seconds sometime.

    Does anybody have a COD injection procedure to remedy that?

    Perhaps a list a CODs from the 668 base?

    This is for a 9700.

    Cheers!
    07-19-12 08:04 PM
  25. lordnorms's Avatar
    Hmm interesting coz afaik wu-wei already fix that media file rendering by not altering the base cods.
    07-19-12 10:10 PM
91 123 ...
LINK TO POST COPIED TO CLIPBOARD