06-15-12 10:08 AM
111 1234 ...
tools
  1. lester78's Avatar
    You don't have to delete the stock ALX files as they will be overwritten, but I tend to keep stock files backed up and handy in case something goes wrong. I've been using my modified ALX files for quite a long time now and I'm pretty confident about what's in there - for me, anyway.

    My java folder contains 348 cod files (I shrink very aggressively). If you're leaving other apps in there (like VVM or VAD, etc) then system software will report a higher value in the options menu.
    Actually my java folder contains 345 cods because i remove these three files:

    net_rim_errortranslator_tmobile.cod
    net_rim_errortranslator_tmobile_resource.cod
    net_rim_errortranslator_tmobile_resource__en.cod

    But I still got 97mb after using your modified alx files. But that's nice. Are you using the 6.0.0.723 base OS? Because I remember you're using an old base OS when you got the 93mb system software.
    05-26-12 11:24 PM
  2. wu-wei's Avatar
    Actually my java folder contains 345 cods because i remove these three files:

    net_rim_errortranslator_tmobile.cod
    net_rim_errortranslator_tmobile_resource.cod
    net_rim_errortranslator_tmobile_resource__en.cod

    But I still got 97mb after using your modified alx files. But that's nice. Are you using the 6.0.0.723 base OS? Because I remember you're using an old base OS when you got the 93mb system software.
    Interesting.

    No, I'm using 723 on this one too, and my system software still reports 93.9 MB
    05-27-12 12:35 AM
  3. lester78's Avatar
    I will continue my quest to figure out what is causing this issue. I honestly hadn't noticed it, and I am a bit puzzled by what could be making this happen.
    You will not see the BlackBerry logo when your BIS is not connected. It is based on my experience since I am on a prepaid data plan.
    05-27-12 06:43 AM
  4. lester78's Avatar
    Interesting.

    No, I'm using 723 on this one too, and my system software still reports 93.9 MB
    I think something is wrong with my installation. Hope I can figure it out.
    05-27-12 06:44 AM
  5. wu-wei's Avatar
    You will not see the BlackBerry logo when your BIS is not connected. It is based on my experience since I am on a prepaid data plan.
    True, but I want to figure out why this is happening.

    When BIS (or BES) is connected, it should trigger the display of the wifi bullets. Their placement is controlled within themes.....except for some reason the 3G text overrides wifi bullet placement with my hybrids.

    One of the only files that I believe is unique to my hybrids is net_rim_bis_lib (I've been using 7.0.0.277 for a very long time now). If I could have one of the folks who is seeing this problem replace the bis_lib cod with a base OS version (I'd prefer 6.0.0.723) and test whether we get the same result, I would greatly appreciate it.
    05-27-12 11:55 AM
  6. wu-wei's Avatar
    And to be clear, "wifi bullets" is the term used to refer to that specific graphic element - it does not mean that they are only visible when connected via wifi. They are also visible when connected via cell radio.

    Within theme code, they are toggled by these status changes:

    wifi_bis_and_bes_connect / wifi_bis_and_bes_disconnect
    AND
    wapi_bis_and_bes_connect / wapi_bis_and_bes_disconnect.

    I'm almost positive this issue is down to the bis_lib file.
    05-27-12 12:06 PM
  7. Slayohslay's Avatar
    So all i have to do is to change the bis_lib file ? Swap it with ver 6.0.0.723 as you preffered ?
    05-27-12 02:27 PM
  8. wu-wei's Avatar
    So all i have to do is to change the bis_lib file ? Swap it with ver 6.0.0.723 as you preffered ?
    Yes. I'm not positive that will fix the 3G text issue, but I'm pretty sure that's the source of the problem. This is a bit of open testing at work here.
    05-27-12 02:37 PM
  9. Slayohslay's Avatar
    Yes. I'm not positive that will fix the 3G text issue, but I'm pretty sure that's the source of the problem. This is a bit of open testing at work here.
    Will you check that up for us please wu ? hehe
    05-27-12 03:05 PM
  10. wu-wei's Avatar
    Will you check that up for us please wu ? hehe
    I would if I could. I do not currently have 3G coverage to confirm the bullet issue - that's why we're discussing the testing process openly in this thread.

    If you're concerned about causing issues with your device, I can confirm that replacing the bis_lib file will not brick your device. It is also a simple upgrade of one file via Loader - it will not trigger a full OS install....so this will be quick.
    05-27-12 03:09 PM
  11. Slayohslay's Avatar
    I would if I could. I do not currently have 3G coverage to confirm the bullet issue - that's why we're discussing the testing process openly in this thread.

    If you're concerned about causing issues with your device, I can confirm that replacing the bis_lib file will not brick your device. It is also a simple upgrade of one file via Loader - it will not trigger a full OS install....so this will be quick.
    Aight , i give it a shot once im on my PC then
    05-27-12 03:19 PM
  12. wu-wei's Avatar
    Thanks - I appreciate it.
    05-27-12 03:22 PM
  13. Timothy082620's Avatar
    can someone please help me I posted on here before but still no one answered my question... I still get the error. and I can only install the .723 on the 9800
    05-27-12 04:26 PM
  14. wu-wei's Avatar
    I need more information in order to help you.

    It sounds like your installation might be missing a file, but I don't know if you're getting an error on the PC or the device. What is happening? Did you follow the instructions in the first post? Did you shrink out additional files?
    05-27-12 04:42 PM
  15. Timothy082620's Avatar
    I copied the files provided and put them in the java folder of the .723 and when apploader loads I get blackberry core apps and the error says "The application "Blackberry 7.1.0 Core Applications" cannot be loaded, Because it requires the following applications that are not available net.rim.platform.ecmascript
    05-27-12 05:24 PM
  16. wu-wei's Avatar
    Make sure the following files are present in your java folder:

    net_rim_ecmascript.cod
    net_rim_ecmascript_resource.cod
    net_rim_ecmascript_resource__en.cod
    05-27-12 05:44 PM
  17. Timothy082620's Avatar
    no they aren't
    05-27-12 05:49 PM
  18. wu-wei's Avatar
    OK, there could be several problems. Those files should still be there as part of the base OS installation. I do not replace those files as part of my builds.

    Did you delete anything out of the java folder before you copied my files into it? If so, you shouldn't have. Probably the best way to address this is to do a repair of the original stock 723 OS on your PC, then copy my files into that folder.
    05-27-12 06:05 PM
  19. Timothy082620's Avatar
    ok well it worked and this is what shows up and I did that and I got a error 561 on the blackberry I deleted the vendor in the apploader
    oh yeah I forgot to mention when I load the .alx files it says device isn't compatible
    Last edited by Timothy082620; 05-28-12 at 08:49 AM.
    05-27-12 06:23 PM
  20. EVERED78's Avatar
    Installed today and everything running awesome ty again!!!!!!

    Sent from my BlackBerry 9700 using Tapatalk
    wu-wei likes this.
    05-27-12 09:15 PM
  21. moniza's Avatar
    Hello guys.. I've already swap the net rim bis lib file with the base os .723. Thu bullet placement still attach together..
    wu-wei likes this.
    05-28-12 12:34 AM
  22. wu-wei's Avatar
    Hello guys.. I've already swap the net rim bis lib file with the base os .723. Thu bullet placement still attach together..
    [email protected] I thought for sure that was going to sort it.

    Alright, I'll keep looking.....<grumble grumble grumble>
    05-28-12 12:43 AM
  23. wu-wei's Avatar
    Anyone willing to try it out can switch net_rim_bb_banner to the base OS version. There may have been some changes along the way with that file....
    05-28-12 01:30 AM
  24. moniza's Avatar
    Already done that wu wei.. Net rim banner app , net rim banner lib, net rim bb banner skin svg, skin svg delayed initializer.. The bullet still attached .. If I found the solution I'll post here too.. It kinda nnoy me too..
    Slayohslay and wu-wei like this.
    05-28-12 06:56 AM
  25. Slayohslay's Avatar
    Already done that wu wei.. Net rim banner app , net rim banner lib, net rim bb banner skin svg, skin svg delayed initializer.. The bullet still attached .. If I found the solution I'll post here too.. It kinda nnoy me too..
    Indeed it is , annoying much
    05-28-12 07:22 AM
111 1234 ...
LINK TO POST COPIED TO CLIPBOARD