1. kjjb0204's Avatar
    Seems many people are noticing memory loss, some with no user activity. Can you take note if there is a significant memory loss on your Tour running .419? It's the only thing stopping me from loading right now. I know it's been mentioned in the other .419 threads, but thought this issue is significant enough to warrant it's own thread.
    01-05-10 12:27 PM
  2. willyboy6's Avatar
    Seems many people are noticing memory loss, some with no user activity. Can you take note if there is a significant memory loss on your Tour running .419? It's the only thing stopping me from loading right now. I know it's been mentioned in the other .419 threads, but thought this issue is significant enough to warrant it's own thread.
    i have experienced minimal. and even if you were losing a meg or two a day, IMO it'd be worth it...
    01-05-10 12:28 PM
  3. Tifoso's Avatar
    As said in the other thread, lost 0.2MB in 10 hours sitting idle overnight.
    Lost 2.2MB since 8:18am with moderate activity.

    I don't see this OS as having a significant memory leak. Your results may vary.
    01-05-10 12:30 PM
  4. berryfit's Avatar
    Ive been up and running for 4 hours and I have zero memory leak. Which is pretty incredible so far. Its possible someone has an app that leaks worse with this version, but so far so good here. Im going to put berryweather on and see what happens. That damn thing was leaking like crazy...we'll see..

    the os itself seems very stable though.
    01-05-10 12:33 PM
  5. jgodin03's Avatar
    I have 89mb free. On .230 I had 96. So the leak is not very huge...

    Posted from my CrackBerry at wapforums.crackberry.com
    01-05-10 12:35 PM
  6. kjjb0204's Avatar
    Great info, keep it coming. Leaning towards loading up this bad boy!
    01-05-10 12:53 PM
  7. RBBB's Avatar
    -.9mb in 8 hours for me. Battery seems good 1.2 %.
    Last edited by RBBB; 01-05-10 at 03:49 PM.
    01-05-10 03:46 PM
  8. livspop's Avatar
    At first, I thought there was a memory leak issue. But after a few battery pulls for various other reasons, there has been no leakage at all.

    In fact, my memory level has not moved since 8 a.m. this morning despite moderate texting, emails and phone calls. This is actually the most stable OS I have experienced (memory-wise) with all of my BBs, beta or official! I have had no issues whatsoever with anything on this beta. Battery life is also as good or better than the latest "official" release.
    Last edited by livspop; 01-05-10 at 04:26 PM.
    01-05-10 04:23 PM
  9. elir41's Avatar
    I had major memory leakage. I put it to charge last night around 10 with 97mb, and awoke to 78mb. This is with around 10 apps and 2 themes and nothing running in the background. I did a batt pull and went to 96mb. About half an hour after that, it dropped to 92. It kept dropping slowly after that. I decided to drop back down to 4.7 and my memory is still holding steady. I might try a complete wipe and try it again. We'll see...

    Posted from my CrackBerry at wapforums.crackberry.com
    01-05-10 07:14 PM
  10. dreedy1's Avatar
    Loaded software to my device (completed) @ 6:57pm est, did a battery pull and rebooted. At 7:03pm, I had 107.6 MB free.....it is 7:49pm and I now have 102.3 MB free with 11 apps running and free signal strength (I'm basically doing a stress test on the memory since this seems to be a major thread in the forums on this leaked OS). I'm gonna mark what I have @ 8:33pm, reboot and see what I get in another hour and a half with little to no apps running. Will keep you posted.
    01-05-10 07:51 PM
  11. dreedy1's Avatar
    Loaded software to my device (completed) @ 6:57pm est, did a battery pull and rebooted. At 7:03pm, I had 107.6 MB free.....it is 7:49pm and I now have 102.3 MB free with 11 apps running and free signal strength (I'm basically doing a stress test on the memory since this seems to be a major thread in the forums on this leaked OS). I'm gonna mark what I have @ 8:33pm, reboot and see what I get in another hour and a half with little to no apps running. Will keep you posted.
    *full signal strength I meant. Sorry
    01-05-10 07:52 PM
  12. dreedy1's Avatar
    Alright...stress test #1 on memory leak is done.

    Started @ 7:03pm, ended @ 8:33pm. In an hour and a half, I went from 107.6 MB free to 97.6 MB free (-10 MB) with 11 apps running in the background. Apps running were:

    BerryWeather, Facebook, Home, Mobile Checkbook, Clock, Windows Live, Camera, Browser, App World, BBM, SMS/MMS

    Did battery pull and rebooted....at 8:39pm, memory was at 108.0 MB. This go round, I'm only gonna have FB and BerryWeather running in the backround...other than the normal stuff (phone, messages, browser etc.)

    Will give you another update around 9:45pm
    01-05-10 08:43 PM
  13. dreedy1's Avatar
    Alrighty then...memory leak test #2

    8:39pm = 108.0 MB
    9:39pm = 107.7 MB

    0.3 MB leak in an hour

    Apps running: Facebook, BerryWeather, SMS/MMS, Browser
    Moderate use of FB and SMS during that hour.

    Gonna do a battery pull, reboot and see what happens overnight but looks like after the inital pull, it may not be leaking as much. Lets hope because it's a great build!!
    01-05-10 09:44 PM
  14. jasper0201's Avatar
    Mass mem leak only after I open the browser. Even if I close it out after I will leak upwards to 19mb, oing to DL the hybrid, load it up, set it up and see if one of them can fix it up... we will see...
    01-16-10 12:50 AM
  15. gchahinian's Avatar
    big memory leak for me....with 4.7 i was at a constant 103 free, now over the course of the day i drop down to 89 mb before i get home from work
    01-18-10 08:51 AM
  16. rumessingwitme's Avatar
    Mine is better on .419 vs .230
    01-18-10 03:05 PM
  17. SuperWario89's Avatar
    I have a drop of about 10mbs over a full day. I usually only have the default apps running plus berryweather. I've heard that berryweather has a lot of memory issues tho. Even with this memory leak I still like .419 better than 4.7 which is what I was running earlier.

    I should also note that I loaded .419 onto my phone without wiping it. I've had no bugs at all. My VAD works, no sms bugs. Better battery life, great signal, fast download speeds for apps and web pages (using opera mini 5). My only problem is the memory leak. (I've been running .419 for about a week now
    01-18-10 04:09 PM
  18. SuperWario89's Avatar
    i no longer have memory leak, i removed two of my locations on berryweather, and suddenly i have virtually no leaking. i only have two locations now instead of four.

    i've also been running berryjoose since i loaded .419, so that may be helping now too (altho i'm not sure why i would have had a leak in the first place from 4 locations on berry weather, but maybe berryjoose can keep up with the leak now that i only have two locations?)

    either way i am very happy now, super snappy, no complaints at all anymore
    01-19-10 12:23 AM
  19. JR_Rider's Avatar
    i no longer have memory leak, i removed two of my locations on berryweather, and suddenly i have virtually no leaking. i only have two locations now instead of four.

    i've also been running berryjoose since i loaded .419, so that may be helping now too (altho i'm not sure why i would have had a leak in the first place from 4 locations on berry weather, but maybe berryjoose can keep up with the leak now that i only have two locations?)

    either way i am very happy now, super snappy, no complaints at all anymore

    You all are very lucky with your 5.0.0.419 memory losses. I have been experiencing such extreme memory losses that I am considering dropping back to 4.7. When I initially loaded 5.0 I booted with over 100mb. Over the course of having it installed on my phone, the free memory at bootup has decreased drastically. Now my phone only boots with about 55mb. On top of that, I have one of the highest memory leaks I have ever experienced, which causes me to drop to below 5mb after about 24 hours of uptime. I have no idea what is causing my memory leak or the loss in memory at bootup. I thought my memory leak was coming from BerryWeather 2.0 and Beejive but that was not the case. I actually lost memory faster when not running them. I just deleted App World so we shall see if that makes a noticeable difference.
    01-22-10 08:51 AM
  20. willyboy6's Avatar
    You all are very lucky with your 5.0.0.419 memory losses. I have been experiencing such extreme memory losses that I am considering dropping back to 4.7. When I initially loaded 5.0 I booted with over 100mb. Over the course of having it installed on my phone, the free memory at bootup has decreased drastically. Now my phone only boots with about 55mb. On top of that, I have one of the highest memory leaks I have ever experienced, which causes me to drop to below 5mb after about 24 hours of uptime. I have no idea what is causing my memory leak or the loss in memory at bootup. I thought my memory leak was coming from BerryWeather 2.0 and Beejive but that was not the case. I actually lost memory faster when not running them. I just deleted App World so we shall see if that makes a noticeable difference.
    If you're not running one of the .419 hybrids from BBhybrids you should consider picking one and giving it a shot. There are a few builds that have proved to eliminate this terrible memory leak that .419 is known for.
    01-22-10 10:19 AM
  21. berryfit's Avatar
    The only leak I ever had with .419 was with berryweather. When .419 runs on its own, I lose MAYBE 1 meg over a few days. With Berryweather, I use BerryJoose and it keeps it under control.

    I found today that with ubertwitter, and berryweather, my screen keep freezing going from keyboard lock, to unlock and a moderate leak.

    I think all bb's leak a bit, but its app related i think. I removed both berryweather and ubertwitter and no more freeze for a few seconds and its speedy again. Not a fan of berryweather for that only reason.

    Check your apps. even unload them one at a time, and reload one at a time and see how the leak goes.

    Make sure you arent keeping any open without knowing. Hold the menu key and see what's running. Berryweather, even when you are in it and close it properly, is still in the background...check your settings on apps to make sure they arent running in the background.
    01-22-10 10:28 AM
  22. kjjb0204's Avatar
    It seems as the days pass, my memory leak on stock .419 is correcting itself. Memory leak is negligible now.
    01-22-10 04:41 PM
  23. jasper0201's Avatar
    I am still having massive mem leaks. Unfortunately I have only notived it with my favriot things. The BB browser, and get this.. CB launcher.. I am not sure if CB launcer takes you just to the browser or if it is another process. I hope not... CB please fix this if not...
    01-22-10 05:15 PM
  24. SuperWario89's Avatar
    The only leak I ever had with .419 was with berryweather. When .419 runs on its own, I lose MAYBE 1 meg over a few days. With Berryweather, I use BerryJoose and it keeps it under control.

    I found today that with ubertwitter, and berryweather, my screen keep freezing going from keyboard lock, to unlock and a moderate leak.

    I think all bb's leak a bit, but its app related i think. I removed both berryweather and ubertwitter and no more freeze for a few seconds and its speedy again. Not a fan of berryweather for that only reason.

    Check your apps. even unload them one at a time, and reload one at a time and see how the leak goes.

    Make sure you arent keeping any open without knowing. Hold the menu key and see what's running. Berryweather, even when you are in it and close it properly, is still in the background...check your settings on apps to make sure they arent running in the background.
    i have berryjoose now too, and even with that my leak has reappeared, and i didn't change any apps. i'm starting to think it might be theme related. i'm going to try a hybrid this weekend and see how that works
    01-22-10 10:49 PM
  25. joshtb86's Avatar
    yeah i lost 20 mb in maybe 48 hours.
    01-23-10 04:10 PM
LINK TO POST COPIED TO CLIPBOARD