1. drskwurl's Avatar
    I was wondering if and/or when the 8330 will be getting an upgrade to OS v4.6 or v5.0? I have seen some leaked versions, but I don't know how those work. I'm new to Blackberries and I don't want to mess anything up if I do use a leaked version. My carrier is US Cellular, if that matters.

    Thanks for any help.
    12-17-09 11:32 AM
  2. kreitz3's Avatar
    It will be a while before you get an official version from US Cellular, if you ever get one.
    12-17-09 11:34 AM
  3. xtort's Avatar
    You won't be using the 8330 versions of the OS, you'll be using the 8330m versions. US Cellular and Sprint use MEID versions of the 8330 on their networks.

    As for using 5.0 on these devices, I doubt it will happen IMHO. The 8520/8530 are already out and have succeeded the older 83xx series in every way. The newer phones also have 256MB RAM which 5.0 will run much better with.
    12-17-09 11:46 AM
  4. Kepeli's Avatar
    For me, it would be nice to have a 5.0 release for my Curve, but not highly necessary. I run my business with my Curve running 4.5.0.138 and it does it's job very well. I only have 2 other apps that I have downloaded onto my Curve which is (Precision Theme, and AIM messenger). If you consider it, then yes, I am running BBM 5.0.0.55. I also do not take chances with leaked OSs. I just wait for the official ones to save myself any hassles. Other than that, I strictly use the Email technology to keep in touch with fellow partners, business clients and prospective clients, I use the scheduling technology to keep in touch with local as well as national scheduling (it took me a while to get used to the time frame difference technology, but love it now that I understand it), the Contact List allows me to keep an evolving rolodex right in my handset, the expandable MicroSD (up to 8 GB) is more than enough memory for me to store files, and multimedia I need for presentations etc., I love the Password Keeper because my business requires me to have a lot of passwords and user IDs, the Maps have helped me out when traveling and yes, the browser (albeit not the best) has saved me on several occasions from situations where I needed definitions or quick reference answers. So as far as a 5.0 release for me, although it would be great, I am content. Should a time come when my business requires me to upgrade, then I'll see what's available. Till then, I'm staying with my tried and true Curve running on Verizon's 4.5.0.138!
    12-17-09 01:45 PM
  5. docsmody's Avatar
    You won't be using the 8330 versions of the OS, you'll be using the 8330m versions. US Cellular and Sprint use MEID versions of the 8330 on their networks.

    As for using 5.0 on these devices, I doubt it will happen IMHO. The 8520/8530 are already out and have succeeded the older 83xx series in every way. The newer phones also have 256MB RAM which 5.0 will run much better with.
    You're absolutely wrong.

    Sprint uses and supports both 8330e (ESN) and 8330m (MEID) on their network.

    Further, RIM has confirmed a 5.0 OS will be released for the 8330 which has 96MB. Yes, it may not run as well as other phones but it will be supported.
    12-18-09 04:45 PM
  6. ipodtouch1234's Avatar
    You won't be using the 8330 versions of the OS, you'll be using the 8330m versions. US Cellular and Sprint use MEID versions of the 8330 on their networks.
    False, before I got my Tour, I had an 8330 with an ESN, not a MEID.
    12-18-09 08:55 PM
LINK TO POST COPIED TO CLIPBOARD