1. Mateo1041's Avatar
    I'm trying to download the App World application. First, I tried by email. The following link was sent in the email, but it's invalid and doesn't work:

    <link removed due to dumb post limit>

    Then, I tried the desktop approach. But, even though I'm using IE, the page says my browser is unsupported. :-(

    <link removed due to dumb post limit>

    Does RIM really make it this hard to buy from them? Any ideas?
    05-06-09 08:01 PM
  2. tonytizzle's Avatar
    ia m having same problem. tells me browser not supported. any help out there?
    05-06-09 08:04 PM
  3. Kellina's Avatar
    I didn't have probs downloading but it is slow as molasses and I just couldn't do it! uninstalled it about a half hour ago.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-09 08:23 PM
  4. Motorcycle Mama's Avatar
    Do you have a BlackBerry Data Plan?
    05-06-09 09:14 PM
  5. eripmu's Avatar
    Where do I go for the link. Website name?
    05-06-09 09:17 PM
  6. Motorcycle Mama's Avatar
    05-06-09 09:57 PM
  7. xliderider's Avatar
    I hated appworld, it was a huge waste of memory. You're better off downloading the applications on your own IMO.

    Check out the OTA download links thread in m.crackberry.com

    And this link as well:


    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by xliderider; 05-06-09 at 10:45 PM.
    05-06-09 10:42 PM
  8. fruitmix23's Avatar
    You need to make sure you have os 4.5 or later.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-07-09 01:42 AM
  9. zdaman101's Avatar
    I had this same problem, and after alot of different tries I finally figured out how to get it. I had to manually type in the following address into my bb browser. It wouldn't work in my opera browser fwiw. Just take the space out of the first part of the link.

    h ttp://mobileapps.blackberry.com/devicesoftware/entry.do?code=appworld
    05-14-09 03:59 PM
  10. Khalnath's Avatar
    I suspect beta OSes are disallowed. It worked fine for me under 4.6, but in 5.0 it says browser not supported.

    If you're running a beta OS, that's probably the reason.
    05-14-09 06:44 PM