1. golfboss's Avatar
    Opened orig version of WeatherEye today and got a message about upgrading to new version. Clicked on yes. Message said it successfully installed. Did the reboot. Tried to open the app and got an error message: "Uncaught exception: GUIFactory.startScreen error:WeatherEye.loadData error:Could not retrieve screen config file". Any thoughts?
    02-15-10 03:52 PM
  2. nfldberryuser's Avatar
    I got the same message and upgraded without any problems. You could try editing permissions by setting all to deny. This should require a reset. After that set all permissions to allow & see if it works then. If that doesn't work, I'd delete the app & reinstall.

    If none of that works, there's a thread on the previous Betas of WeatherEye that might be useful to you, particularly if you're on BES. Good luck.

    Posted from my BlackBerry using BerryBlab
    02-15-10 04:07 PM
  3. golfboss's Avatar
    I tried to delete and reinstall twice. Rebooted and even did a batt pull. Interestingly, it doesn't actually delete but goes to archive. When I tried to reinstall the third time it asked if I wanted to return it from archive.
    02-15-10 04:13 PM
  4. nfldberryuser's Avatar
    You must have originally downloaded it from BB App World for it to archive. When it archives, it saves the app on your memory card so you don't have to download OTA again. Leave it archived & try downloading from http://betatesting.pelmorex.com/


    Posted from my BlackBerry using BerryBlab
    02-15-10 04:44 PM
  5. golfboss's Avatar
    Thanks for your help on this. I no longer get the error message but now when I open the app I have a blue sky with light clouds and a plain blue bar in the middle of the screen. How's the weather in Newfoundland?
    02-15-10 05:00 PM
  6. nfldberryuser's Avatar
    Thanks for your help on this. I no longer get the error message but now when I open the app I have a blue sky with light clouds and a plain blue bar in the middle of the screen. How's the weather in Newfoundland?
    I wish I had been more help. I think your only option at this point is to email the developer.

    The weather in Newfoundland? Exactly what you wouldn't expect - kind of the point here. -2 temperature falling with freezing rain warnings issued. Positively balmy

    Posted from my BlackBerry using BerryBlab
    02-15-10 06:39 PM
  7. bigmac05's Avatar
    I'm having the exact same issue. Had weathereye app on my phone since Feb 09, now after the update, I get the same error. Basically, I just removed the app from my phone and emailed the developer. It sucks, I really like the app, and it was very accurate.
    02-15-10 07:09 PM
  8. nfldberryuser's Avatar
    Looks like I was lucky. I won't be so quick to update the next time.

    Posted from my BlackBerry using BerryBlab
    02-15-10 07:20 PM
  9. golfboss's Avatar
    Bigmac let me know if you hear back from the developer. I emailed them too and haven't gotten a reply yet.
    02-15-10 08:04 PM
  10. bigmac05's Avatar
    Bigmac let me know if you hear back from the developer. I emailed them too and haven't gotten a reply yet.
    Hopefully I will get a response. We will see.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-16-10 09:08 AM
  11. Q_T_PI_KM's Avatar
    Hi, I too was getting the same error. I emailed the WeatherEye support team last night and we finally resolved the issue after emailing each other back and forth all day. After deleting and rebooting numerous of times, I still ended up with the "Uncaught exception: GUIFactory.startScreen error:WeatherEye.loadData error:Could not retrieve screen config file." My fix was after I installed the upgrade once more I got the error again, I turned on my wifi and connected to my home wireless network, then tried to load the app...presto! no error anymore...it works like a charm...so maybe you should give that a try
    02-23-10 08:58 PM
  12. bigmac05's Avatar
    Do you have to be logged on wifi to use the app? Or is it just to initially set it up? If its the former that won't benefit me, as I am not always near an accessible wifi spot.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-24-10 09:15 AM
  13. lawden's Avatar
    I am not getting the error message however the icon is not displaying the current conditions. I can get short/long term forecasts, but not the current condition. Anyone else having this problem or know how to fix it??

    Posted from my CrackBerry at wapforums.crackberry.com
    02-24-10 10:43 AM
  14. rrosen's Avatar
    Same problem as others. I activated the WiFi as Q T PI KM did and now I don't get the error message, just get a blue bar across the screen. Clearly the developer broke something in the new version.
    02-24-10 06:18 PM
  15. rrosen's Avatar
    Spoke too soon. Now I'm back to getting the screen config file error.
    02-24-10 06:19 PM
  16. verado7's Avatar
    problem solved almost >>>> it seems the bb firewall doesnt like the new weathereye app - if you turn off the firewall on the bb weaher eye works perfect - you will get a couple other warnings but check appropriate boxes then it all goes away and works flawless - turn on the firewall it stops working ..im gonna keep working on it - maybe this could turn into a sticky .
    02-28-10 06:43 PM
  17. verado7's Avatar
    weather still working - the only error message i get now happens when i use the back button - ie: i pushed the back button to go back to the previous page - it gives me the connection attempt error - maybe i just need to leave the firewall off a bit longer and run thru every process - other than that its not too annoying .
    02-28-10 06:57 PM
  18. verado7's Avatar
    just got off the phone with a friend who had the same problem - working fine now -with the exception of the error when using the back button - which is minor and doesnt affect useability - they should still correct this - as it categorizes the app as unsafe - they must be collecting user data for ??? also the guys who report no problems are probably useing newer bb's as most like the bold come factory with firewall disabled now because of other app conflicts - i see alot about opera behaving the same way .
    Last edited by verado7; 02-28-10 at 07:43 PM. Reason: additional info
    02-28-10 07:40 PM
LINK TO POST COPIED TO CLIPBOARD