04-18-12 08:45 PM
125 1234 ...
tools
  1. bharuch7282's Avatar
    thanks for giving this opportunity to test this app. i downloaded the app but unfortunately doesnt work gets stuck at the main page and after closing gets this msg " Uncaught exception : pushModalScreen called by a non-event thread". thanks
    TWN likes this.
    05-06-11 10:10 AM
  2. sheldonbk's Avatar
    I've uploaded a new version (2.4.3.9) that will hopefully fix the splash screen crash.

    Betatesting Weather Eye
    Previously - Had been running beta version ok and icon stopped updating late yesterday and couldn't open at all. Deleted App. Rebooted. Reinstalled 2.4.3.9.

    Splash screen freezes after install of new version.
    "Uncaught exception: pushModalScreen called by non-event thread"

    Error Log -
    Uncaught Exception Trace - RuntimeException Severe Error
    pushModalScreen called by a non-event thread
    net_rim_cidc-15(4D8F0C0C)
    UiEngineImpl
    addScreenModal
    0x73CD
    net_rim_cidc-17(4D8F0C0C)
    Dialog
    doModal
    0x4FF2
    net_rim_cidc-17(4D8F0C0C)
    Dialog
    alert
    0x5ABA
    WeatherEye-12(4DC40274)
    WeatherEye
    main
    0x96F
    TWN likes this.
    05-06-11 10:34 AM
  3. TWN's Avatar
    Rogers BB users have experienced some issues reaching our servers since yesterday. If you're on the Rogers network, you can check your connection by opening http://weyebbsearch.pelmorex.com/ in your device browser. If you see a message "Welcome to Load Balancing Web Site", your connection is ok.

    I've also uploaded further fixes (2.4.3.10).
    05-06-11 11:27 AM
  4. sahaller's Avatar
    I just installed 2.4.3.10 (fresh). I still can't get past the splash screen.
    05-06-11 12:46 PM
  5. TWN's Avatar
    I just installed 2.4.3.10 (fresh). I still can't get past the splash screen.
    saclifford can you confirm that you can open the site http://weyebbsearch.pelmorex.com/ from your device browser?
    05-06-11 01:02 PM
  6. sahaller's Avatar
    saclifford can you confirm that you can open the site http://weyebbsearch.pelmorex.com/ from your device browser?
    I get "The requested URL could not be retrieved" Error: 10006
    TWN likes this.
    05-06-11 01:10 PM
  7. TWN's Avatar
    Thanks for the info saclifford, that helped us find the problem. We changed some server configurations yesterday, which made WeatherEye unable to look up cities/locations when connecting from several networks.

    It's fixed now, reinstalling the app will let you run it (although you can still run into other bugs).

    Once again, thank you all for your continued support, as you can see everything you post in this thread helps us create a better WeatherEye!
    05-06-11 01:43 PM
  8. sahaller's Avatar
    I just installed 2.4.3.10 (fresh). I still can't get past the splash screen.
    I reinstalled it; I still get this error.

    I still get the same error when I try to open weyebbsearch.pelmorex.com, too.

    05-06-11 02:14 PM
  9. TWN's Avatar
    I reinstalled it; I still get this error.

    I still get the same error when I try to open weyebbsearch.pelmorex.com, too.

    weyebbsearch.pelmorex.com has now been deactivated

    The new address is weyesearch.pelmorex.com

    The app downloads a settings file on startup that lets it know where to search for cities. I have changed the settings to point to weyesearch (old one was going to weyebbsearch) when I posted the last message, but maybe the file got cached somewhere on the wireless provider's server and you ended up with the old version.

    Re-installing will solve this once the cache has been updated - although I don't know how long this will take.

    EDIT: I just posted another update (2.4.3.11) that should tell you which server it was connecting to when it failed
    Last edited by TWN; 05-06-11 at 02:32 PM.
    05-06-11 02:27 PM
  10. sheldonbk's Avatar
    All I get at the latest URL (last post not the URL in the quoted post) is the "welcome to load balancing site". Then nothing.

    Rogers BB users have experienced some issues reaching our servers since yesterday. If you're on the Rogers network, you can check your connection by opening http://weyebbsearch.pelmorex.com/ in your device browser. If you see a message "Welcome to Load Balancing Web Site", your connection is ok.

    I've also uploaded further fixes (2.4.3.10).
    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-11 08:36 PM
  11. bovid's Avatar
    downloaded, installed fine here. i like the new interface, i will follow up over the next few days with findings
    05-06-11 09:13 PM
  12. joesworld's Avatar
    Seems to work good, except it doesn't seem to want to keep the auto location turned off... every time I restart the app it sets the auto location back on again. Unfortunately I had to uninstall because of this because I can't risk it draining my battery too much. Hope it's fixed soon because otherwise it's a great improvement! I love how more forecast information is displayed on each page... nice touch.
    05-07-11 07:45 AM
  13. BigBadWulf's Avatar
    Just made attempt #2 to beta test this app. The icon was on my home screen, but I couldn't get it to open. Tried a battery pull, still nothing. Checked the Event Log for errors, and found normal system logs for it, that was all.

    Just a thought. You may consider a couple private beta testers, before posting the next update.
    05-07-11 02:27 PM
  14. PavementPilot's Avatar
    Installed 2.4.3.11 and after 2 battery pulls, every time it try and use it, I can see it communicating but not opening. I am running 6.0.0.499 on a 9700
    05-09-11 12:59 AM
  15. TWN's Avatar
    All I get at the latest URL (last post not the URL in the quoted post) is the "welcome to load balancing site". Then nothing.
    That's all it does! I just wanted to make sure you can reach the server.
    05-09-11 09:52 AM
  16. TWN's Avatar
    We had another server issue since Saturday morning that is resolved now. If your WeatherEye was not starting before, it should do so now.
    05-09-11 11:36 AM
  17. TWN's Avatar
    Users confirmed that the new version 2.4.3.12 fixes the crash on startup.

    Thank you everyone for your patience, you really helped us make progress!

    Download link: Betatesting Weather Eye

    Posted from my CrackBerry at wapforums.crackberry.com
    sheldonbk likes this.
    05-09-11 07:46 PM
  18. Apocalypso's Avatar
    Reinstalled this app again after several unsuccessful attempts with the previous betas. Finally have it running again on my BB.

    I'm loving the new auto location feature. Glad to have my favourite weather app back.

    Good job guys!

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Apocalypso; 05-10-11 at 08:36 AM.
    05-10-11 08:18 AM
  19. sahaller's Avatar
    I am successfully running 2.4.3.12. YAY!!

    I can't seem to turn off the auto location feature, though. Any one else have that problem?
    05-10-11 09:13 AM
  20. Apocalypso's Avatar
    I am successfully running 2.4.3.12. YAY!!

    I can't seem to turn off the auto location feature, though. Any one else have that problem?
    Hmm...simply unchecking that feature should be all there is to it. Once you've opened the app, click the blackberry button. You'll then see the auto locate feature checked. Uncheck it and hit the backspace button to close the app. Done.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-10-11 09:18 AM
  21. sahaller's Avatar
    @Apocalypso The check box doesn't clear. I don't have any problems with the Show on Homescreen check box.
    05-10-11 09:21 AM
  22. jwhelan's Avatar
    I just installed this on my Torch and I find the previous version (2.1.0.1) was much easier to navigate and visually more appealing.

    I prefer to have buttons to touch to switch between Current/Hourly/Short Term etc. I am not a big fan of having to hit the menu button to switch views.

    I will continue to monitor for updates and look forward to new versions.
    05-10-11 12:44 PM
  23. jwhelan's Avatar
    A couple more issues:
    1. When I uncheck "Auto-Locate" and Exit the app, it is checked again when I open it.

    2. It seems this version of WeatherEye continues to show in the list of running applications when you press the back button to go back to home screen. You have to select "Exit" from the menu to close it out. And then it takes a lot longer to start up.
    05-10-11 12:50 PM
  24. TWN's Avatar
    A couple more issues:
    1. When I uncheck "Auto-Locate" and Exit the app, it is checked again when I open it.

    2. It seems this version of WeatherEye continues to show in the list of running applications when you press the back button to go back to home screen. You have to select "Exit" from the menu to close it out. And then it takes a lot longer to start up.
    1. If your only city is [Current location], every time you open the app it has to turn on auto-locate to check what exactly the current location is. It is possible to use this version just like the old one: add a city from the menu, check "Show on homescreen icon", and turn off Auto-location.

    2. Yes - the WeatherEye is sleeping in the background by default. We've taken precautions to minimize battery usage, so the WeatherEye will not use any power unless your homescreen icon is scheduled to update. We're working closely with RIM to make this a super app, and preserving the battery is one of our priorities.
    Last edited by TWN; 05-11-11 at 11:23 AM.
    05-11-11 11:15 AM
  25. sahaller's Avatar
    1. If your only city is [Current location], every time you open the app it has to turn on auto-locate to check what exactly the current location is. It is possible to use this version just like the old one: add a city from the menu, check "Show on homescreen icon", and turn off Auto-location.

    2. Yes - the WeatherEye is sleeping in the background by default. We've taken precautions to minimize battery usage, so the WeatherEye will not use any power unless your homescreen icon is scheduled to update. We're working closely with RIM to make this a super app, and preserving the battery is one of our priorities.
    I have Pittsburgh, PA added as a city, but I still can't turn off auto-locate.

    Also, I just noticed that the app doesn't automatically start after a device reboot. That's probably not a deal breaker for me, but it is annoying.
    05-11-11 12:52 PM
125 1234 ...
LINK TO POST COPIED TO CLIPBOARD