1. E92Vancouver's Avatar
    I haven't been able to login to App World the last 2 days. Username and password are correct. I can login to App World on a PC but not from my Blackberry.

    Uggh!!!! Why does this all of sudden act up like this? Why does this have to be so difficult.

    My carrier tells me this a blackberry problem. Blackberry tells me they want $50 to listen to my problem. Great customer service.

    I don't want to have to wipe my phone so don't suggest this.

    I have deleted App World on the Berry and reinstalled. No luck.

    I would rather suffer through a Berry that can't be updated than wipe the device and start again.
    02-05-12 04:55 PM
  2. jafobabe's Avatar
    From what other posters have stated, when they called Support, the servers were down that effected App World.

    So no need to wipe your device. And the servers should be up soon.
    E92Vancouver likes this.
    02-05-12 11:40 PM
  3. Morty2264's Avatar
    I have the exact same problem as you. App World refuses my username and password (both correct); and when I try to reset my password on my laptop it says "your email address is not recognized"; which makes no sense, because it WAS recognized weeks ago. I don't know if this is a problem with BlackBerrys in general or the server; because my other friends with Bolds and with Rogers have no login problems but I do. I tried tweeting BlackBerry Help on Twitter and their suggestions were to reset my password (which didn't work). I would suggest you try tweeting them as well - maybe they will offer something different for you or look into the issue more seriously. Have you tried making an entirely new account (new password, same email)? I want to try doing that but I don't know what it will do to my device.
    02-07-12 12:29 PM
  4. E92Vancouver's Avatar
    I have the exact same problem as you. App World refuses my username and password (both correct); and when I try to reset my password on my laptop it says "your email address is not recognized"; which makes no sense, because it WAS recognized weeks ago. I don't know if this is a problem with BlackBerrys in general or the server; because my other friends with Bolds and with Rogers have no login problems but I do. I tried tweeting BlackBerry Help on Twitter and their suggestions were to reset my password (which didn't work). I would suggest you try tweeting them as well - maybe they will offer something different for you or look into the issue more seriously. Have you tried making an entirely new account (new password, same email)? I want to try doing that but I don't know what it will do to my device.
    Yes, I made a new account but that did not work. When I tried to login from the Berry, I got a message saying "Login with the account registered to this device".

    This happened to me before and the only way I fixed it was to wipe my phone. Of course this is a big waste of time because not all your apps or settings are restored from the backup.

    I will suffer through this, hoping I can get back online. If not, I will chuck this phone and be done with blackberry.

    My friend's blackberry did this when it was new and out of the box. I had to wipe the phone. Since it was new and not setup, wiping was an option.

    This is frustrating because there are always new updates to install. If you do a battery pull because your blackberry has frozen, you have to login into App World again. Often you get these login issues after a battery pull.
    Last edited by E92Vancouver; 02-07-12 at 12:52 PM.
    02-07-12 12:49 PM
  5. Morty2264's Avatar
    Yes, I made a new account but that did not work. When I tried to login from the Berry, I got a message saying "Login with the account registered to this device".

    This happened to me before and the only way I fixed it was to wipe my phone. Of course this is a big waste of time because not all your apps or settings are restored from the backup.

    I will suffer through this, hoping I can get back online. If not, I will chuck this phone and be done with blackberry.

    My friend's blackberry did this when it was new and out of the box. I had to wipe the phone. Since it was new and not setup, wiping was an option.

    This is frustrating because there are always new updates to install. If you do a battery pull because your blackberry has frozen, you have to login into App World again. Often you get these login issues after a battery pull.

    Thanks for your reply! This sounds pretty bleak... I re-tweeted BlackBerry Help and will let you know what they say. Have you tried resetting your password online? Try going to https://blackberryid.blackberry.com/...coverpassword/ . It did not work for me; but it might work for you! I might also suffer through this, as well; as I do not want to wipe my phone. And yeah, there are always updates to Facebook and BBM and that will be an issue. I can't believe that happened to your friend when the phone was right out of the box! You almost want to throw it back in the box and demand a new one...
    Anyway, I hope this gets fixed!
    02-07-12 01:18 PM
  6. DannyAves's Avatar
    Thanks for your reply! This sounds pretty bleak... I re-tweeted BlackBerry Help and will let you know what they say. Have you tried resetting your password online? Try going to https://blackberryid.blackberry.com/...coverpassword/ . It did not work for me; but it might work for you! I might also suffer through this, as well; as I do not want to wipe my phone. And yeah, there are always updates to Facebook and BBM and that will be an issue. I can't believe that happened to your friend when the phone was right out of the box! You almost want to throw it back in the box and demand a new one...
    Anyway, I hope this gets fixed!
    I don't know if this will help but I had that problem when I upgraded to 7.1 yesterday so I just entered my email address and clicked 'forgot password' - as soon as they sent the email to me it started to work again.
    02-07-12 01:49 PM
  7. Morty2264's Avatar
    I don't know if this will help but I had that problem when I upgraded to 7.1 yesterday so I just entered my email address and clicked 'forgot password' - as soon as they sent the email to me it started to work again.
    I just tried that; and an error message came up, saying something like, "Please ensure you have an activated ID and are connected to the server." or something like that. It won't take my email address. Thank you for your help, though!
    02-07-12 02:03 PM
  8. i_hiker's Avatar
    I had a similar issue a while back and I simply deleted the app and reloaded it. No problem.
    02-07-12 02:23 PM
  9. E92Vancouver's Avatar
    Changed the password. Still locked out.
    02-08-12 02:39 AM
  10. E92Vancouver's Avatar
    Just clicked forgot password on my device. It took me to the change password screen. Changed the password again but this time using the device. Still locked out.

    I think RIM locked me out because I have been vocal about how poorly they compare to the competition.
    02-08-12 02:42 AM
  11. E92Vancouver's Avatar
    Really, it is Blackberry ID that I can't sign into.
    02-08-12 03:03 AM
  12. E92Vancouver's Avatar
    02-08-12 03:05 AM
  13. E92Vancouver's Avatar
    Okay. Got it fixed finally. Plugged it into my PC. Connected to Desktop Manager. It did a bunch of updates and now it works.
    02-08-12 04:26 AM
  14. Nokuthula Ntiwane's Avatar
    I dnt see my app world now I hav 3mnths I dnt hav it
    06-17-13 02:49 PM
LINK TO POST COPIED TO CLIPBOARD