04-11-12 10:54 AM
546 12345 ...
tools
  1. Spiral_ouT's Avatar
    Pkcable spoke about this yesterberry in another topic.... really starting to get my interest.... The ONLY thing Im missing or if theres an app out there for espn, sports center, or even being able to get nfl games on radio through the bb that would be AWESOME!!!
    Sprint loss the contract to the NFL to Verizon.... so as a result sprints alternative is some horrible nfl live app that mimics espn's online service.. no offense to espn..

    Is there a tv app that would do this?

    My other option would be slingbox.....

    Thanks


    "NY Giants stand tall- Patriots understand your legacy is finished. There is always that 18-1"
    If you have DirecTV, you can get NFL Sunday Ticket and then NFL Sunday Ticket To-Go to watch all NFL games. Has the RedZone channel and everything else you would regularly get with NFL Sunday Ticket. That is what I did this year.

    Back to Yesterberry.. I wish there were channel titles in text underneath the channel so I could access it from Opera. Forced to use the native browser so I can read the titles in the "mouse over"
    09-07-10 03:09 PM
  2. ratfinkstooley's Avatar
    If you like sports don't be so quick to dismiss this. The Chinese LOVE the NBA, plus they have a pro baseball league too. And if you like soccer at all you'll find loads of that. I was able to watch 2 Euro Cup games this weekend. There are also a few Slovak stations which I THINK show hockey in season.
    hmm, good call. I might as well give it a shot. What have I to lose?
    09-07-10 03:21 PM
  3. CharredPC's Avatar
    Really busy today doing real-life stuff, but snuck away to toss up nine more TV channels

    Back to Yesterberry.. I wish there were channel titles in text underneath the channel so I could access it from Opera. Forced to use the native browser so I can read the titles in the "mouse over"
    I had stopped testing the site under Opera Mini because the VOD section used to be 100% incompatible with it. With the recent changes, it might just work... I'll get working on full Opera compatibility ASAP.
    09-07-10 03:59 PM
  4. Spiral_ouT's Avatar
    Really busy today doing real-life stuff, but snuck away to toss up nine more TV channels



    I had stopped testing the site under Opera Mini because the VOD section used to be 100% incompatible with it. With the recent changes, it might just work... I'll get working on full Opera compatibility ASAP.
    Awesome! Thanks for taking the time to add a few more channels. Looking forward to the Opera compatible version
    09-07-10 07:10 PM
  5. CharredPC's Avatar
    Okay, guys, time to help yourselves by helping me out

    I've added three more live tv channels you may like on the last page. I don't have a name for two of them, so... think you can check them out, try and figure out what they are? I like having proper icons and titles. Also, let me know if you think they're worthy of being moved closer to the beginning of the selection. Thanks a bunch!
    09-07-10 11:18 PM
  6. pkcable's Avatar
    Okay, guys, time to help yourselves by helping me out

    I've added three more live tv channels you may like on the last page. I don't have a name for two of them, so... think you can check them out, try and figure out what they are? I like having proper icons and titles. Also, let me know if you think they're worthy of being moved closer to the beginning of the selection. Thanks a bunch!
    SiTV looks really badass! I will try to take a good look at the other 2 tomorrow and try to help figure them out. But SiTV is gonna be a fav for me I can tell
    09-07-10 11:38 PM
  7. CharredPC's Avatar
    SiTV looks really badass! I will try to take a good look at the other 2 tomorrow and try to help figure them out. But SiTV is gonna be a fav for me I can tell
    Thought someone would like that

    Decided to do things all official... Yesterberry is now on Twitter. Check there for site updates, announcements, etc.
    09-08-10 12:10 AM
  8. JasW's Avatar
    Charred, kudos to you for such awesome work! One issue on the Torch, though -- the mouse-over titles don't show up in the OS 6 WebKit browser. For some reason, they pop up under the icon, and have no lettering in any event.
    09-08-10 08:50 AM
  9. Glenn J's Avatar
    I've run into that connection error while on wifi. From my experience, it's a RIM/Wifi thing; switching the browser mode to "Hotspot" usually clears it up for me. I can tell you that it's not a problem with the feeds

    Another common glitch (especially while jumping from channel to channel quickly) is that it will hang on the data transfer arrows and not start buffering the channel. Hitting back, waiting a few seconds, then trying again always solves it for me here. It's unfortunately a problem in how the BlackBerry software handles things.

    Yes, all the channels are live simulcasts, just in a format that's compatible to our phones. In today's day and age, I think internet-based mobile tv should be free just as basic antenna broadcasts are free. Not that many broadcast corporations agree with me!

    I'm open to suggestions on how to categorize things. Some channels are hard to classify

    Posted from my CrackBerry at wapforums.crackberry.com
    I bet that's my problem; I was going between channels very quickly...that probably caused the lag.

    I hear you on the free broadcasts. That would be cool if channels, even if it was just local affiliates, had the shows over the internet.

    Good point...some of the channels are hard to classifiy.

    Oh, another thing I like: The "app" is pretty smalle. Since you set everything up on the web, it takes up very little space on the BB.

    Thanks again for putting this together; great work.
    09-08-10 09:38 AM
  10. Jeffy294's Avatar
    CharredPC.....love your site, have not got the app yet. I just wondered if you knew the Travel Channel is not working, it shows the Travel Channel Icon but its some Chinese channel. Figured I would let you know, keep up the good work.
    09-08-10 09:57 AM
  11. BiG BaLLA 923's Avatar
    This is amazing!! You're a champ!!
    09-08-10 10:01 AM
  12. CharredPC's Avatar
    Charred, kudos to you for such awesome work! One issue on the Torch, though -- the mouse-over titles don't show up in the OS 6 WebKit browser. For some reason, they pop up under the icon, and have no lettering in any event.
    There's a good reason for RIM to get us OS6 for the 9700! How else am I supposed to test things in webkit?

    Between Opera Mini and the new webkit browser, it sounds like a lot of users don't have labeled channels. I'll make this a high priority, and work on it immediately.


    CharredPC.....love your site, have not got the app yet. I just wondered if you knew the Travel Channel is not working, it shows the Travel Channel Icon but its some Chinese channel. Figured I would let you know, keep up the good work.
    Confusingly enough, the icon is wrong, but the channel is right. As best I could translate from Chinese, the correct name is "Travel Channel." I noticed last night that a few channels are having problems, so I'm going through the entire (240+ !) collection today doing maintenance; I'll add changing that icon to my to-do list.
    09-08-10 10:48 AM
  13. JasW's Avatar
    There's a good reason for RIM to get us OS6 for the 9700! How else am I supposed to test things in webkit?

    Between Opera Mini and the new webkit browser, it sounds like a lot of users don't have labeled channels. I'll make this a high priority, and work on it immediately.
    Frankly, I'm surprised even an empty tooltip came up. I know there is some problem with WebKit and image title tooltips but it's beyond me what the solution is.
    09-08-10 12:56 PM
  14. pkcable's Avatar
    Ok I BELIEVE the last channel, one of the new ones is called Títulos, and it is a news station from Puerto Rico, or somewhere else nearby, they are in the Atlantic time zone 1 hour later than US East, and they speak Spanish.
    09-08-10 01:06 PM
  15. CharredPC's Avatar
    Frankly, I'm surprised even an empty tooltip came up. I know there is some problem with WebKit and image title tooltips but it's beyond me what the solution is.
    If you get a chance, could you refresh the main live TV page and try hovering over one of the icons in the top row? I don't expect such an easy fix to work, but...

    The Opera Mini issue is tougher. It purposely breaks most normal HTML rules; even the simple CSS hover menus don't function in it. The only fixes I can think of offhand are the ones I outlined a page or two back. I did find and fix a coding glitch that made visited links in OM hard to read


    Ok I BELIEVE the last channel, one of the new ones is called Títulos, and it is a news station from Puerto Rico, or somewhere else nearby, they are in the Atlantic time zone 1 hour later than US East, and they speak Spanish.
    Sounds good, I'll label it as such. Thanks so much!
    09-08-10 01:20 PM
  16. Jude526's Avatar
    so nice of you thank you ! awesome
    09-08-10 06:02 PM
  17. CharredPC's Avatar
    so nice of you thank you ! awesome
    Your welcome!

    Quick site update: The 150 live tv channels have been sorted by language; the same sort of thing will happen to the 83 live radio channels, and eventually the VOD section. I'll try and add more of everything soon. Let me know if there's any issues.
    Last edited by CharredPC; 09-09-10 at 03:19 AM. Reason: It's 2:19am. Who doesn't make mistakes at 2:19am?
    09-09-10 03:14 AM
  18. pkcable's Avatar
    Looks good bro!
    09-09-10 09:18 AM
  19. John Yester's Avatar
    I should get partial stock share!! lol

    Keep up that great work.
    09-09-10 09:23 AM
  20. pezboy's Avatar
    Unfortunately RIM decided to make random models (such as your 9630) not support HTTP streaming. I doubt we'll ever know why, since even the 8900's do. In the meantime, you should be able to download the VOD material and watch it straight from your phone afterward. I know that's not a perfect option, but we can thank RIM for it
    First off, thanks for the hard work on such a great FREE app!!

    Is the Storm 2 9550 one of the random models that doesn't support HTTP streaming? I can get the VOD section to play, but none of the user submitted content plays. I just get an error that says "

    In addition, whenever I try to watch CNN, BBC world, BBC News (and probably others) it goes to a black screen for a minute or so and then gives an error that says "An error has occurred attempting to play media." I can, however, watch WCTV news, Sesame Street, CBN news, (and probably others).

    I am using the 9550 on wifi. My OS is 5.0.0.886 (a hybrid by Lyricidal). I am wondering if this is something that may be tweaked in my browser settings, a known issue with the 9550, or possibly a glitch with my hybrid.
    09-09-10 09:30 AM
  21. CharredPC's Avatar
    First off, thanks for the hard work on such a great FREE app!!
    Is the Storm 2 9550 one of the random models that doesn't support HTTP streaming? I can get the VOD section to play, but none of the user submitted content plays. I just get an error that says "
    I believe that is one of the non-HTTP streaming models. I've been debating taking down the user-submitted VOD content anyway, since they aren't nearly as reliable (or compatible) as the rest of the website. Unless someone complains about the idea, I'll likely remove it when I overhaul the VOD section.

    In addition, whenever I try to watch CNN, BBC world, BBC News (and probably others) it goes to a black screen for a minute or so and then gives an error that says "An error has occurred attempting to play media." I can, however, watch WCTV news, Sesame Street, CBN news, (and probably others).

    I am using the 9550 on wifi. My OS is 5.0.0.886 (a hybrid by Lyricidal). I am wondering if this is something that may be tweaked in my browser settings, a known issue with the 9550, or possibly a glitch with my hybrid.
    I just tested those channels, and they work fine on my 9700. A couple troubleshooting steps you can try:

    1. If you're using wifi, try switching your browser to Hotspot mode (in your browser, Options -> General Properties -> Default Browser -> Hotspot Browser; also Options -> Browser Configuration -> Browser -> Hotspot Browser; save, restart browser). Sometimes RIM severs have interesting quirks running through wifi routers.... here, often not all icons load, and clicking refresh does nothing because RIM has incorrectly cached the page Clearing the local cache doesn't help, so I usually have to switch to Hotspot or Web2Go, then refresh.

    2. Changing channels quickly can cause problems. This is unfortunately a RIM software glitch, so not something I can fix. Symptoms are usually either getting stuck on the "Loading..." green label, or stuck at the data transfer arrows, either way never reaching the "Buffering..." step. If this happens, users often assume that the channel is having problems, when all we need is some patience. When it occurs here, I go back to the website, wait 5-10 seconds, then click again.

    3. Another issue I've run into once or twice (also a RIM bug) is that after failing to play a stream, something gets 'stuck' and several thereafter won't play as well. It hasn't happened often enough to develop a solution, though once a channel does play, the rest work fine again. Keep in mind, our BlackBerry devices are awesome things, but their multimedia capabilities are more of an aside than a strength.

    Another troubleshooting tip you can try is to disconnect from Wifi entirely and try loading the problem channels over your cell network. Even if (like here) it isn't fast enough and buffers a lot, if the channels work, it helps figure out what's causing the problem

    Lastly, occasionally some of these live feeds have temporary problems, like any other service. Last week, one of the channels went down for 24 hours. I welcome reports on that, but as fair warning I usually don't remove channels immediately. Often it's quickly resolved without my doing anything. If a channel does develop a continuous issue, I do remove / replace it. Bottom line- don't panic!

    Let me know if any of these suggestions work out for you (or not), and thanks for checking out Yesterberry!
    09-09-10 10:25 AM
  22. pezboy's Avatar
    Thanks for the thorough response Charred!

    I believe that is one of the non-HTTP streaming models. I've been debating taking down the user-submitted VOD content anyway, since they aren't nearly as reliable (or compatible) as the rest of the website. Unless someone complains about the idea, I'll likely remove it when I overhaul the VOD section.
    Figures. the Storm2 had the potential to be the best multimedia experience on a BB with its big screen and they don't allow HTTP streaming on it. Why am I not surprised??

    I just tested those channels, and they work fine on my 9700. A couple troubleshooting steps you can try:

    1. If you're using wifi, try switching your browser to Hotspot mode (in your browser, Options -> General Properties -> Default Browser -> Hotspot Browser; also Options -> Browser Configuration -> Browser -> Hotspot Browser; save, restart browser). Sometimes RIM severs have interesting quirks running through wifi routers.... here, often not all icons load, and clicking refresh does nothing because RIM has incorrectly cached the page Clearing the local cache doesn't help, so I usually have to switch to Hotspot or Web2Go, then refresh.
    I tried this prior to posting the first time with no success.

    2. Changing channels quickly can cause problems. This is unfortunately a RIM software glitch, so not something I can fix. Symptoms are usually either getting stuck on the "Loading..." green label, or stuck at the data transfer arrows, either way never reaching the "Buffering..." step. If this happens, users often assume that the channel is having problems, when all we need is some patience. When it occurs here, I go back to the website, wait 5-10 seconds, then click again.
    I had read this in one of the posts in this thread and tried it, but no luck. I get through the "Loading..." green label, and see the data transfer arrows, but then the screen just goes black and after a minute or so, I get the error "An error has occurred attempting to play media." Going back and waiting and trying again got same results.

    3. Another issue I've run into once or twice (also a RIM bug) is that after failing to play a stream, something gets 'stuck' and several thereafter won't play as well. It hasn't happened often enough to develop a solution, though once a channel does play, the rest work fine again. Keep in mind, our BlackBerry devices are awesome things, but their multimedia capabilities are more of an aside than a strength.
    Going to a channel that does play, then going back to CNN does not fix it for me.

    Another troubleshooting tip you can try is to disconnect from Wifi entirely and try loading the problem channels over your cell network. Even if (like here) it isn't fast enough and buffers a lot, if the channels work, it helps figure out what's causing the problem
    The results of this suggestion were interesting. Instead of the previously quoted error when launching CNN, I get an error that says "Error Playing" in red up where the green loading box was and a popup that says "Content not available. Server is blocked or unresponsive." I got that error several times. BBC World News just still showed the "An error has occurred attempting to play media." error. Going back to CNN about 5 minutes later, and I am getting the same error as BBC World again.

    Lastly, occasionally some of these live feeds have temporary problems, like any other service. Last week, one of the channels went down for 24 hours. I welcome reports on that, but as fair warning I usually don't remove channels immediately. Often it's quickly resolved without my doing anything. If a channel does develop a continuous issue, I do remove / replace it. Bottom line- don't panic!
    I suspected this when I installed Yesterberry a couple of days ago and was getting these errors (on a different WiFi connection BTW). That's why I waited to post. Now that you confirmed they are working, I don't think that's the issue.


    Let me know if any of these suggestions work out for you (or not), and thanks for checking out Yesterberry!
    I also just noticed that BBC news actually streams fine. It's BBC News HD that gives the error.
    09-09-10 11:02 AM
  23. lakersfan562's Avatar
    This is sweet any chance of getting an NBC feed for the
    Vikings/Saints game 2nite? :O

    Posted from my CrackBerry at wapforums.crackberry.com
    09-09-10 12:27 PM
  24. CharredPC's Avatar
    I also just noticed that BBC news actually streams fine. It's BBC News HD that gives the error.
    Looks like the HQ version is having a glitch here too, so that part is explained at least!

    Sorry it's so frustrating. Trust me, it is here too. RIM has refuses to accept even the most common (mms://) form of streaming transport, even though the Windows Media codecs themselves are supported just fine. It's ridiculous that we can save a WMV stream and have it play on our phones fine, but they didn't bother to include live capability. I'm sitting on at least seven more UK channels (UK Entertainment, Four, etc) and countless good American ones (HBO, etc) which we can't use, just due to this reason... but back on topic, here's what I could figure out:

    First off, CNN International plays just fine here on my 9700 on both wifi and EDGE, first try

    CNN's streaming specs are: h264 video @ 432x320, with mp4a audio. You mentioned a few other channels which work for you- their specs are: mp4v video @ 320x288, with mp4a audio. This seems to explain the difference in what works for you and what doesn't, though according to RIM's documents, neither stream should present a problem on either of our phones. I especially don't see anything that would make mine work and keep yours from working, unless that hybrid has swapped out a different model's media player which doesn't support everything your original did.

    So it looks like it's device-specific, the question is whether it's specific to your device, or all Storm 2's. If anyone out there is running a 9550 on the stock OS, please chime in and let us know if CNN works for you!


    This is sweet any chance of getting an NBC feed for the
    Vikings/Saints game 2nite? :O

    Posted from my CrackBerry at wapforums.crackberry.com
    If you submit one, I'll happily post it up
    09-09-10 03:25 PM
  25. wowser's Avatar
    Looks like the HQ version is having a glitch here too, so that part is explained at least!

    Sorry it's so frustrating. Trust me, it is here too. RIM has refuses to accept even the most common (mms://) form of streaming transport, even though the Windows Media codecs themselves are supported just fine. It's ridiculous that we can save a WMV stream and have it play on our phones fine, but they didn't bother to include live capability. I'm sitting on at least seven more UK channels (UK Entertainment, Four, etc) and countless good American ones (HBO, etc) which we can't use, just due to this reason... but back on topic, here's what I could figure out:

    First off, CNN International plays just fine here on my 9700 on both wifi and EDGE, first try

    CNN's streaming specs are: h264 video @ 432x320, with mp4a audio. You mentioned a few other channels which work for you- their specs are: mp4v video @ 320x288, with mp4a audio. This seems to explain the difference in what works for you and what doesn't, though according to RIM's documents, neither stream should present a problem on either of our phones. I especially don't see anything that would make mine work and keep yours from working, unless that hybrid has swapped out a different model's media player which doesn't support everything your original did.

    So it looks like it's device-specific, the question is whether it's specific to your device, or all Storm 2's. If anyone out there is running a 9550 on the stock OS, please chime in and let us know if CNN works for you!




    If you submit one, I'll happily post it up
    I have the same issue with CNN on a Tour 9630 running the stock OS (5.0.0.732).

    Thanks!
    09-09-10 03:41 PM
546 12345 ...
LINK TO POST COPIED TO CLIPBOARD