04-11-12 10:54 AM
546 ... 89101112 ...
tools
  1. Fruitini's Avatar
    .
    Thanks for the feedback. This would be an encoder issue on my end- it's more noticeable on some phones than others. (Warning, technical jargon ahead!) It's due to a transcoding glitch where the bitrate isn't properly resampled, so you end up with 48000Khz audio squeezed into too small of bandwidth. That creates a hissy / distorted / underwater sound, especially for things other than voice, like laugh tracks. I might be able to fix this. I'll dedicate today to working on it and keep you posted here.
    Thanks very much. You're a star :-)
    10-05-10 01:18 PM
  2. CharredPC's Avatar
    I've reworked our server-routed channels. Here's what we have so far:

    1. Audio should no longer sound so "underwater-ish"
    2. Channels start much faster (less sitting on the Buffering screen)
    3. Less ugly blocks of color that take a while to go away

    The audio tweak decreased video quality slightly, since I don't want to raise the bandwidth. I'm working on some other tweaks to get them looking better while still retaining the plus points above. I'll keep everyone posted... thanks for your patience as the streams bumped up and down today during the updates.
    10-05-10 03:14 PM
  3. Fruitini's Avatar
    Thanks very much Charred. Off to check it out now
    10-05-10 04:31 PM
  4. Evermore707's Avatar
    Keep it small, and work your way up. Ignore all the " gimme gimmes".. Your onto a really cool thing here!
    10-06-10 12:04 AM
  5. CharredPC's Avatar
    Just a heads-up: there's a problem with the stream server hosting. We're running at half capacity. I've contacted the provider and they are looking into it. Hopefully it will be resolved soon... they tell me they should know something and contact me within a few hours.
    10-06-10 02:17 PM
  6. pkcable's Avatar
    Could just be a bad internet day because of the start of the MLB playoffs. Or maybe we are getting throttled because we went over our bandwidth?
    10-06-10 03:17 PM
  7. CharredPC's Avatar
    Could just be a bad internet day because of the start of the MLB playoffs. Or maybe we are getting throttled because we went over our bandwidth?
    I've heard back from them. We have unlimited bandwidth, but our service is through a VPS (Virtual Private Server). That means it was cheap because we're sharing one machine with other people. Our bandwidth and cpu cycles were getting eaten up by other users- which arguably shouldn't happen, actually, but that's another story. The company told me that even though it costs three times more, we should be running a Dedicated Server (only us on the machine), otherwise we can expect the resources to continue to shrink.

    I'm trying to get them to credit our newly-rented VPS accounts toward the cost of a dedicated server... haven't heard back yet. I'll continue to keep everyone posted. In the middle of this, I've also been running some stream tests, trying to improve quality. Now I just hope that it's not a wasted effort. So very frustrating.
    10-06-10 04:08 PM
  8. David282010's Avatar
    I like yesterberry

    Posted from my CrackBerry at wapforums.crackberry.com
    10-06-10 05:36 PM
  9. triniexr's Avatar
    Sorry for the newbie question but im new to blackberries. How do you install this?
    10-07-10 08:09 AM
  10. pkcable's Avatar
    Sorry for the newbie question but im new to blackberries. How do you install this?
    Yesterberry is a web site, it works through the BlackBerry browser, you can save the URL (web address) as a favorite, on your native browser as a bookmark, OR you can download the Yesterberry launcher, which is listed in the first post, BUT I will post here for your convience.....

    http://www.yesterberry.com/YesterberryLauncher.jad



    Here is the URL.....

    YesterBerry News and Updates




    PS: Charred, check the donations bin, there's another present in there! Folks give this guy donations we need to support his efforts!
    10-07-10 08:17 AM
  11. CharredPC's Avatar
    Thank you for your continued and mucho-appreciated support, pkcable! The hosting service is giving me the departmental runaround, but when they finally straighten things out, that gift will be very helpful in landing us the New Improved stream server

    In other happy news- Yesterberry has officially hit 100 live English channels! And of course that will bump a bit higher after we're back to full server capacity. The foreign submissions are starting to pile up too, but I've had too much on my plate to sort through, test, and label them all. Perhaps tomorrow I can get another page of those up.

    The ads are slightly discouraging (less than 20 cents per day the past few days). I keep telling myself that as Yesterberry gains popularity, that number will grow...

    PS. Crippled as our stream servers are at the moment, I also got a recent favorite channel back up. Enjoy!
    Last edited by CharredPC; 10-07-10 at 09:03 PM.
    10-07-10 08:52 PM
  12. pkcable's Avatar
    Folks,

    Another thing you can do to help is to click on the ad links every so often. I believe that is how Charred gets paid, the more clicks the more money he gets. You don't need to stay on the other site, just click on the banner then come right back. Do it several times each time you have a viewing session on Yesterberry.

    And of course feel free to make a donation. Again you need to visit the yesterberry page from a PC to donate or just use you paypal account and send a gift to support(at)yesterberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 12:46 AM
  13. SCrid2000's Avatar
    So the main page had a little glitch in it today. Basically a bunch if text was garbled together.
    I tried to put a pic in, but photobucket was being picky.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 02:10 AM
  14. CharredPC's Avatar
    So the main page had a little glitch in it today. Basically a bunch if text was garbled together.
    I tried to put a pic in, but photobucket was being picky.

    Posted from my CrackBerry at wapforums.crackberry.com
    Let me know if it occurs again. If it was a momentary thing that no longer happens, it could very well be that you loaded it right as I was changing the code. I did do some updates tonight, including finally fixing the ad / forward and previous arrow alignment, reworking and simplifying the News page, moving a few non-English channels over to the Sports section, and tweaking some possible layout issues.
    10-08-10 02:24 AM
  15. SCrid2000's Avatar
    I think that what's happening is nothing is scrolling on my 9650 running os6, so stuff gets pushed together; ads get mixed with text, and the navigation buttons hide behind the channel links. Also, some of the channel labels (which are great btw) extend below the edges of the page (again, I think because of the set screen size).
    Thanks again for all your work man

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 02:31 AM
  16. CharredPC's Avatar
    I think that what's happening is nothing is scrolling on my 9650 running os6, so stuff gets pushed together; ads get mixed with text, and the navigation buttons hide behind the channel links. Also, some of the channel labels (which are great btw) extend below the edges of the page (again, I think because of the set screen size).
    Thanks again for all your work man

    Posted from my CrackBerry at wapforums.crackberry.com
    That's odd. I'll take a look at it tomorrow, though it's always fun trying to troubleshoot without having the actual device here! The width is set to avoid runaway annoying side-scrolling or unnecessary scaling, but the height isn't; things should be free to scroll vertically as needed. I'm not sure why it would think it has to overlap anything. If you can manage to get a screenshot of it doing that, feel free to skip image hosting altogether and just email it to me at support@yesterberry.com. Evil OS6 webcr@p browser... we'll get it sussed out anyway
    10-08-10 02:42 AM
  17. SCrid2000's Avatar
    Excellent news I got on to get some screenshots, and everything is working again

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 10:02 AM
  18. CharredPC's Avatar
    Excellent news I got on to get some screenshots, and everything is working again

    Posted from my CrackBerry at wapforums.crackberry.com
    Awesome! Let me know if there's any further problems with the OS6 display. I found and fixed a potential issue that could have caused the described overlapping; I also tweaked the channel label code, so there should be less cut-off problems. Thanks for the quick feedback- never be afraid to shout at me if something breaks / doesn't look right, that's how things get fixed
    10-08-10 10:06 AM
  19. SCrid2000's Avatar
    Don't worry, I won't be glad to know you fixed something before it got better, mracle fixes make me nervous; like when my suzuki ran perfectly for the first time in thousands of miles for no reason, 10 minutes before the transmission exploded :O lol.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-08-10 10:09 AM
  20. CharredPC's Avatar
    A quick heads-up before anyone panics: I'm reworking the OS6 channel label system to fix the 'clipping' visibility issues. The new code will slowly go sitewide, hopefully finished by tonight. The first English TV page is already finished, so you can check that out and let me know if there's problems.

    The new code also finally has a proper database-style format, so that the previously mentioned spiffy customization / sorting / search features can be implemented. See? There is a method to my madness!
    10-08-10 02:24 PM
  21. aNYthing24's Avatar
    Does anyone else have problems trying to watch HBO and Disney? I always get an error message.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-09-10 08:12 AM
  22. CharredPC's Avatar
    Does anyone else have problems trying to watch HBO and Disney? I always get an error message.

    Posted from my CrackBerry at wapforums.crackberry.com
    Those two channels are currently down (happened overnight). I'll look into it and replace them as needed. Thanks for reporting it.

    In site news, I got the English and Misc language sections finished. They should be 100% compatible with both OS5 and OS6 now. Let me know if there's any layout / channel label / whatever issues. Today I'll get to the Live Radio section, and try to start work on the search features.
    Last edited by CharredPC; 10-09-10 at 11:41 AM.
    10-09-10 11:36 AM
  23. AJ_Franklin's Avatar
    Thank you for this sweet little product, CharredPC! I love it and some of those movies take me back to my childhood in the 50's. Just beautiful
    10-09-10 01:46 PM
  24. Harpy's Avatar
    It is looking good on os6!
    10-09-10 03:08 PM
  25. CharredPC's Avatar
    Thank you for this sweet little product, CharredPC! I love it and some of those movies take me back to my childhood in the 50's. Just beautiful
    Always great to hear I admit I've been neglecting the VOD section for a while, since the OS6-compatibility redesigns and Live TV work are keeping me occupied. But after implementing some new search code today, I think I'll add some more content there.


    It is looking good on os6!
    Excellent! That's also something great to hear.

    Site news: The Live Radio section is done (new OS6 label / back-end code). The News page was throwing up some Twitter errors, so I replaced the code for that too; hopefully it'll work better. I haven't forgotten about the Live TV categories (Sports, Movies, News, Music), but my plan is to use the new search back-end to produce those pages on the fly. That way, if a new channel is added or one is removed, those sections will automatically pull up the current list. I'm working on that now.
    10-09-10 03:37 PM
546 ... 89101112 ...
LINK TO POST COPIED TO CLIPBOARD