02-24-12 09:47 AM
1,007 ... 1920212223 ...
tools
  1. JRSCCivic98's Avatar
    I don't really see how someone visiting the beta download link to get 1.3.1 would think it's "better and bug free" compared to 1.3. It's a beta download link for a reason...
    Well, aside from the understanding that /bbb stands for BlackBerryBeta, most people who have a general understanding of version numbers would automatically assume that 1.3.1 is better then 1.3, since it is a higher release number. See what I'm getting at here? By having "b" in the build number, it's guaranteed that the terms "beta" is implied.
    11-04-10 02:14 PM
  2. alex.gavrilov's Avatar
    I see that you are calling them 1.3b2 etc. but when you actually download the file it's still shown as 1.3.

    It makes sense to leave the public builds as 1.3 1.4 1.5 etc. but it wouldn't hurt for beta to have 1.3.1 1.3.2 etc. and when it goes public, make it 1.4 or something.

    It's just confusing, in my opinion. No big deal.
    I thought about this too but then decided against it due to the same concerns JRSCCivic98 expressed and also because I'm too lazy to rebuild the app when it turns from beta into public release. I think I should probably add some kind of ever-incrementing build number, which is not tied to the version and will allow to precisely identify which code you are running.
    11-04-10 02:39 PM
  3. alex.gavrilov's Avatar
    Sorry guys, looks like there will be no quick audio output switching update. I was testing it today and although it seemed to work initially after more toggling back and forth I found it's quite unstable and ended up losing all sound on Storm2 in the end (for all apps even phone, which just confirms how fragile audio system is).
    11-04-10 02:52 PM
  4. catfishal's Avatar
    Alex, I have downloaded Tunein Radio on my Curve 8330m running 4.5.0.186 and every station I try to stream is very choppy and unlistenable. I have tried various MP3 and AAC stations that I listen to and get the same result. I have tried various buffer settings and have had the Compress server responses checked and unchecked. I have tried both 1.3 and 1.3b2 with the same result. FWIW I don't have these problems with Wunder Radio but much prefer the UI for TuneIn, plus it seems that development of Wunder Radio has ceased for the Blackberry platform. Any chance that a future version of TuneIn will have better performance on the 8330m, or is the 8330m too low end as the performance does seem to be memory related.
    11-04-10 03:21 PM
  5. alex.gavrilov's Avatar
    Alex, I have downloaded Tunein Radio on my Curve 8330m running 4.5.0.186 and every station I try to stream is very choppy and unlistenable. I have tried various MP3 and AAC stations that I listen to and get the same result. I have tried various buffer settings and have had the Compress server responses checked and unchecked. I have tried both 1.3 and 1.3b2 with the same result. FWIW I don't have these problems with Wunder Radio but much prefer the UI for TuneIn, plus it seems that development of Wunder Radio has ceased for the Blackberry platform. Any chance that a future version of TuneIn will have better performance on the 8330m, or is the 8330m too low end as the performance does seem to be memory related.
    There is at least one more user of 8330 who reported similar issues. The device itself is powerful enough but apparently there is something in my code which doesn't play well with it. I have yet to figure out what is it, which is tricky without the device itself. Could you send the log (after you tried a few stations)? My e-mail at @gmail.com matches my username here. Thanks
    11-04-10 03:50 PM
  6. catfishal's Avatar
    There is at least one more user of 8330 who reported similar issues. The device itself is powerful enough but apparently there is something in my code which doesn't play well with it. I have yet to figure out what is it, which is tricky without the device itself. Could you send the log (after you tried a few stations)? My e-mail at @gmail.com matches my username here. Thanks
    Sent to your email, thanks for responding so quickly.
    11-04-10 04:30 PM
  7. JRSCCivic98's Avatar
    I thought about this too but then decided against it due to the same concerns JRSCCivic98 expressed and also because I'm too lazy to rebuild the app when it turns from beta into public release. I think I should probably add some kind of ever-incrementing build number, which is not tied to the version and will allow to precisely identify which code you are running.
    The thing is, if you do that, when installing the new versions, the app will be treated as a completely new app (i.e. it'll be in the Download folder then where you placed the previous version).

    Sorry guys, looks like there will be no quick audio output switching update. I was testing it today and although it seemed to work initially after more toggling back and forth I found it's quite unstable and ended up losing all sound on Storm2 in the end (for all apps even phone, which just confirms how fragile audio system is).
    What is this quick audio output you're talking about?

    Alex, I have downloaded Tunein Radio on my Curve 8330m running 4.5.0.186 and every station I try to stream is very choppy and unlistenable. I have tried various MP3 and AAC stations that I listen to and get the same result. I have tried various buffer settings and have had the Compress server responses checked and unchecked. I have tried both 1.3 and 1.3b2 with the same result. FWIW I don't have these problems with Wunder Radio but much prefer the UI for TuneIn, plus it seems that development of Wunder Radio has ceased for the Blackberry platform. Any chance that a future version of TuneIn will have better performance on the 8330m, or is the 8330m too low end as the performance does seem to be memory related.
    The 8330 doesn't even have EVDO Rev.A speed on the network. It's the slower Rev.0, so that may be part of your issue. Couple that with the fact that it's Sprint and well...
    11-04-10 06:01 PM
  8. alex.gavrilov's Avatar
    What is this quick audio output you're talking about?
    .
    I meant "no quick update" referring to the function of switching audio output between the speaker, headphones or a bluetooth headset. I thought I've got that working but testing proved opposite so this feature is back to the lab.
    11-04-10 07:38 PM
  9. catfishal's Avatar
    The 8330 doesn't even have EVDO Rev.A speed on the network. It's the slower Rev.0, so that may be part of your issue. Couple that with the fact that it's Sprint and well...
    I have no trouble streaming 128k MP3 stations in my car using Wunder Radio on the 8330m. I think you still get 300-400K peak on EVDO Rev.0 which is more then enough bandwidth for most streaming audio. I would say that this 8330m is somewhat better for mobile streaming then my HTC Hero (which is EVDO Rev.A) is because the BB seems to hold on to weak signals better. Sprint is fine in my area (St. Louis). I think there is a bug with TuneIn Radio and the 83xx series. I'm going to guess since Alex has a Bold and a Storm 2 that he is on AT&T. The GSM 83xx series were just Edge which is just barely enough for 64k audio and not enough for 128k audio.
    Last edited by catfishal; 11-04-10 at 10:50 PM.
    11-04-10 10:43 PM
  10. tha_crock85's Avatar
    I've run into issues like this with the native media player on several BB models. Most notably, during several leaked versions of the Storm OS. Each time it was bogus code/bugs with the media player app and codec support that botched it. I have a feeling you might be experiencing the same issues here and it's not really the app's fault, but the OS version you're running.
    As far as I know I'm running the most up-to-date version of the software for the Tour that VZW has released (v5.0.0.975, Bundle 1600 , Platform 4.2.0.424). I generally don't download any of the leaked OS updates, I only update my Tour when I get the email telling me the upgrade is available.

    Could you try this: Uninstall the app, do the battery pull, install, configure Storm2 mode and Automatic buffer and try these stations again. If still no luck please send the log from Settings (the link at the bottom). Add my address (my nickname here @gmail.com) to the recipients list to make sure I get it fast. Thanks!
    First off Alex, I wanted to say sorry for taking so long to get back to you - it got a little busy here over the past week or so. I uninstalled the app & did the battery pull - and since you've released 1.3 since then I went ahead and installed that. Also configured Storm2 mode & Automatic buffer before trying those stations again.

    Since you've added a bunch of features I've been able to find out that it seems my problem is that most of my local stations are streaming in Windows Media, which doesn't seem to play well with my Tour. The stations will buffer up to 100% for about a minute or so, and then I'll get "Stream error," "Media unloaded while initializing," "Empty or invalid playlist," or in one case "Server sent error code -107."

    I did go ahead and send you the log as you asked. Still a great app though...thanks again for all the hard work you've put into it. I'll still be using it to hopefully find other cool stations to listen to!
    11-05-10 12:57 AM
  11. raysivley's Avatar
    Sorry guys, looks like there will be no quick audio output switching update. I was testing it today and although it seemed to work initially after more toggling back and forth I found it's quite unstable and ended up losing all sound on Storm2 in the end (for all apps even phone, which just confirms how fragile audio system is).
    Sorry, different question. What are the colored arrows to the right mean? Red vs green?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-05-10 06:33 AM
  12. alex.gavrilov's Avatar
    Sorry, different question. What are the colored arrows to the right mean? Red vs green?
    This is one of new features in 1.3:
    • Use yellow (or rather orange) >> marker instead of green for stations, which are potentially incompatible (= Windows Media-only stations on CDMA)
    11-05-10 07:28 AM
  13. pkcable's Avatar
    This is one of new features in 1.3:
    • Use yellow (or rather orange) >> marker instead of green for stations, which are potentially incompatible (= Windows Media-only stations on CDMA)
    a most excellent feature!
    11-05-10 07:30 AM
  14. JRSCCivic98's Avatar
    As far as I know I'm running the most up-to-date version of the software for the Tour that VZW has released (v5.0.0.975, Bundle 1600 , Platform 4.2.0.424). I generally don't download any of the leaked OS updates, I only update my Tour when I get the email telling me the upgrade is available.
    Doesn't matter if it's an official carrier OS or not. After a certain verison in the 5.x OS series, some models have Media Player codec issues on the newer OS versions... Tour included. It's issues that the carrier testers don't ever stumble upon because they don't test for it. Nothing new here... same ol bs that causes broken things... like OpenGL support not to work properly on the latest Storm2 releases.
    11-05-10 11:25 AM
  15. SPeeDy RI's Avatar
    I have a BB Storm 9530.

    I find that a lot of the streams "skip" or "hesitate" (whatever term best describes it).

    Have others experienced this?
    11-07-10 03:59 PM
  16. alex.gavrilov's Avatar
    The first beta build on 1.4 version is available at TuneIn Radio for Blackberry beta download Now I'm using the build number along with version number so it should be easy to identify different releases. No big changes but I'd want to get some feedback on it because the changes made touch the networking core, so big chances of screwing it up

    • Simplified networking code, which helped 8330 users and doesn't seem to break it on my devices either. I really need to confirm it still works for other people and networks though.
    • Added option to switch audio output. It will show up in the menu on Now playing screen when you play something and some kind of headset is connected.
    • Cancel loading of additional stream urls for a station once one of them starts to play. Some stations offer 30+ streams and previuosly the app will check them all which might take non-trivial time and interfere with the playback if the connection speed is barely sufficient to play the stream.


    This version is not considered stable so if it breaks for you please send the log file and roll back to 1.3. Thanks!
    11-08-10 01:04 PM
  17. stardomains's Avatar
    Coming from 1.0 on a 9700 5.0.0.979:

    Headset to speaker function works as described.
    Loaded a station a played it with no problem.

    One of the best apps on my BB. Thanks.
    11-08-10 02:36 PM
  18. xtchico's Avatar
    The new beta seems to have fixed the buffering and skipping the previous versions had on my 8330m.
    I have been listening for 1/2 an hour now and it hasn't cut out once. previous versions would cut our every 15 seconds or so.
    Thanks!
    11-09-10 06:59 AM
  19. jlb21's Avatar
    DLing 1.4 Build 102 to my VZW 9650 OS5.0.0.975 right now. Will try out soon.....
    11-09-10 08:22 AM
  20. hibanzai's Avatar
    When I clicked check for updates on my 1.2 version it said up to date. Didn't ahow 1.3

    Posted from my CrackBerry at wapforums.crackberry.com
    11-09-10 08:44 AM
  21. jlb21's Avatar
    It won't....you need to use your BB browser and go to TuneIn Radio for Blackberry beta download to pick up the next beta version....which will now be 1.4 build 102
    11-09-10 08:55 AM
  22. SPeeDy RI's Avatar
    Definitely addressed the skipping issue.

    This is a GREAT app..
    11-09-10 10:07 AM
  23. dollface's Avatar
    I didn't have any freezing issues, but this is definitely making my streams load SUPER fast (ver 1.4b)
    11-09-10 11:08 AM
  24. MADBRADNYC's Avatar
    I don't know what was done, but I have to admit & agree that the streams are downloading very fast now with the latest beta. Works wonderfully. Thanks for your efforts!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-09-10 11:37 AM
  25. jlb21's Avatar
    My listening has been great. Quick loads....stable playback, etc.

    I have had a few minor pauses, but that is likely the fortress of the building I am in causing the signal to fluctuate.

    Great work!!!
    11-09-10 12:38 PM
1,007 ... 1920212223 ...
LINK TO POST COPIED TO CLIPBOARD