1. rockey's Avatar
    Folks, i am trying to download Bb World App for a friend of mine on his BB curve 8320, when i go thru the steps it gives me an message that says this:
    NOTICE:
    Sorry, your device does not meet the system requirements that are needed to support Blackberry App World.

    Can anyone tell me whats going on here?
    Thank
    rockey
    01-05-10 01:23 PM
  2. TNuggs13's Avatar
    It might not have enough available memory to run it.
    01-05-10 02:23 PM
  3. rockey's Avatar
    yes you may be right i just dont know as i'm new to the Blackberry world.
    01-05-10 02:59 PM
  4. Motorcycle Mama's Avatar
    1. Do you have a BlackBerry Data Plan?
    2. What OS version is on the device? Go to Options > About and read the third line.
    01-05-10 05:31 PM
  5. rockey's Avatar
    Its actually a friend of mines blackberry, i do know he has a data plan but i do not know what his OS version is, i will find out tomorrow when i see him at work and let you all know.
    01-05-10 08:33 PM
  6. bukhari9's Avatar
    Hi to All in conversation!
    Buddies I also have the same problem, Actualy my bb 8320 have os 4.5 but bb app world i have is for os 5.0. And even my contry is not supported for app world so i cannot download it from bb web.

    PLEASE HELP ME OUT!!!

    If anyone have a app world supported with os 4.5???
    05-15-10 06:41 AM
  7. Laura Knotek's Avatar
    Hi to All in conversation!
    Buddies I also have the same problem, Actualy my bb 8320 have os 4.5 but bb app world i have is for os 5.0. And even my contry is not supported for app world so i cannot download it from bb web.

    PLEASE HELP ME OUT!!!

    If anyone have a app world supported with os 4.5???
    Try the steps in this thread to see if you can get App World to work in your country. http://forums.crackberry.com/f100/ho...ntries-237065/
    05-15-10 10:15 AM
  8. blazed12's Avatar
    Actually, I asked BlackBerry Help on twitter how come I can't download BB App and why I keep getting the "Sorry, your device does not meet the system requirements that are needed to support BlackBerry App World" apparently you need a data plan from your carrier (maybe BIS?) to download the application.. Hope this helps

    Posted from my CrackBerry at wapforums.crackberry.com
    05-15-10 11:49 AM
  9. Motorcycle Mama's Avatar
    Did you even read the posts in the thread?
    05-15-10 11:58 AM
  10. blazed12's Avatar
    Did you even read the posts in the thread?
    Are you referring to me or something?
    05-15-10 12:53 PM
  11. Motorcycle Mama's Avatar
    Yes.

    The need for a BlackBerry Data Plan in order to use BlackBerry App World was discussed several times already in the thread.
    05-15-10 01:08 PM
  12. blazed12's Avatar
    Umm.. okay? you don't have to be a smart a s s about it.. As you can see i replied with a mobile phone i just read the first post and replied with my answer.. i didn't read every single post so give me a break
    05-15-10 01:45 PM
  13. Motorcycle Mama's Avatar
    That's why I asked if you had actually read the posts in the thread.

    Your answer should have been "No."

    Posting via the WAP site is not an excuse for not reading the thread before posting.
    05-15-10 02:25 PM
  14. blazed12's Avatar
    That's why I asked if you had actually read the posts in the thread.

    Your answer should have been "No."

    Posting via the WAP site is not an excuse for not reading the thread before posting.

    Yeah that's my fault i should of said no instead.. my bad lol
    05-15-10 04:56 PM
LINK TO POST COPIED TO CLIPBOARD