1. futrftdoc12's Avatar
    I seem to keep having this same problem occur rather frequently. The screen will go white and read "App Error 523 Reset". I have wiped it clean, and have installed the newest OS .593 and the only apps that I now have on my device are berrybuzz, berryweather, RepliGo, and Facebook. The problem was there before the newest OS and is now back. Happened 3 times to me in one day. Is there anything that I can do to fix this? Do I need to just go in and get a new phone with the warranty? Any help would be greatly appreciated. Thanks.
    04-08-10 07:37 PM
  2. dictoresno's Avatar
    at this point, it may be some kind of a hardware defect causing the issue. but i do wonder if one of your apps are somehow creating the error. which app did you install last, before this all started happening?
    04-08-10 08:54 PM
  3. futrftdoc12's Avatar
    The last app that I installed was Facebook. If its not the app that's causing the problem, and is a hardware issue, I would assume it's best to take it back to at&t and get a new phone right?
    04-09-10 08:05 AM
  4. scoot05redss's Avatar
    I had the same issue a few weeks back while upgrading my OS. Turns out the problem was Shrink A OS was removing a file that shouldnt have been removed. Reinstalled without shrinking and everything was gold. Removed and reinstalled shrink a os and then reinstalled the OS and everyting was great!
    04-09-10 08:39 AM
  5. futrftdoc12's Avatar
    Thanks Scoot05RedSS, I will have to give it a try. I really don't want to have to deal with going in to at&t and ordering a new (refurb) phone.
    04-09-10 08:57 AM
  6. scoot05redss's Avatar
    Not a problem, hopefully I can save you half the headache i went through to figure that out! 4 days, 3 different OS's!! 1 thing in common, all loaded through Shrink a OS! Were you using ShrinkAOs?
    04-09-10 11:08 AM
  7. SLVR6's Avatar
    I've been having this issue since I loaded .536 (or whatever the leak was before .545) and can't seem to get rid of it! I do not use shrink a os or anything else, just hand strip the OS and have been using the loader to install. Going to have to try a full wipe/brick the phone, then reinstall. Otherwise I guess I will have to badger att for a replacement.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-10 10:07 PM
  8. joe.kent's Avatar
    I had this on my original bold.. had it for a day. I ordered it offline and when it got here it was having that issue... took it to ATT store, they swapped it no problem... no more issues.
    04-11-10 11:38 AM
  9. Pete6's Avatar
    RM say this about JVM 523

    For BlackBerry smartphones running BlackBerry® Device Software version 4.1, this error may occur if a third-party browser channel icon has a HyperText Transfer Protocol (HTTP) redirect.
    Cause 2
    When a locked BlackBerry smartphone with content protection enabled receives a Multimedia Messaging Service (MMS) message, this error may occur. This error only occurs with the Today themes in BlackBerry Device Software version 4.2.2.

    Pretty useless 2nd paragraph...

    I suggest that you try booting the phone in Safe Mode byt re-booting and then holding down the Escape key while the phon eis booting. By doing this you will boot without any 3rd party app. If the phone now works then the problem lies with something you have downloaded or installed. If niot then you need and OS re-install.
    04-11-10 11:56 AM
  10. cantontrader's Avatar
    I'm managing about 900 devices. 35 of them are 9700s. So far, 16 of those are having the application error 523 error at random times. I have an open case with RIM on the issue. I suspect it has something to do with the mandated content protection that is required on our devices.

    Here's the weird thing.... NO OTHER DEVICE IS HAVING THE ISSUE !

    I have 7290s up to the 9700 on 3 BESs. The 9700s are the only device having the issue.

    I think it's a firmware problem. (We've tried the original 5.0.0.463 AND 5.0.0.405 and nothing fixes it).

    Some of the 9700s are oncall devices, so there are times they are not getting the pages because the device is in the App Error 523 error. The only recourse is to downgrade to the 9000 bold or a lower device.

    Any solutions would be extremely helpful.
    04-13-10 02:40 PM
  11. virgocrush's Avatar
    using at&t .405 firmware

    one of these popped up last week(first time) and after rebooting several times I had to pull the battery to get it up running.
    04-14-10 10:17 PM
  12. HNYK's Avatar
    are your devices throwing the error when the signal drops to EDGE or edge?
    04-19-10 07:20 PM
  13. mi_canuck's Avatar
    I had this happen (app error 523) just today! Loading up .680 onto my 9700 (which i'm back on... long story).... anyways... found this solution... was the only thing that worked... meant having to start back from scratch, but beats a bricked 9700... and this actually worked!

    BlackBerry 101: How to Reload the Operating System on a Nuked BlackBerry | CrackBerry.com
    05-31-10 05:49 PM
  14. SLVR6's Avatar
    I had this happen (app error 523) just today! Loading up .680 onto my 9700 (which i'm back on... long story).... anyways... found this solution... was the only thing that worked... meant having to start back from scratch, but beats a bricked 9700... and this actually worked!

    BlackBerry 101: How to Reload the Operating System on a Nuked BlackBerry | CrackBerry.com

    Didn't defect to another "device" recently?

    I got rid of my problem by doing a double wipe with JL_Cmdr and then reloading everything. No issues since then thankfully.
    06-01-10 03:32 PM
  15. mi_canuck's Avatar
    i defected... but realised my foolishness and happily back to the best GSM device on the planet... 9700!! seriously, CDMA is beyond ********, I can't believe I actually left... momentary insanity!

    i'm since back to .586 right now... .680 was giving me what seemed like dropped call issues (in a weak signal spot - ie. my office's building, but still... didn't seem as stable as .656)... so 'downgraded' to .586 in hopes that migrating to .714 will come sooner (as the rumoured OTA that a very few have been lucky to get)....
    06-01-10 03:54 PM
LINK TO POST COPIED TO CLIPBOARD