1. puckish88's Avatar
    Okay, I have searched the internet high and low and am yet to find a solution for this very simple problem. BTW, I love my blackberry, but it's things like this--very simple problems with very complex solutions--that make me think I'd be better off with an iPhone.

    Every time I get a voicemail, I also get a SMS text message notifying me of my new voicemail. This is pointless, redundant and annoying and I don't want to receive these text messages anymore.

    Before you all spit back some of the suggestions I've seen others give on other sites, let me tell you what I've tried:

    Call your voicemail and set your administrative options to change this.
    I have tried this. I have Verizon, and there is no option to turn off these SMS texts.

    Go to options > security options > firewall and turn off SMS texts.
    This blocks all messages. I just want to block those from my voicemail.

    Download a SMS text filter/blocker and block the SMS messages from Voicemail.
    I have also tried this. I downloaded Black & Whitelist 1.5.1 to do this, but this program only works for phone calls. In the instructions it says specifically, "Black & Whitelist blocks only phone calls. It is not capable of blocking SMS messages." If someone knows of another third party app that can filter SMS messages PLEASE LET ME KNOW WHAT IT IS. I cannot find one for blackberrys. I found one for the S60 OS called SMS Spam Manager 1.09. I want something like this for blackberrys.

    Go to your messages and hit Alt + V and this will bring up all your voicemail texts. Now you can delete them.
    This DOES NOT fix the problem. I don't want to erase them. I don't want ever want to receive them in the first place.

    Sorry for the long post, but I wanted to document all the potential fixes I've seen so that I don't get suggestions I've already tried.

    HELP!
    10-28-08 02:04 PM
  2. Navan's Avatar
    You may be able to BLOCK them using an app (although I haven't heard of one either- not many people want to block SMSes from a certain person) but you can't stop them all together using an app.

    This isn't a blackberry problem- it's something your service providor does. That's why people keep telling you to call Verizon and tell them to turn it off, because THEY'RE sending them!

    I get this too from Rogers- I get my voicemail notification on the phone, the missed call notifier, a text message letting me know I have a voicemail, AND a WhoCalled text message notification. It's a pain in the *** I agree- but again, not a blackberry issue, a provider issue. It's a relic from the days when cellphones didn't have automatic voicemail notification through the phone. I guess not enough people have complained about it (it doesn't **** most people off to that extent) and therefore isn't a priority for them to remove.

    My recommendation would be to remove your voicemail service from Verizon and get an app such as PhoneFusionVoicemailPlus (free visual voicemail and inbox) instead. I'd use this service and get rid of the annoying texts and Whocalled notifications (which are redundant- I KNOW who called that's what caller ID is!) but alas- American number, long distance!

    So in my mind those are your options. Live with it, or get another service.
    10-28-08 03:20 PM
  3. sunkast's Avatar
    You could try setting your call logging options to none. Phone > Menu > Options > Call Logging.
    10-28-08 03:26 PM
  4. kvaughan's Avatar
    You could try setting your call logging options to none. Phone > Menu > Options > Call Logging.
    CDMA Berries still send a text notification of voicemails.
    10-28-08 07:09 PM
  5. Navan's Avatar
    CDMA Berries still send a text notification of voicemails.
    The Berry doesn't send them the CDMA carrier does!
    10-28-08 09:21 PM
  6. kvaughan's Avatar
    The Berry doesn't send them the CDMA carrier does!
    I know. Wrong wording
    10-29-08 12:50 AM
  7. Pre-dawn raid's Avatar
    I am also annoyed by this feature. I called Sprint to have the issue resolved and the rep told me that it can't be removed on their end. So is it a BB problem or Sprint problem. Noone knows!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-29-08 02:21 AM
  8. some's Avatar
    I am on Cricket and have been for several years. Each year my wife and I generally get a new phone. This year she chose a Blackberry 8130 because of the great reception and extras. She now is plagued with the voice mail sms. I am using an htc touch (windows mobile) and do not have this issue. Microsoft and all of the other phone companies are doing a great job of interpreting this message to increment the voice mail count. I know for a fact that if I switch this blackberry for an old throwaway cdma phone, it would not have this issue.
    The wife can no longer get to her sms messages easily because they are buried in 'voice mail' notificaitons.
    Don't try to excuse a true bug in the Blackberry OS. It's tempting to do but this needs to be fixed. The phone needs to simply increment the voice mail count and ignore (not store) the sms.
    11-13-08 01:10 AM
  9. malicio's Avatar
    I currently have Rogers and used to get the annoying SMS to my ex-Phone (Motorola ROKR). I was able to disable it from the phone itself using the call logging feature. Unfortunately for some reason the BOLD does not have this option to disable voicemail sms. It can disable the missed calls sms, etc. but not voicemail. They should come out with either an incrementer as mentioned before or an extra checkbox to disallow voicemail in the call logging feature.
    01-05-09 04:21 AM
  10. techrebel's Avatar
    When you are at the firewall, scroll to the bottom of the page and press he menu button again & you should see exception options where you can ytpe in the exact number the SMS is coming form & block only it. Mine is an 8310 though, so yours may not have those features.

    Good luck
    05-11-09 07:57 PM
  11. RobEmenecker's Avatar
    I have the same issue with the Tour. Since some contacts still use SMS, it's annoying to have to weed through all of the voicemail SMS messages. On the Tour I do get the proper call notification icon AND it is incremented properly.

    I just tried the firewall suggestion. I turned on the Firewall and then blocked all SMS *except* if they are on my Contact list or on my exception list. I still got the SMS.

    Problem is that the Firewall sees the SMS notification as coming FROM the in bound caller. Aaaaarrrggggh.

    I can't block the Contacts. I'm getting the proper notification. What I need to do is set up a filter based on the text of the SMS. Can't think of any other way around it.
    08-06-09 05:49 PM
  12. Ami.'s Avatar
    Just a thought, but why not just turn off the voicemail notification so you don't get the icon, but still get the text message? It eliminates the redundancy. Yeah, I'm sure you don't want the text message, but there's really no way around it, so make it less of a hassle.

    (Like i said, just a thought )
    09-25-09 10:35 AM
  13. lovinthecurveinsocal's Avatar
    The only way I've cured this on my Sprint 8330 is to enable the firewall, check Block SMS Messages, and check the box at bottom that says "Except messages from my Address Book Contacts". Since my voicemail is not a contact, no more SMS notices about voicemail.

    This causes two issues though:
    1. No texts unless they're in the Address Book. Not an issue for me though.
    2. Some apps have an issue with firewall enabled...Smrtguard can't connect for me with the firewall enabled.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-26-09 01:06 AM
  14. Fuzzballz's Avatar
    I too think this is annoying and ********.

    And actually, the problem IS with blackberry, because my other phones on VZW have not done this. If they can reject these types of SMSs, I'm sure BBs can as well.
    Last edited by Furballz; 10-24-09 at 09:35 PM.
    10-24-09 09:31 PM
  15. NRAMember's Avatar
    The only way I've cured this on my Sprint 8330 is to enable the firewall, check Block SMS Messages, and check the box at bottom that says "Except messages from my Address Book Contacts". Since my voicemail is not a contact, no more SMS notices about voicemail.

    This causes two issues though:
    1. No texts unless they're in the Address Book. Not an issue for me though.
    2. Some apps have an issue with firewall enabled...Smrtguard can't connect for me with the firewall enabled.

    Posted from my CrackBerry at wapforums.crackberry.com

    Thanks! This worked for me. Best solution I've found after hours of searching the net.
    07-06-10 10:24 PM
  16. just_a_guest's Avatar
    I would just like to confirm something, the CDMA carrier sends this message, GSM carries also can do this but they usually tend to send just the message instead of the icon. Normally CDMA carriers have 3 options based on the Service Type used when submitting a message to the SMSC:
    1. Send icon and text message
    2. Send a message only
    3. Send icon only

    Using your carrier options to stop the message is the only clean way of stopping the notifications everything would be a hack and would lead to some undesirable side effects. If they have no such options related to their Voicemail system you could ask them if it is possible to blacklist the voicemail number from sending messages to you handset via the SMSC. Depending on the SMSC vendor, this might be possible
    02-17-11 07:53 AM
  17. b1gbleu's Avatar
    Thanks Diggstar, that setting works for me not getting the message icon on my 8350i, only now I get the icon for VM + counter, but no red led blinking. Not good.
    Thanks lovinthecurveinsocal , but that didn't help.
    checking contacts in the exceptions list doesn't help, adding phone numbers worked but is ridiculous. I should point out that V4.6 didn't do this. I recently upgraded to 5.0.
    They should make an editor for the BB.
    Last edited by b1gbleu; 03-22-11 at 06:14 PM.
    03-22-11 06:09 PM
  18. pharmarep's Avatar
    I went into my Verizon voicemail and fixed it. You got to Message Waiting Indicator option Turn Off. I no longer get a text message yellow indicator showing a recorded voicemail.
    10-30-12 09:50 AM
LINK TO POST COPIED TO CLIPBOARD