09-01-09 03:15 PM
50 12
tools
  1. AppStateAddict's Avatar
    I am running slacker on .75 on my 9530. I am having the same lag issue, or what I am thinking is a lag issue, with Slacker ending songs early. I also have slacker stop songs when my ringtone is set to anything but vibrate and I receive email or sms. I wanted to try to cache a few of my stations to see if that has any effect, not to mention just wanting to free up some bandwidth on the device instead of surfing the web and streaming music at one time.

    I am playing a station, hit the BB Menu, press cache this station, and it brings up some sort of message about connecting the device to your computer first. I did this, but how am I to know if the station was cached or not? Can anyone assist with a step-by-step account of what to do?
    01-18-09 05:21 PM
  2. CojonesDeToro's Avatar
    Slacker still has some issues. I see the same problems with premature ending of songs and no restart after the bb makes any noise.

    As for caching, you need to connect it to a computer via usb such that the bb is shares the sd card as a drive (forget the name of the mode). The slacker sync client will then show up as a runnable item in the autostart menu. If it doesn't show up go to /slacker/bin/win32/syncer and look for the executable file.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-18-09 08:54 PM
  3. jbharman45's Avatar
    Yeah, if you dig into the Slacker Forums, the sound issues on the Storm are known. A fix is supposed to be coming. And, it took me a couple of hours to figure out that I had to run the Sync app from the SD Card in Storage Mode to get the cache to fill. However, I really like this feature and I am looking forward to trying it on my next flight.
    01-18-09 11:28 PM
  4. Pabongka's Avatar
    I have also tried to cache stations and have run the sync and on the app doesn't show up as cached...though do understand that this isn't set up for the storm yet...
    01-18-09 11:38 PM
  5. SGracer's Avatar
    Works fine for me on .86 7 stations cached.
    01-18-09 11:40 PM
  6. Pabongka's Avatar
    huh...I'm running .86 as well....need to figure out how to get it to work...that is a great feature that I am somehow not getting.
    01-18-09 11:48 PM
  7. AppStateAddict's Avatar
    Well, I found the exe file. I do have a Mac, G4 so I can't run bootcamp, parallels or anything the like. Obviously you can't run an .exe files on a non-intel based macs. So I guess this is a problem with slacker. If you don't have a pc or intel mac, then you can't cache stations? Maybe I'm missing something. Continued help would be great.
    01-19-09 12:07 PM
  8. goathog02's Avatar
    Have you upgraded your OS since installing Slacker the first time? I did, and had the same problem. I just needed to delete all the Slacker data from my memory chip, and reinstall. Caching works great now!
    01-20-09 02:35 PM
  9. AppStateAddict's Avatar
    Have you upgraded your OS since installing Slacker the first time?
    Nope. I installed on .75 and am still running .75. Once again maybe someone can help on this, but there was mention of needing to run the .exe file. I have a Mac that isn't capable of opening .exe's as it is a G4 and not Intel based. So, is this the problem? Has anyone who syncs to a Mac and uses Slacker been successful in caching stations and what did you do?

    So, it's my thinking that is impossible to cache stations if you are a Mac user. Once again, help would be appreciated if someone has been successful.
    01-20-09 02:46 PM
  10. Valve's Avatar
    How does the caching work?

    I don't really understand what it does.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-09 02:49 PM
  11. AppStateAddict's Avatar
    Caching basically creates a playlist of songs, lets say 30 for example, for any given station and stores it on the media card. This allows you to listen to those stations you have cached without having to access any data network. So, there is no worry about buffering and lag issues. And I would guess would just free up some bandwidth on your device instead of running 3 or 4 apps that are accessing data at once.

    I have no idea how many songs are cached, though. I made up that number for example. But everytime you connect to your computer to sync the device, Slacker updates the playlist so the music doesn't get stale! It is pretty smart. Now, if someone can read my previous post and either confirm or disprove my thoughts on this because I would love to have this feature!
    01-20-09 03:15 PM
  12. marcuswyse's Avatar
    Can someone give me step by step instructions on how to cache stations? I am not understanding the whole slacker/bin/win32/syncer terminology. Help! Thanks in advance
    01-20-09 03:48 PM
  13. d20636's Avatar
    YMMV - this is what I've had to do...

    With the BB unplugged and Slacker running a station, cache it. I had to disable mass Storage under Options/Media Card for Slacker to recognize I had the card installed.

    I then had to enable mass storage so it would be recognized upon connection via USB. This brought up the normal "device found whatchya wanna do" with an option for Slacker Sync. Selecting this ran a small app that founf the one station I had cached and it sync'd it - in a little over 7 minutes.

    Oh, and then I had to disable mass Storage again so Slacker could see the card again...

    I can only assume I have something else not quite tweaked - this is a bit of a kludge just to sync/cache some stations...
    01-26-09 09:51 PM
  14. davidaugust111's Avatar
    Can anybody update this thread?

    It's an official release now, but I can't figure out how to cache. When the BB is unplugged, Slacker says I have 0 stations cached on the list of different genres. But I've selected 5 stations, and when I try to re-enter one of those, it says it's already on the list.

    Plugging it in with the USB seems to do nothing whether I have the DM open or not.

    Can anybody tell me exactly what I need to do?

    Thanks!
    02-09-09 07:36 PM
  15. Philly-Sports's Avatar
    How do I cache stations on my BlackBerry?
    While a station is playing on your BlackBerry phone, click on the menu button and then choose “Cache Playing Station” The next time you connect your BlackBerry to your PC, make sure it’s set to run in Mass Storage Mode. If so, you should have an autorun box pop up that asks what you would like to do, choose Sync with Slacker Sync program. If you do not see the box pop up, that means you have disabled your Autorun. In this case, navigate to your Removable Drive (My Computer, Then whatever drive letter is the removable drive for your BB), and you will find a program called “Slacker.Synclauncher.exe” Run this file to start the syncing process.
    02-09-09 08:44 PM
  16. davidaugust111's Avatar
    Thanks Philly-Sports,

    I followed your instructions, but unfortunately it keeps popping up with: "Login failed: Server returned 401 Run setup on the device again." Don't know what that means. Uninstall the whole thing?
    02-09-09 09:22 PM
  17. miseri's Avatar
    Thanks Philly-Sports,

    I followed your instructions, but unfortunately it keeps popping up with: "Login failed: Server returned 401 Run setup on the device again." Don't know what that means. Uninstall the whole thing?
    I think this has to do with the .99 OS, I was running the official Slacker software for Storm, wasn't having any problems whatsoever with caching until last night when I finally broke down and upgraded from .75 to .99.
    02-09-09 09:42 PM
  18. aaronwh98's Avatar
    I'm also having a problem caching Slacker. My Storm (.99) won't enter into mass storage mode no matter what I do. I've set it to auto enable mass storage when connected; I've tried to manually enable it while it's connected to the computer, I've started up the media manager, I've tried a batter pull, I've even tried it in Vista and Windows 7 (I have a dual boot)...nothing seems to work. Any ideas?
    02-09-09 09:46 PM
  19. oOOOo's Avatar
    Missing piece for me was "options/memory/mass storage mode support=on".

    I did do a Slacker "account reset" after mss=on. Currently caching station#1 (nickleback).

    edit:
    a) seems like you cannot add a cached station WHILE updating cache,
    b) seems like you have to close Slacker on the bb before connecting the usb to launch the station loader,
    c) blue "c" means already cached,
    d) gold "c" means cache op pending next usb hookup...

    Please let me know if I misconstrued anything guys...
    Last edited by oOOOo; 02-09-09 at 10:54 PM. Reason: completeness
    02-09-09 10:41 PM
  20. matrix2004's Avatar
    Thanks Philly-Sports,

    I followed your instructions, but unfortunately it keeps popping up with: "Login failed: Server returned 401 Run setup on the device again." Don't know what that means. Uninstall the whole thing?
    Problem solved. Delete Slacker from your Storm. Then from mass storage mode on your pc, delete the slacker folder from the memory card. Finally, go to Slacker.com and resinstall Slacker. Play a station,cache it, close Slacker. Go back to mass storage mode, and choose the Slacker sync. It will now sync. Enjoy. It does take a long time though.
    02-09-09 11:41 PM
  21. miseri's Avatar
    Missing piece for me was "options/memory/mass storage mode support=on".

    I did do a Slacker "account reset" after mss=on. Currently caching station#1 (nickleback).

    edit:
    a) seems like you cannot add a cached station WHILE updating cache,
    b) seems like you have to close Slacker on the bb before connecting the usb to launch the station loader,
    c) blue "c" means already cached,
    d) gold "c" means cache op pending next usb hookup...

    Please let me know if I misconstrued anything guys...
    Thanks, the account reset did it for me, I'm caching right now!
    02-10-09 12:22 AM
  22. davidaugust111's Avatar
    Alas, no such luck for me. I did all of the steps from matrix2004 and eventually got the exact same message. That's all the energy I'm willing to invest for now; perhaps later there will be a combination of software updates for either Slacker or the BB that will make it work for me.
    02-10-09 06:32 AM
  23. gonoles23's Avatar
    I am lost. When i do this my comp opens the files with itunes and nothing happens. Nothing that has anything to do with slacker pops up. can someone pelase help?
    02-10-09 03:32 PM
  24. mainadungo's Avatar
    I had the "Login failed: Server returned 401 Run setup on the device again." error also, and couldn't figure it out. Thanks to oOOOo and Matrix, I got it to work.

    matrix2004's solution seemed like a lot of work, so I just:

    1) enabled mss on my Storm (options/memory/autoEnableMassStorageModeWhenConnected)
    2) opened Slacker and did an "account reset" from the Slacker menu (Slacker will reset)
    3) once it completed, I re-opened Slacker and signed back in
    4) chose station I wanted to cache
    5) CLOSED SLACKER COMPLETELY
    6) plugged in to USB and it synced right up!

    gonoles23 (and others who aren't getting any sync prompts)
    If you don't get the Slacker window at this point, then open mass storage mode (My Computer) and open the drive, and click on "slacker.synclauncher.exe"
    02-11-09 11:18 AM
  25. davidaugust111's Avatar
    I also gave it another try, and it worked! Now the only thing that I did differently was to start with JUST 1 cached station. In my previous attempts I was trying more than one. So this time I just did one, it worked, and then I went back in and cached two more at the same time, and it worked. I went in one more time and cached 3 additional stations; it worked and it now appears that when re-hooking up, it automatically is check all 6 subscriptions.

    Thanks to all of you that helped!
    02-11-09 12:14 PM
50 12
LINK TO POST COPIED TO CLIPBOARD