01-14-13 07:27 AM
712 ... 678910 ...
tools
  1. TomCanuck's Avatar
    'ImportMacro' imports macros, not a full shortcut (AppName and Parameter in TES shortcut is not imported. Only the Macros field in TES is imported).
    Ahha

    Shortcut Name: Toggle Bluetooth
    Shortcut Keys: BTT
    App Name: Macro
    Macros:
    Launch Manage Connections;
    While0 !IsAppForeground Manage Connections;
    Do0;
    Delay1;
    EndWhile0;
    NavMoveDown2;
    NavClick;
    EscKey;

    Shortcut Name: Test
    Shortcut Keys: TES
    App Name: Macro
    Macros:
    ImportMacroBTT;

    Works like a charm. Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    Vijik likes this.
    10-13-11 10:04 PM
  2. TomCanuck's Avatar
    Delay200;NavMoveDown1;Delay200;NavClick;Delay200;N avMoveDown5;Delay200;NavClick;

    Running the latest beta 5.5.6.1

    Posted from my CrackBerry at wapforums.crackberry.com
    tested with ShortcutMe 5.5.6.1 (Beta) with all permissions allowed on 8330/5.0.0.438

    Shortcut Name: Media_Pictures
    Shortcut Keys: TES
    App. Name: Media_Pictures
    Macros:
    Delay200;
    NavMoveDown1;
    Delay200;
    NavClick

    seems to work fine for me. I also tested

    Shortcut Name: Test
    Shortcut Keys: TET
    App Name: Macro
    Macros:
    Launch Media_Pictures;
    Delay500;
    NavMoveDown1;
    Delay200;
    NavClick;

    and that seems too be good to go also
    Last edited by Juggalo20; 10-13-11 at 10:20 PM.
    10-13-11 10:18 PM
  3. pdl2mtl90's Avatar
    tested with ShortcutMe 5.5.6.1 (Beta) with all permissions allowed on 8330/5.0.0.438

    Shortcut Name: Media_Pictures
    Shortcut Keys: TES
    App. Name: Media_Pictures
    Macros:
    Delay200;
    NavMoveDown1;
    Delay200;
    NavClick

    seems to work fine for me. I also tested

    Shortcut Name: Test
    Shortcut Keys: TET
    App Name: Macro
    Macros:
    Launch Media_Pictures;
    Delay500;
    NavMoveDown1;
    Delay200;
    NavClick;

    and that seems too be good to go also
    Did you happen to try it with NavMoveDown2, 3, 4 or some other integer? I can get it to move down 1, however, I can not get it to move down past 1.
    10-14-11 06:08 AM
  4. dimm0k's Avatar
    Not sure if anyone else has come across this, but I was in the process of creating my first macro and after entering everything I wanted it to do I went to save. I was told by SCM that I didn't have an "App Name" set and after acknowledging this, instead of bringing me back to the editor? to let me fix that it just exited with no remorse!
    10-14-11 07:20 PM
  5. TomCanuck's Avatar
    Not sure if anyone else has come across this, but I was in the process of creating my first macro and after entering everything I wanted it to do I went to save. I was told by SCM that I didn't have an "App Name" set and after acknowledging this, instead of bringing me back to the editor? to let me fix that it just exited with no remorse!
    True story. Does the same with me on. 5.9.1.3_OS7_T on 9900/7.0.0.440. It does forgive you if you forget shortcut keys though

    Posted from my CrackBerry at wapforums.crackberry.com
    10-14-11 07:28 PM
  6. dimm0k's Avatar
    Should have included all my findings in one post, so I'll do that here... Maybe I'm a bit too anal, but hopefully others find these to be annoying as well.

    Previously stated that not having an "App Name" set does not give you a way to go back and fix, instead it just exits regardless of what you may have already entered/save in the editor.

    When adding a new item and going to save, one has to use the trackpad/ball to select Save. Usually pressing 'Enter' does the same, but not the case here.

    Trying to create a macro that turns off Wi-Fi, BT, and radio if any of them are on with the following:
    If0 IsBtOn;
    Then0;Launch Bluetooth_Toggle;
    Else0;If1 IsRadioOn;
    Then1;Launch Radio_OFF;
    Else1;If2 IsWifiOn;
    Then2;Launch Wifi_OFF;
    Else2;Stop;
    EndIf0;
    EndIf1;
    EndIf2;


    Running this the first thing that happens is I'm asked if I want to turn on BT because SCM requires BT to be enabled... am I using the "IsBtOn" correctly? Not sure if this prompt screws up the whole macro, but the rest of the macro doesn't seem to get touched afterward.
    10-14-11 07:53 PM
  7. Vijik's Avatar
    True. It doesn't like a shortcut with no AppName.
    I will fix it soon in a new beta version.

    dimm0k, do you have the beta link?
    10-14-11 07:56 PM
  8. dimm0k's Avatar
    True. It doesn't like a shortcut with no AppName.
    I will fix it soon in a new beta version.

    dimm0k, do you have the beta link?
    No, but I wouldn't mind it. Using 5.9.1.0_OS7_T BTW...
    10-14-11 08:05 PM
  9. Vijik's Avatar
    Should have included all my findings in one post, so I'll do that here... Maybe I'm a bit too anal, but hopefully others find these to be annoying as well.

    Previously stated that not having an "App Name" set does not give you a way to go back and fix, instead it just exits regardless of what you may have already entered/save in the editor.
    This will be corrected soon.

    When adding a new item and going to save, one has to use the trackpad/ball to select Save. Usually pressing 'Enter' does the same, but not the case here.
    Usually pressing ESC key in BB OS will ask you if you want to save (if anything is changed). This is also the case here.
    ENTER key doesn't always, in BB OS, means Save. (I might be wrong).

    I always press ESC key when I am done with a shortcut settings.


    Trying to create a macro that turns off Wi-Fi, BT, and radio if any of them are on with the following:
    If0 IsBtOn;
    Then0;Launch Bluetooth_Toggle;
    Else0;If1 IsRadioOn;
    Then1;Launch Radio_OFF;
    Else1;If2 IsWifiOn;
    Then2;Launch Wifi_OFF;
    Else2;Stop;
    EndIf0;
    EndIf1;
    EndIf2;


    Running this the first thing that happens is I'm asked if I want to turn on BT because SCM requires BT to be enabled... am I using the "IsBtOn" correctly? Not sure if this prompt screws up the whole macro, but the rest of the macro doesn't seem to get touched afterward.
    IsBtOn is using an API that unfortunately does pop up that dialog box if BT is On. This is very odd and not in consistency with similar APIs I have used for IsRadioOn and IsWifiOn.
    This is the way the API behaves.
    Last edited by Vijik; 10-14-11 at 08:14 PM.
    10-14-11 08:05 PM
  10. Vijik's Avatar
    No, but I wouldn't mind it. Using 5.9.1.0_OS7_T BTW...
    Send email to support at shortcutme dot com
    10-14-11 08:06 PM
  11. TomCanuck's Avatar
    Usually pressing ESC key in BB OS will ask you if you want to save. This is also the case here.
    ENTER key doesn't always, in BB OS, means Save. (I might be wrong).

    I always press ESC key when I am done with a shortcut settings.
    I usually hit EscKey for the prompt then either "y" or "s" depending on the prompt to save changes. but neither works in SCM
    10-14-11 08:09 PM
  12. Vijik's Avatar
    dimm0k, I sent you the link. You should be able to find 5.9.1.3 there.

    The fix for the problem you reported will be in a newer version today or tomorrow as 5.9.1.4
    10-14-11 08:21 PM
  13. Vijik's Avatar
    I usually hit EscKey for the prompt then either "y" or "s" depending on the prompt to save changes. but neither works in SCM
    Correct, "y" and "n" doesn't work now.
    Let me check how it will work for devices with reduced keypad and virtual keypad (touch only). If it works across the border I will add it. Otherwise I am afraid you need to hit Yes or No button on the screen instead of Y, N on the keypad.
    10-14-11 08:28 PM
  14. TomCanuck's Avatar
    Correct, "y" and "n" doesn't work now.
    Let me check how it will work for devices with reduced keypad and virtual keypad (touch only). If it works across the border I will add it. Otherwise I am afraid you need to hit Yes or No button on the screen instead of Y, N on the keypad.
    not a big deal to me, I've gotten used to it as is.
    10-14-11 08:31 PM
  15. dimm0k's Avatar
    dimm0k, I sent you the link. You should be able to find 5.9.1.3 there.

    The fix for the problem you reported will be in a newer version today or tomorrow as 5.9.1.4
    Thanks for the link and for the quickness in support!
    10-14-11 08:37 PM
  16. TomCanuck's Avatar
    Thanks for the link and for the quickness in support!
    If you're a fan of the thread please consider rating it (nudge nudge 5 stars :P)
    10-14-11 09:08 PM
  17. dimm0k's Avatar
    If you're a fan of the thread please consider rating it (nudge nudge 5 stars :P)
    Too late... I just realized the star rating thing and couldn't help myself but give it 5 stars!
    10-14-11 09:14 PM
  18. TomCanuck's Avatar
    Too late... I just realized the star rating thing and couldn't help myself but give it 5 stars!
    I'm always too late :'( hahah ;D
    10-14-11 09:15 PM
  19. anon(4113192)'s Avatar
    Is there some way to backup SCM to the device instead of SD?

    I have to reset the OS to test if ift has to go in for repair, and I don't have an SD card
    10-14-11 10:22 PM
  20. TomCanuck's Avatar
    Yeeh, it looks better at the actual line breaks , makes more sense.

    Another cosmetic suggestion, making macros start in the line below of Macros: and not next to it. Because, enter does not create a line break if its the first line.

    As in,
    Macros:
    dwasdwasd;
    wasd;

    instead of,
    Macros: dwasdwasd;
    wasd;

    As a final request, for the day obviously hahaha, is there any ETA on the 230 shortcut limit bump? (you know i wont stop lol)
    this is from the other thread. I'm in agreement here on the moving the "Another cosmetic suggestion, making macros start in the line below of Macros: and not next to it. Because, enter does not create a line break if its the first line."

    Another thing I'd like to see is moving the screenshots folder. to either a subfolder (/SDCard/BlackBerry/Pictures/Shortcutme/) or some user definable location. The reason for this is because when it comes to backing up pictures I rarely have a need to backup screenshots, it'd be cool to just be able to del the folder as needed. And yes I know i could just have them saved to /SDCard/ but then they're still individual not nicely packed in a folder. Actually, even /SDCard/SCM_Screenshots/ or something like that would work nicely (aka better imo). Also, having a /Device/ option for saving would be cool to for users like ONE618 who for some crazy reason dont have an SDCard
    10-14-11 11:42 PM
  21. Vijik's Avatar
    Is there some way to backup SCM to the device instead of SD?

    I have to reset the OS to test if ift has to go in for repair, and I don't have an SD card
    No, unfortunately not currently.
    10-15-11 12:42 AM
  22. Vijik's Avatar
    Tonight I had plan to add many of the requests you guys asked for, but got caught in answering support emails for NFCLauncher app instead. (A customer who had problem with NFCLauncher but didn't want to upgrade to the new version I had on the server).

    As a result I had to released a new version of NFCLauncher.

    So I didn't got much time for ShortcutMe therefore the new version just have minor changes:


    ShortcutMe 5.9.1.4 is now ready on beta site:

    New in 5.9.1.4:

    * If AppName is not set for a shortcut, user gets a chance to go back to set it.

    * (new) Dialog boxes accept 'Y', 'N', 'C' and 'S' shortcuts (Just see what character has '_')
    10-15-11 12:53 AM
  23. TomCanuck's Avatar
    Tonight I had plan to add many of the requests you guys asked for, but got caught in answering support emails for NFCLauncher app instead. (A customer who had problem with NFCLauncher but didn't want to upgrade to the new version I had on the server).

    As a result I had to released a new version of NFCLauncher.

    So I didn't got much time for ShortcutMe therefore the new version just have minor changes:


    ShortcutMe 5.9.1.4 is now ready on beta site:

    New in 5.9.1.4:

    * If AppName is not set for a shortcut, user gets a chance to go back to set it.

    * (new) Dialog boxes accept 'Y', 'N', 'C' and 'S' shortcuts (Just see what character has '_')
    Using. 5.9.1.4_OS7_T on 9900/7.0.0.440
    Dude! That prompt when App Name isn't entered is awesome!
    Pressing "Y" to save changes doesn't work, neither does "n" to exit without saving. Also the "c" for cancel isn't underlined

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Juggalo20; 10-15-11 at 05:32 AM.
    10-15-11 05:29 AM
  24. dimm0k's Avatar
    Using. 5.9.1.4_OS7_T on 9900/7.0.0.440
    Dude! That prompt when App Name isn't entered is awesome!
    Pressing "Y" to save changes doesn't work, neither does "n" to exit without saving. Also the "c" for cancel isn't underlined

    Posted from my CrackBerry at wapforums.crackberry.com
    Man you guys are fast! Nice updates with this beta, but as Juggalo20 noted there's a few little inconsistencies. Other than that, works great!
    10-15-11 10:13 AM
  25. TomCanuck's Avatar
    Man you guys are fast! Nice updates with this beta, but as Juggalo20 noted there's a few little inconsistencies. Other than that, works great!
    Vijik is the MAN for updates. I know of no other company that even comes close to Fonware for updated (even excluding betas) lol

    Posted from my CrackBerry at wapforums.crackberry.com
    Vijik likes this.
    10-15-11 10:15 AM
712 ... 678910 ...
LINK TO POST COPIED TO CLIPBOARD