01-14-13 07:27 AM
712 ... 23456 ...
tools
  1. gbsn's Avatar
    Damn me and my "requires a ton of work" thoughts >.< All for such minor inconviences ... I withdraw this request/suggestion lol.

    Posted from my CrackBerry at wapforums.crackberry.com
    Hahaha nonono, lets hear from vijik first, to see if what i remember is true.

    Suggestions keep this project aliiive :b and you have made some quite good ones.
    09-29-11 12:56 AM
  2. Vijik's Avatar
    Hahaha nonono, lets hear from vijik first, to see if what i remember is true.
    You remember it correctly.
    Suggestions keep this project aliiive :b and you have made some quite good ones.
    Agree!

    Consider the "ESC key = Cancel" request as done. I will make it like BB OS.
    Right now, I am very busy adding the requested Sum, Sub, Mult and Div macro.

    It is difficult to add them because users should be able to use these new macros in 'If' and 'While' loop as well as in other macros.
    09-29-11 05:04 PM
  3. TomCanuck's Avatar
    You remember it correctly.


    Agree!

    Consider the "ESC key = Cancel" request as done. I will make it like BB OS.
    Right now, I am very busy adding the requested Sum, Sub, Mult and Div macro.

    It is difficult to add them because users should be able to use these new macros in 'If' and 'While' loop as well as in other macros.
    Well if gbsn remembers correctly that sounds like a heck of a lot of work for such a minor thing lol. Don't sweat it man if it's a ton of work to make EscKey = Cancel.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-29-11 05:08 PM
  4. Vijik's Avatar
    Well if gbsn remembers correctly that sounds like a heck of a lot of work for such a minor thing lol. Don't sweat it man if it's a ton of work to make EscKey = Cancel.

    Posted from my CrackBerry at wapforums.crackberry.com
    No worries. I actually have already changed the app and the "Esc Key= Cancel" is working now on the new version I am working on.
    I also got Sum, Sub, Mult and Div macros to work.

    Div currently returns an integer value as result and an integer value as Rest.
    Div 5,2; /*Sets $$Result to 2, and $$Rest to 1 */

    Posted from my CrackBerry at wapforums.crackberry.com
    09-30-11 08:45 AM
  5. Jaji_vzw8330's Avatar
    Vijik I have a serious problem. I reinstalled my OS today and when trying to restore my SCM configuration I get 0Shortcuts,0Altshortcuts, etc. Then it tells me I am reading a file that was created by SCM 3.0.0.4 or earlier and i need to copy AppName into Display name.

    What does this mean? Are you telling me I have to reconfigure this whole thing?
    09-30-11 06:26 PM
  6. Vijik's Avatar
    Vijik I have a serious problem. I reinstalled my OS today and when trying to restore my SCM configuration I get 0Shortcuts,0Altshortcuts, etc. Then it tells me I am reading a file that was created by SCM 3.0.0.4 or earlier and i need to copy AppName into Display name.

    What does this mean? Are you telling me I have to reconfigure this whole thing?
    That message pops up when you try to load a config file created by very old version of ShortcutMe into a newer version.
    (I am at a party and don't have access to the source code, so I can't tell you exactly what version).
    Are you sure you have only done an OS upgrade? (Do you have the same uSD card, same version of ShortcutMe, when did you store your settings last time?).

    Posted from my CrackBerry at wapforums.crackberry.com
    09-30-11 07:03 PM
  7. Jaji_vzw8330's Avatar
    That message pops up when you try to load a config file created by very old version of ShortcutMe into a newer version.
    (I am at a party and don't have access to the source code, so I can't tell you exactly what version).
    Are you sure you have only done an OS upgrade? (Do you have the same uSD card, same version of ShortcutMe, when did you store your settings last time?).

    Posted from my CrackBerry at wapforums.crackberry.com

    I have 5.1.0.0_T installed. The message says 3.0.0.4. The file is on the same SD card. The file is there and when I open it as a txt doc I can see all the shortcuts are there. I just need to get them restored. Take your time and thanks for your help!

    EDIT: Oh yeah, I wiped my berry before the install if that matters. But I usually do it this way and never had a problem. Thanks again!
    09-30-11 07:07 PM
  8. Vijik's Avatar
    I have 5.1.0.0_T installed. The message says 3.0.0.4. The file is on the same SD card. The file is there and when I open it as a txt doc I can see all the shortcuts are there. I just need to get them restored. Take your time and thanks for your help!

    EDIT: Oh yeah, I wiped my berry before the install if that matters. But I usually do it this way and never had a problem. Thanks again!
    EDIT: Doesn't matter if you are wiping your BB. The setting files are stored on uSD card. You only loose them if you wipe the uSD card.


    I checked the source code. The only way you can get this message
    "Looks like that you are reading from a file that was created by ShortcutMe 3.0.0.4 or earlier. You need to copy AppName into the Display Name, otherwise you will see many empty shortcut items. Proceed with copying?" is when you load a config file created with an very old version of ShortcutMe.
    Check the files on your uSD card, see if you find files called
    "shortcutmelatestconfig.txt" and "shortcutmeconfig.txt"

    Make a copy of them on your PC.
    Replace all the personal info (phone number, email address, passwords, etc) with xxx and then send both of those files to support at fonware dot ca.
    I will check it for you.

    Do you know that upgrading to 5.8 series is free if you already have version 5.x?
    Last edited by Vijik; 09-30-11 at 10:16 PM.
    09-30-11 10:12 PM
  9. Vijik's Avatar
    I just released version 5.8.4.0 for 9900/9930, 9810, 9850, and 9860.

    New in 5.8.4.0:

    * && and || is now allowed for IF and WHILE macro statement
    Example: If0 $Var1 && IsAppRunning Memopad;Then0; ... ; Else0; ... ;EndIf0;

    * ‘Prompt’ macro accepts variables
    Example: Prompt $Var;

    * ‘Prompt’ macro also allows you to continue with the macros or stop them.

    * Added ‘GetUpTime’ macro
    Returns up time in hhmmss format where hh is hour, mm is minutes, and ss is seconds after the device is turned on.

    * Added ‘GetTime’ macro
    Returns time in hhmm format where hh is hour, and mm is minutes of the day.

    * Added ‘GetDay’ and ‘GetMonth’ macros.
    Return format is a 2 digits number

    * Added ‘Sum’, ‘Sub’, ‘Mult’, and ‘Div’ macros
    Result of these math operations is stored in $$Result (case sensitive) variable.
    $$Rest variable is set to the rest of the Div operation over 2 numbers.

    Example:
    Set $Var1=3;
    Sum 2, $Var1;
    Prompt $$Result; (5 will be shown).
    Div 7,$Var1;
    Prompt Res:$$Result, Rest:$$Rest; ("Res:2, Rest:1" will be shown)


    * Removes ’ _’ from app names.

    * BB_OS-like exit from Shortcut Settings and Macro Editor page (ESC key = Cancel)


    Enjoy!
    Last edited by Vijik; 09-30-11 at 11:01 PM.
    TomCanuck likes this.
    09-30-11 10:41 PM
  10. TomCanuck's Avatar
    I just released version 5.8.4.0 for 9900/9930, 9810, 9850, and 9860.

    New in 5.8.4.0:

    * && and || is now allowed for IF and WHILE macro statement
    Example: If0 $Var1 && IsAppRunning Memopad;Then0; ... ; Else0; ... ;EndIf0;

    * ‘Prompt’ macro accepts variables
    Example: Prompt $Var;

    * ‘Prompt’ macro also allows you to continue with the macros or stop them.

    * Added ‘GetUpTime’ macro
    Returns up time in hhmmss format where hh is hour, mm is minutes, and ss is seconds after the device is turned on.

    * Added ‘GetTime’ macro
    Returns time in hhmm format where hh is hour, and mm is minutes of the day.

    * Added ‘GetDay’ and ‘GetMonth’ macros.
    Return format is a 2 digits number

    * Added ‘Sum’, ‘Sub’, ‘Mult’, and ‘Div’ macros
    Result of these math operations is stored in $$Result (case sensitive) variable.
    $$Rest variable is set to the rest of the Div operation over 2 numbers.

    Example:
    Set $Var1=3;
    Sum 2, $Var1;
    Prompt $$Result; (5 will be shown).
    Div 7,$Var1;
    Prompt Res:$$Result, Rest:$$Rest; ("Res:2, Rest:1" will be shown)


    * Removes ’ _’ from app names.

    * BB_OS-like exit from Shortcut Settings and Macro Editor page (ESC key = Cancel)


    Enjoy!
    Vijik... You are a king among men good sir... King amongt men. Just making a pot of coffee then on to testing. I'll update this post shortly, then off and on throughout the night

    Posted from my CrackBerry at wapforums.crackberry.com

    Update #1

    Upgrade from 5.8.3.1 -> 5.8.4.0 = success
    Clean install = success

    Restoring config made with 5.8.3.1 = success

    Sum, Sub, Mult, Div = success, even when using $$Result over and over in the same macro.

    Prompt with $var = success

    GetDay, GetTime, GetMonth, GetUptime = success.

    BBOS like behavior with the EscKey = success

    Removing _ from app names = Failure.
    I cannot "Launch FileScout" also I used to be able to launch it outside of macro using it as the App Name (without Alternative Launch), I can't do that anymore even with Alternative Launch.

    && and || = failure .. I think.
    Am I doing it correctly?
    If0 IsAppRunning testtest || IsAppRunning Messages;
    Then0;
    Vibrate200;
    Else0;
    Ding100;
    EndIf0;

    Tried it with && also, throws "Error reading integer number! (IfIsAppRunning testtest || IsAppRunning Messages)" if I remove the "|| IsAppRunning Messages" it works fine.

    Update #2
    On a clean install, go into Common Config. Restore a manually saved config. Press the EscKey, you will be prompted to save changes. If you choose "Yes" restoring will not take place. It seems you only get one shot at producing this error. If you manually "remove all" shortcuts, go into common config and enter "trial" as the license key, save changes, exit. Reopen Common Config, restore manually saved config, exit, I didn't get prompted again.

    Update #3
    Silly me, forgot to mention.... I'm on a 9900/7.0.0.353

    Update #4
    SetVolume either still doesn't work or I'm doing it wrong.
    Used it all by it's self in a macro,
    SetVolume100.
    Played a song in the native music player, launched the shortcut, didn't do anything. Made a phone call, launched the shortcut, didn't do anything.

    Update #6
    About the && and ||
    It does work with IsDefined so I guess I'm using IsAppRunning incorrectly
    Set $test1=1;
    set $test3=2;
    If0 IsDefined $test1 && IsDefined $test2;
    Then0;
    Vibrate300;
    Else0;
    SetLedColor g;
    Led On;
    Delay5000;
    Led Off;
    EndIf0;

    Update #7
    Soo....

    Set $test1=1;
    If0 IsDefined $test1 && IsAppRunning Messages;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0

    Works... But

    Set $test1=1;
    If0 IsAppRunning Messages && IsDefined $test1;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0

    Doesn't ... /confuse

    Update #8
    Set $test1=1;
    If0 IsDefined $test1 && IsAppForeground Messages;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0;

    Works, but...

    Set $test1=1;
    If0 IsAppForeground Messages && IsDefined $test1;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0;

    Doesn't :|
    Last edited by Juggalo20; 10-01-11 at 02:34 AM.
    09-30-11 10:44 PM
  11. Vijik's Avatar
    Vijik... You are a king among men good sir... King amongt men. Just making a pot of coffee then on to testing. I'll update this post shortly, then off and on throughout the night


    By the way remember that the number 0 is handled as FALSE for the statements with && and ||
    Any other number is handled like TRUE:

    "FALSE && 1" returns FALSE
    "TRUE && 0" returns FALSE
    "TRUE && 234" returns TRUE
    09-30-11 11:07 PM
  12. gbsn's Avatar
    I just released version 5.8.4.0 for 9900/9930, 9810, 9850, and 9860.

    New in 5.8.4.0:

    * && and || is now allowed for IF and WHILE macro statement
    Example: If0 $Var1 && IsAppRunning Memopad;Then0; ... ; Else0; ... ;EndIf0;

    * ‘Prompt’ macro accepts variables
    Example: Prompt $Var;

    * ‘Prompt’ macro also allows you to continue with the macros or stop them.

    * Added ‘GetUpTime’ macro
    Returns up time in hhmmss format where hh is hour, mm is minutes, and ss is seconds after the device is turned on.

    * Added ‘GetTime’ macro
    Returns time in hhmm format where hh is hour, and mm is minutes of the day.

    * Added ‘GetDay’ and ‘GetMonth’ macros.
    Return format is a 2 digits number

    * Added ‘Sum’, ‘Sub’, ‘Mult’, and ‘Div’ macros
    Result of these math operations is stored in $$Result (case sensitive) variable.
    $$Rest variable is set to the rest of the Div operation over 2 numbers.

    Example:
    Set $Var1=3;
    Sum 2, $Var1;
    Prompt $$Result; (5 will be shown).
    Div 7,$Var1;
    Prompt Res:$$Result, Rest:$$Rest; ("Res:2, Rest:1" will be shown)


    * Removes ’ _’ from app names.

    * BB_OS-like exit from Shortcut Settings and Macro Editor page (ESC key = Cancel)


    Enjoy!
    omfg.... Should have been 5.9 :b, pure epicness.

    This is a bug, that you can fix whenever you have the chance, not top priority. Its about the suspend macro and mediakeybooster stopmacro function. They dont go too well together, if MKB happens to stop SCM in the middle of a suspend, the next time you launch SCM it will say "macro stopped by a remote application" and thats good, but after pressing ok, it will continue with the rest of the macro as in "getting out" of the suspend and continuing with its normal routine, ignoring the stopmacro command from MKB.

    getmonth, returns incorrect for some reason, current month is 10 (october), returns 09 (september)
    getday, returns fine
    gettime, returns fine. Are the leading zeros not present so that the time is kept as an integer?

    These three macros take a bit long to return the values, is it on my phone only?

    I couldn't get to work any of these combinations of AND, if0 isdefined $suspend && $suspend!=0, or $suspend==1, or $suspend or $suspend==0, or $suspend==true.
    Last edited by gbsn; 10-01-11 at 03:34 AM.
    09-30-11 11:32 PM
  13. TomCanuck's Avatar
    Hahah. Fk me. I didn't even catch the getmonth... I just assumed it was the 08th month...

    Edit #1
    It's still September here, so getmonth, which is why I get 08 and not 09...

    Edit #2
    I do find it a bit strange about the gettime without leading zeros though, concidering the month has a leading zero. Getting "6" returned for gettime at 00:06 works (can't think of any scenario that it wouldn't), but just looks odd. Heh, no biggie though

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Juggalo20; 10-01-11 at 01:16 AM.
    10-01-11 12:47 AM
  14. Jaji_vzw8330's Avatar
    EDIT: Doesn't matter if you are wiping your BB. The setting files are stored on uSD card. You only loose them if you wipe the uSD card.


    I checked the source code. The only way you can get this message
    "Looks like that you are reading from a file that was created by ShortcutMe 3.0.0.4 or earlier. You need to copy AppName into the Display Name, otherwise you will see many empty shortcut items. Proceed with copying?" is when you load a config file created with an very old version of ShortcutMe.
    Check the files on your uSD card, see if you find files called
    "shortcutmelatestconfig.txt" and "shortcutmeconfig.txt"

    Make a copy of them on your PC.
    Replace all the personal info (phone number, email address, passwords, etc) with xxx and then send both of those files to support at fonware dot ca.
    I will check it for you.

    Do you know that upgrading to 5.8 series is free if you already have version 5.x?
    Well I upgraded and the reconfiguration worked. I'm not sure what happened because my last backup was August 7th. I don't even think I had v3 on this device.

    Anyway, thanks a lot for your help. Excellent product and excellent customer service as well. I truly appreciate your help.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 01:11 AM
  15. gbsn's Avatar
    Hahah. Fk me. I didn't even catch the getmonth... I just assumed it was the 08th month...

    Edit #1
    It's still September here, so getmonth, which is why I get 08 and not 09...
    You are getting 08 (august) for month?. So basically its delayed by one month in your phone and mine. I guess we just have to use the Inc macro to get it on the correct one :b
    10-01-11 01:43 AM
  16. TomCanuck's Avatar
    You are getting 08 (august) for month?. So basically its delayed by one month in your phone and mine.
    Yup, must be picking up January as 00

    Posted from my CrackBerry at wapforums.crackberry.com

    Update #1
    Tested and yeah, January comes up as 00
    Last edited by Juggalo20; 10-01-11 at 01:49 AM.
    10-01-11 01:45 AM
  17. Vijik's Avatar
    - GetMonth is using a Java class that returns months starting from 0 (January).
    Will fix this.

    - && , || is working by them self, but based on your tests it sounds like the macro engine currently doesn't run correct operator precedence. I will fix this so that it first look for && and || before braking the statement into pieces for further true/false check.
    10-01-11 06:47 AM
  18. Vijik's Avatar
    Okay, 5.8.4.1 is ready for download on the beta link (link ends with 10) If you don't have the link anymore send email to support at shortcutme dot com.

    5.8.4.1 allows you to have a statement for IF and WHILE macros. The statement syntax is like this:

    xxxxx && yyyyy (Only one '&&' or '||' can be used in one statement)
    xxxxx || yyyyy

    xxxxx and yyyyy can be a statement with all operators except && and ||

    If0 IfAppIsRunning Memopad && $Var==1;Then0;..... (OK)
    If0 1 && IfAppIsRunning Phone;Then0;..... (OK)

    GetMonth should now return the correct number

    (Mobihand has changed the developer portal. It is not anymore possible to just update the program without sending email to all users. So lets remove all the bugs for the new features and then I release it)
    10-01-11 10:02 AM
  19. TomCanuck's Avatar
    Okay, 5.8.4.1 is ready for download on the beta link (link ends with 10) If you don't have the link anymore send email to support at shortcutme dot com.

    5.8.4.1 allows you to have a statement for IF and WHILE macros. The statement syntax is like this:

    xxxxx && yyyyy (Only one '&&' or '||' can be used in one statement)
    xxxxx || yyyyy

    xxxxx and yyyyy can be a statement with all operators except && and ||

    If0 IfAppIsRunning Memopad && $Var==1;Then0;..... (OK)
    If0 1 && IfAppIsRunning Phone;Then0;..... (OK)

    GetMonth should now return the correct number

    (Mobihand has changed the developer portal. It is not anymore possible to just update the program without sending email to all users. So lets remove all the bugs for the new features and then I release it)
    I can now launch Filescout from the App Name or from "launch Filescout" but I cannot IsAppRunning or IsAppForeground for filescout. I also tried com_emacberry_FileScout (which I grabbed from the JVM Process list in the Engineering Screen)

    Still testing, so more updates to follow...

    Posted from my CrackBerry at wapforums.crackberry.com

    Update #1
    I broke && again sorry

    Set $test1=1;
    If0 IsDefined $test1 && $test1==1;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0;

    Just to be sure I also tried

    Set $test1=1;
    If0 IsDefined $test1 && $test1=1;
    Then0;
    Vibrate300;
    Else0;
    Ding100;
    EndIf0

    Using 9900/7.0.0.353

    Update #2
    I also tried || from update #1, doesn't work.

    Getmonth does return the correct month now though (10)

    SetVolume doesn't work (or I'm using it wrong?) Opened a song in native media player, turned down the volume, ran the macro. Nothing happened. The same goes for making a phone call.

    Update #3
    This still exists also:
    On a clean install, go into Common Config. Restore a manually saved config. Press the EscKey, you will be prompted to save changes. If you choose "Yes" restoring will not take place. It seems you only get one shot at producing this error. If you manually "remove all" shortcuts, go into common config and enter "trial" as the license key, save changes, exit. Reopen Common Config, restore manually saved config, exit, I didn't get prompted again.
    Last edited by Juggalo20; 10-01-11 at 11:03 AM.
    10-01-11 10:30 AM
  20. Vijik's Avatar
    Okay. I will run your macro in debugger to find out why it doesn't decode correctly.

    Run filescout in background, then use MediaKeyBooster ("Add App to the List" button) to find out what filescout really called.
    Use that for IsAppRunning and see if it works.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 11:47 AM
  21. TomCanuck's Avatar
    Okay. I will run your macro in debugger to find out why it doesn't decode correctly.

    Run filescout in background, then use MediaKeyBooster ("Add App to the List" button) to find out what filescout really called.
    Use that for IsAppRunning and see if it works.

    Posted from my CrackBerry at wapforums.crackberry.com
    MediaKeyBooster calls it FileScout. If I use the button in MKB to add Filescout it picks it up as a blacklisted app (not Filescout thought) BUT! If I copy paste Filescout from the MKB blacklist I can paste it into SCM and it works for IsAppForeground and IsAppRunning. Which is pretty cool.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 11:54 AM
  22. Vijik's Avatar
    Good.
    That means I should be able to fix this by looking into what I wrote for MediaKeyBooster app.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 11:58 AM
  23. TomCanuck's Avatar
    If anyone reading this knows any third party apps that have their Home Screen hotkey not at the start of their name please let me know. The only one I know of is BBNotePad, need moar for testing purposes. Also, the hotkey needs to actually be part of it's name, not like BerryWeather, which has the hotkey seperate "BerryWeather (w)" I mean something like Application

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 12:10 PM
  24. Vijik's Avatar
    ShortcutMe 5.8.4.2 is ready to be downloaded from the beta link.

    It should solve the bug (in 5.8.4.1) related to decoding of the IF/WHILE statements with 'IsDefined' macro.

    'IsAppRunning' and 'IsAppForeground' macros should now be able to detect apps with '_' in their name.
    10-01-11 05:14 PM
  25. TomCanuck's Avatar
    ShortcutMe 5.8.4.2 is ready to be downloaded from the beta link.

    It should solve the bug (in 5.8.4.1) related to decoding of the IF/WHILE statements with 'IsDefined' macro.

    'IsAppRunning' and 'IsAppForeground' macros should now be able to detect apps with '_' in their name.
    Nice Filescout launchs properly, and works with IsAppRunning and IsAppForeground.
    I haven't been able to break || or &&

    Looks like the only two issues are the restore config from thr Common Config page the first try after clean install, and SetVolume

    Posted from my CrackBerry at wapforums.crackberry.com
    10-01-11 07:58 PM
712 ... 23456 ...
LINK TO POST COPIED TO CLIPBOARD