1. jostrat21's Avatar
    Ok, so if you do not want to see the connection permission message each time you first load opera mini, then you can enable the firewall.

    Either enabling the firewall or something else causes the "java.lang.illegalArgumentException" message when trying to run quickpull. If you change the permissions to the email setup application to "allow," then quickpull mysteriously runs without a hitch.

    However, for whatever reason, once you do that the connection permission message pops up again each time you launch opera mini (even though the firewall is still enabled).

    What is going on here?

    I've always had my firewall enabled and I've never had a problem with quickpull until recently. I don't know if it's quickpull v2 that is causing the issue or OS .148. I cannot find a link anywhere to download an older version of quickpull, does anyone have one (or the old files from a previous installation on their computer)?

    For now I'm just using memory eye to get around the problem, but I miss having the scheduling option from quickpull.

    Either way I am confused as to why changing the permissions of the email setup application effect the firewall and quickpull.
    07-02-09 10:42 AM
  2. JRSCCivic98's Avatar
    Opera Mini is a non-signed app. It'll always trigger that prompt.
    07-02-09 10:50 AM
  3. jostrat21's Avatar
    Opera Mini is a non-signed app. It'll always trigger that prompt.
    Right, unless you have your firewall enabled. It's been that way for me ever since OS 4.3.

    The only time the message reappeared with my firewall still enabled was after I changed all of the default permissions of the email setup application to allow (and I only did that because of the "java.lang.illegalArgumentException" error I was getting from quickpull).
    07-02-09 10:56 AM
  4. JRSCCivic98's Avatar
    Are you sure you changed the permissions of just that app and not the "Default Permission" for ALL apps? You can easily mess that up because the menu options are all that clear. Also, there's no reason to chagne the permissions for the email setup app... it works just fine.
    07-02-09 10:58 AM
  5. jostrat21's Avatar
    Are you sure you changed the permissions of just that app and not the "Default Permission" for ALL apps? You can easily mess that up because the menu options are all that clear. Also, there's no reason to chagne the permissions for the email setup app... it works just fine.
    Changing the default permissions was the only way I could get quickpull to run (with the firewall enabled). In doing so, however, it brought back the prompt in OM.

    I never had a problem with OM/my firewall/quickpull until recently. I don't know if it's a quickpull issue (never had a glitch prior to v2), an OS issue (never had a glitch prior to .148), or what?

    I can confirm for you that, without messing with any permission settings, quickpull v2 will run for me without a glitch, so long as I have my firewall disabled. Without doing anything else except enabling my firewall, quickpull will give me an uncaught exception message. Obviously it has something to do with the firewall, I just don't understand why this wasn't an issue either with an earlier version of quickpull or with an OS previous to .148.

    I realize it's not a big deal either way, but I use OM pretty much exclusively for my browser, so it's annoying to get that prompt every time I load it for the first time. The only way to rid of that prompt is by enabling my firewall. I also like sheduling quickpull every night, but it won't work unless I have my firewall disabled or I change the default permissions (which is moot due to the OM issue). Either way, it's a small gripe, but I've been able to have my firewall enabled without any quickpull issues in the past. I guess I could just leave OM running all the time...I just get frustrated when things don't work the way I want them to (especially when they have before).
    Last edited by jostrat21; 07-02-09 at 11:19 AM. Reason: Forgot to mention something
    07-02-09 11:06 AM
  6. JRSCCivic98's Avatar
    Well, it's either a bug with Quickpull/OS version or it's a messed up setting you have. I would maybe do a backup of your phone and try a Security Wipe (just wipes your settings). Then install just Quickpull and turn on the firewall and see if the error pops up again. Maybe I'll try turning on my firewall and see if Quickpull gives any errors.
    07-02-09 11:34 AM
  7. jostrat21's Avatar
    Well, it's either a bug with Quickpull/OS version or it's a messed up setting you have. I would maybe do a backup of your phone and try a Security Wipe (just wipes your settings). Then install just Quickpull and turn on the firewall and see if the error pops up again. Maybe I'll try turning on my firewall and see if Quickpull gives any errors.
    Yea I probably will do that. I just wiped & reloaded 148 last week. I seem to reload my os every other week for some reason & I think it gave me the error right away but I can't be sure. Can you do me a favor & see what happens when you try to reboot via quickpull after enabling your firewall?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-09 11:51 AM
LINK TO POST COPIED TO CLIPBOARD