1. jrcasco's Avatar
    I'm trying to download the blackberrry apps world but I get a error message saying my "device does not meet the system requirements".However the system requirements are 4.2 or higher and my bb bold has 4.6,help!!!
    07-11-09 10:59 PM
  2. dragonsamus's Avatar
    Do you have the bb data plan?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-11-09 11:49 PM
LINK TO POST COPIED TO CLIPBOARD