1. larrymcj's Avatar
    Has anyone been successful getting QuickPull or QuickPull Pro to work on their Tour with OS 5.0.591? I tried the Beta 2 version that Steelthorn has on their site that is supposedly for "only" OS 5.0 and though it installs, every time I try a RESET it just hangs up. Of course, Steelthorn support is non-existent. I have the Pro version and would sure like to be able to use it again.
    03-31-10 04:43 PM
  2. recout's Avatar
    I am having the same problem with my quick pull pro....
    03-31-10 06:59 PM
  3. bb_craze's Avatar
    My doesn't work either..
    03-31-10 07:01 PM
  4. Terradactyl's Avatar
    Mine doesn't work either so I deleted it. Now I have to find another way to simulate a battery pull since I have an otterbox on my phone and it is too hard to take off.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-31-10 07:15 PM
  5. pr1nce's Avatar
    I'm having the same problem. I also installed the beta version from the Steelthorn site. It was supposed to work with OS 5.0 but it doesn't work.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-31-10 07:47 PM
  6. PDM's Avatar
    It wont work (yet)...

    QP won't work on OS builds. This is a RIM bug that can't be fixed by us. OS builds should work tho
    03-31-10 07:53 PM
  7. joggy's Avatar
    Does the Alt+Shift+Del key combo still work at least?

    I'm on the fence making an upgrade decision from 4.7 to 5.0.591 mainly due to this problem with Quickpull/RIM bug as noted. Having a Seidio case on makes it inconvenient for a physical battery pull.
    04-01-10 06:11 AM
  8. anon(3214719)'s Avatar
    I'm using quickpull free v3.7.2 with .591 without issues.

    04-01-10 06:32 AM
  9. ksb63's Avatar
    Mine is hanging on the scheduled restart get the restart in 5 sec then goes to the restart required click to restart now/later screen. will restart if you say restart now but this defeats the scheduled while your asleep restart. (3.7.2 pro and free both do this)
    04-01-10 06:39 AM
  10. joggy's Avatar
    Hmmm, so is it just the Scheduled restarts that don't work? A forced Reset via QP works? I can live with that if so.
    04-01-10 07:08 AM
  11. Terradactyl's Avatar
    forced reset did not work for me either. It gets hung up on the "your device will reboot in 5 seconds" screen then gives me an error about a minute later
    04-01-10 07:35 AM
  12. joggy's Avatar
    I downloaded the beta 3.9.2 from Steelhorn's site and it seems to work without a problem on .591. This is a forced Reset though, not Scheduled.
    04-01-10 10:32 AM
  13. Turbaru's Avatar
    I am running 3.7.2 and it works but I have to click on "restart now". Before it would do it on its own.
    04-01-10 10:38 AM
  14. 2_BCs's Avatar
    I just re-installed and got version - it is hanging on the restart required screen too...
    04-01-10 11:00 AM
  15. retnuh#CB's Avatar
    I am having the same problem and ran across this on Steelthorn's page about OS 5:

    How to use QuickPull on OS 5.0
    Article ID: 26
    Last updated: 18 Nov, 2009
    Export to PDF
    Email to friend
    Views: 23147

    This article will help you install the QuickPull for OS 5 Technical Preview (Beta2).

    * UPDATED with instructions for Beta2 *


    You must meet the following requirements to use QuickPull on OS 5:

    • A BlackBerry device running OS No lower version will work. To check your OS version, go to Options > About menu on your device.
    • Ability to grant requested permission on your device.


    Please go to Options > Advanced > Applications. Scroll down to QuickPull in the list, then press the Menu key and select Delete. Reset your device.

    To install QuickPull Beta2 for OS 5, browse to one of the following links from your BlackBerry device:

    http://files.steelthorn.com/labs/OS5/pro/QuickPull.jad (QuickPull Pro)
    http://files.steelthorn.com/labs/OS5/QuickPull.jad (QuickPull Free)

    Immediately after installation, you will receive a series of prompts to grant "Trusted Application Status" to several components of QuickPull. Any time you see one of these dialogs, always choose YES to grant it Trusted Application status.


    QuickPull will request certain permissions on first run. If you are having problems with QuickPull Beta2, do these steps to eliminate any permissions related problems:

    1. Go to Options > Applications and highlight QuickPull in the list.
    2. Press Menu > "Edit Permissions".
    3. Set all three categories to "Deny".
    4. Menu > Save.
    5. Repeat steps 1-4 but set all permissions to "Allow".
    6. Do a real battery pull.
    04-01-10 12:43 PM
  16. rgunturi's Avatar
    thanks!! i will try those settings and see if it will work
    04-01-10 01:50 PM
  17. retnuh#CB's Avatar
    I followed their directions yesterday and my scheduled reboot seems to have worked this morning without anything popping up or additional direction needed.
    04-02-10 06:37 AM
  18. rgunturi's Avatar
    if you set the permissions to "deny", after the reboot, it says that quickpull is requesting changes to the permissions. Do I just say Deny here too? Will the program work if all the permissions are set to deny?
    04-02-10 11:21 AM
  19. brentc's Avatar
    I gave up on quickpull and just use the "reboot device" feature of quicklaunch. Works the same without the schedule feature. Sucks, because I just paid for quickpull pro.
    04-02-10 10:38 PM
  20. mikemyu's Avatar
    I give up on quickpull too. I followed the directions but still nothing and I keep getting this message about "uncaught java exception blah blah blah" I just went ahead and deleted quickpull. I even downloaded the 3.9 something version from the above link. I'll just do a hard reset manually myself.
    04-03-10 01:01 AM
  21. saintjah's Avatar
    Mine does this or something similar, and it is not a real quick pull simulation, this is just the phone doing a regular reboot thinking that it is settling in/installing a new program. Even though after rebooting quickpull comes up and says it worked, I feel that this is just a generic message dialogue programmed in to pop up after reboot and the simulation did not actually succeed.

    Mine is hanging on the scheduled restart get the restart in 5 sec then goes to the restart required click to restart now/later screen. will restart if you say restart now but this defeats the scheduled while your asleep restart. (3.7.2 pro and free both do this)
    04-05-10 04:47 PM
  22. Floont's Avatar
    Gave up on Quickpull after the 5.0 upgrade. Alt + Right Shift + Del works well and works instantly and without any special app.

    However, you may need extra fingers to press the 3 keys simultaneously while holding your BB in one hand.

    04-05-10 05:42 PM
  23. mileaway's Avatar
    Quick Pull is a rip-off, CS is all but non existent on this issue.
    They suggest blame belongs to RIM.
    What a bunch of bull****! They advertise a version for use with OS 5.0, no other disclaimers until one goes in search of support on their website.
    04-13-10 06:09 PM