11-17-12 02:02 AM
322 ... 10111213
tools
  1. Vijik's Avatar
    there isnt any such icon.
    I have found out that, if icon "E" is hidden, the hotkey doesn't work.
    if does work if icon is unhidden. But clicking on the icon, wheather hidden or unhidden, works fine.

    Sent from my Playbook using Tapatalk
    Thanks for the info.

    I did install MOHK 1.3.5.1 on a brand new 9900 (owned by a friend) and (after a reset) all hotkeys were working including E. So MOHK managed to override all default hotkeys.

    I did not hide any icon, but just moved them to the bottom ofas the main page of Home Screen so that they did not botter me.

    Regrding hiding icons: you should always be prepared to unhide an icon or more if BB OS gets stabborn and doesn't let MOHK to override its hotkeys.
    09-21-12 07:39 AM
  2. JAKrzysztow's Avatar
    First, I did have the "E" icon. It was not hidden.

    So, I removed the entire program and all associated home icons. Rebooted. Install again from AppWorld, rebooted. And all is well.

    So something happened in regards to the update from 1.3.5.0 to 1.3.5.1.
    09-21-12 10:36 AM
  3. JAKrzysztow's Avatar
    First, I did have the "E" icon. It was not hidden.

    So, I removed the entire program and all associated home icons. Rebooted. Install again from AppWorld, rebooted. And all is well.

    So something happened in regards to the update from 1.3.5.0 to 1.3.5.1.
    I spoke too quick! It worked for a bit and it once again not working. If I select the shortcut from the Home screen, it works, but if I press "E", it does not.

    Could it be something in the configuration of the previous version?
    09-21-12 12:04 PM
  4. netwerx1's Avatar
    Are there any plans to possibly allow changes to the font and display style of the popup multiclick menu? I would probably use multiclick if it displayed with the normal system font instead of Comic Sans and had a nice clean display with transparency to better integrate with the look of the OS. Or is that already there and I'm missing it?
    09-21-12 04:31 PM
  5. Vijik's Avatar
    I spoke too quick! It worked for a bit and it once again not working. If I select the shortcut from the Home screen, it works, but if I press "E", it does not.

    Could it be something in the configuration of the previous version?
    1- When it stops working, do you see E icon in BB Home Screen (hided? moved?)?

    2- What is the settings for E hotkey in MOHK when it is working and when it stops working?
    09-22-12 11:57 AM
  6. JAKrzysztow's Avatar
    1- When it stops working, do you see E icon in BB Home Screen (hided? moved?)?

    2- What is the settings for E hotkey in MOHK when it is working and when it stops working?
    Here's what I know....

    Removed MOHK. Rebooted. Installed MOHK. E works.

    Load existing configuration. E works.

    Reboot. E stops working.

    The shortcut is in a folder, but I also tried at "root". Neither matter. Not hidden.

    I sent my configuration Friday I believe, but will be happy to send again.

    Is there a way to get the configuration in human understandable format? Print to HTML or some such?
    09-24-12 10:49 AM
  7. JAKrzysztow's Avatar
    Was wondering if any progress has been made? Or if I can provide more information?
    09-26-12 11:47 AM
  8. Vijik's Avatar
    Here's what I know....

    Removed MOHK. Rebooted. Installed MOHK. E works.

    Load existing configuration. E works.

    Reboot. E stops working.

    The shortcut is in a folder, but I also tried at "root". Neither matter. Not hidden.

    I sent my configuration Friday I believe, but will be happy to send again.

    Is there a way to get the configuration in human understandable format? Print to HTML or some such?
    When E stops working it doesn't help by just moving it out of folder and test E hotkey.

    Do the followings:
    Move E icon out of the folder and place it somewhere at the bottom of the BB Home Screen.
    Then do a battery pull restart and test E hotkey. If it works don't move it to a subfolder, leave it in the main page of the BB Home Screen.
    09-26-12 07:31 PM
  9. JAKrzysztow's Avatar
    When E stops working it doesn't help by just moving it out of folder and test E hotkey.

    Do the followings:
    Move E icon out of the folder and place it somewhere at the bottom of the BB Home Screen.
    Then do a battery pull restart and test E hotkey. If it works don't move it to a subfolder, leave it in the main page of the BB Home Screen.
    I have moved them all to the BB Home Screen and after the battery pull, E works.

    Wish it worked in the folder like I had it since I've started using MOHK, but such it life I guess.
    09-27-12 09:40 AM
  10. Vijik's Avatar
    I have moved them all to the BB Home Screen and after the battery pull, E works.

    If only E hotkey stops working after a while, just make sure that E icon is in the BB Home Screen. You don't need to have all the MOHK icons in the Home Screen.

    Wish it worked in the folder like I had it since I've started using MOHK, but such it life I guess.
    Or "so is BB OS".

    MOHK works within the BB OS framework which has its limitations (and good features). Forcing BB OS to forget about its own hotkeys is not an easy task, but now can be done with MOHK. You just need to be prepared to fight the trouble making hotkeys using MOHK icons in the BB Home Screen.
    09-27-12 10:10 AM
  11. JAKrzysztow's Avatar
    MOHK works within the BB OS framework which has its limitations (and good features). Forcing BB OS to forget about its own hotkeys is not an easy task, but now can be done with MOHK. You just need to be prepared to fight the trouble making hotkeys using MOHK icons in the BB Home Screen.
    Yes, one more device to bend to my will!

    Actually, moving them made a couple of others that never worked, work, so...

    Between MOHK and ShortCutMe, I rarely use the Home Screen anyway, just the top few icons, so not really a big deal like it was once.....

    Thanks for being persistent! I know I can be dense at times!

    Jeffrey
    Vijik likes this.
    09-27-12 11:36 AM
  12. Claidheamhmor's Avatar
    Thanks for the posts about "E" - it was driving me nutty! I unhid the MOHK_E icon, and it works now.

    I have a funny one: both U and C are set to open Unit Converter Pro. When I press C, Unit Converter Pro opens. When I press C, the calculator opens. I've unhidden both icons.
    10-03-12 06:34 AM
  13. JAKrzysztow's Avatar
    Well, my "E" key, is once again not functioning. Has been for quite a bit now, but I recently updated the Bridge and Playbook and now noticed, the "E" key fails (not saying the update did anything - other than they we recent changes).

    All shortcuts are in Home, none are hidden and the icons themselves behave.

    I do have a new icon: "mohk__27(ad...", the image is a black rectangle with "?" in the middle.
    10-03-12 04:20 PM
  14. Vijik's Avatar
    @JAKrzysztow and @Claidheamhmor

    Unhide and move all the MOHK icons to the bottom of the BB Home Screen, then do a battery pull restart and see if MOHK can claim all hotkeys back from the OS (with new apps on it).
    10-06-12 08:38 AM
  15. JAKrzysztow's Avatar
    @JAKrzysztow and @Claidheamhmor

    Unhide and move all the MOHK icons to the bottom of the BB Home Screen, then do a battery pull restart and see if MOHK can claim all hotkeys back from the OS (with new apps on it).
    All of the MOHK icons are already at the BB Home Screen and on the bottom. I do have an addition "icon" "mohk_27(address...". This has no assigned icons like the rest. And the only key that fails is "E". The "mohk_4(e)" icon does work, but not the key shortcut.
    10-08-12 10:31 AM
  16. Vijik's Avatar
    Mohk_27 is a bug. It shouldn't be there.
    I fixed that in a new version that was submitted to App World yesterday.

    If E hotkey doesn't launch your E setting in MOHK, it means another app or the BB OS holds the E hotkey.
    10-08-12 11:48 AM
  17. berriac's Avatar
    I have installed dD_Metro theme and it does not allow to override some hotkeys with MyOwnHotKeys.how should I claim back the hotkeys?
    10-08-12 12:00 PM
  18. JAKrzysztow's Avatar
    Mohk_27 is a bug. It shouldn't be there.
    I fixed that in a new version that was submitted to App World yesterday.

    If E hotkey doesn't launch your E setting in MOHK, it means another app or the BB OS holds the E hotkey.
    What will the new version number be?

    Not sure what could be doing this....what DOES happen it the MOHK configuration screen is shown with no key configuration preselected.
    10-08-12 02:45 PM
  19. JAKrzysztow's Avatar
    The update has fixed both issues...so far...fingers crossed it stays!
    10-10-12 12:59 PM
  20. Vijik's Avatar
    I have installed dD_Metro theme and it does not allow to override some hotkeys with MyOwnHotKeys.how should I claim back the hotkeys?
    Themes might get presidence in owning hotkeys.
    What hotkey does that theme take from MyOwnHotkeys?
    10-10-12 01:17 PM
  21. Vijik's Avatar
    What will the new version number be?

    Not sure what could be doing this....what DOES happen it the MOHK configuration screen is shown with no key configuration preselected.
    "No key configuration preselected" ? Please elaborate.
    10-10-12 01:19 PM
  22. Vijik's Avatar
    The update has fixed both issues...so far...fingers crossed it stays!
    The update (1.3.2.0) has a fix for mohk_27 icon you used to see.
    No fixes for E hotkey as I can't reproduce the E hotkey bug. So, I assume you might loose E hotkey again.

    Do you have a 3rd party theme on your BB?
    10-10-12 01:22 PM
  23. JAKrzysztow's Avatar
    First, this is all fixed.

    Second, screen is just the like running the main MyOwnHotKey icon directly.
    10-10-12 03:44 PM
  24. JAKrzysztow's Avatar
    First, this is all fixed.

    Second, screen is just the like running the main MyOwnHotKey icon directly.
    10-10-12 03:44 PM
  25. berriac's Avatar
    Themes might get presidence in owning hotkeys.
    What hotkey does that theme take from MyOwnHotkeys?
    Hi Vijik

    I cannot override the following keys :
    e = camera
    J = manage connections
    V = saved messages
    p = clock (though it is not mentioned in the theme)
    App world and google talk hotkeys don't work for me from the beginning. It is not the issue in this theme. Although G is set as Google Talk (and it works)in this theme, but I can override the G hotkey. If I select G (or any other hotkey) as google talk from MyOwnHotkey, then it stops working. same is the case with app world. nothing happens after pressing the hotkey.
    Last edited by berriac; 10-11-12 at 02:09 AM.
    10-11-12 01:08 AM
322 ... 10111213
LINK TO POST COPIED TO CLIPBOARD